Jump to content
Калькуляторы

мультикаст убивает сеть

Доброго времени суток!

 

Помогите, пожалуйста, разобраться с ситуацией...

 

У меня два каталиста: 3550 и 2960, соединены гигабитом. 2960 идет гигабитом в iptv сервер, который постоянно вещает 120 мегабит каналов. 3550 идет гигабитом в ядро сети, где собственно и есть потребители iptv. Их скорость такова, что больше одного канала одновременно никто смотреть не сможет.

Остальные все порты каталистов - сотки. Везде включен igmp snooping. Влан в котором сидит iptv сервер затерминирован на 3550 каталисте и в ядро не идет. В ядро мультикаст идет по L3 через multicast routing. Режим sparse-mode. Точка рандеву 3550 каталист.

Все работает. Но!

 

Бывают ситуации, когда на какой-то из стомегабитных портов ВДРУГ начинает идти ВЕСЬ iptv поток, забивая сотку... Ситуация легко воспроизводится.

От 2960 каталиста идет линк ко мне на стол на мой 2950 каталист. На нем кстати тоже включен igmp snooping. В порт 2950 каталиста втыкаю adsl модем (без линии конечно) tplink и... все. На этот порт начинает идти ВЕСЬ iptv поток. Такое ощущение, что модем подписывается на все каналы! Тоже самое у меня бывало и с самыми невинными устройствами типа контроллера двери, ip телефона... Еще обнаружил, что если на каталистах включен stp, то пока поднимается trunk порт, по нему в течение какого-то периода времени тоже идет весь iptv поток. Пришлось выключить stp.

 

Софт на каталистах перешивал, каталисты менял... Может я что-то фундаментальное не понимаю?

Share this post


Link to post
Share on other sites

Отзеркальте себе порт и посмотрите IGMP трафик через tcpdump, на своём настольном стенде.

 

 

Share this post


Link to post
Share on other sites

Отзеркальте себе порт и посмотрите IGMP трафик через tcpdump, на своём настольном стенде.

 

делал... ничего подозрительного, просто вдруг начинает идти весть поток. Без IGMP подписки...

Share this post


Link to post
Share on other sites

querier на 3550 включен?

 

т.е.? он сам и есть querier для того влана где вещается IPTV

Share this post


Link to post
Share on other sites

Конфиг 2950/2960 в студию!

Edited by CLI

Share this post


Link to post
Share on other sites

sh ip igmp snooping с 3550:

 

Global IGMP Snooping configuration:
-----------------------------------
IGMP snooping              : Enabled
IGMPv3 snooping (minimal)  : Enabled
Report suppression         : Enabled
TCN solicit query          : Disabled
TCN flood query count      : 2
Last Member Query Interval : 1000

Vlan 1:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 5:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 6:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 7:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 8:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 9:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 11:
--------  
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 12:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 15:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 16:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 17:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 19:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 23:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 24:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 25:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 27:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 28:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 29:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 50:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 71:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 93:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 94:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 95:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 100:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 299:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 399:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 402:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 404:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 405:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 599:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 601:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY
Vlan 1000:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
Source only learning age timer      : 10
CGMP interoperability mode          : IGMP_ONLY

 

sh ip igmp snooping c 2960:

 

Global IGMP Snooping configuration:
-----------------------------------
IGMP snooping              : Enabled
IGMPv3 snooping (minimal)  : Enabled
Report suppression         : Enabled
TCN solicit query          : Disabled
TCN flood query count      : 2
Last Member Query Interval : 1000

Vlan 1:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 5:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 6:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 7:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 8:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 9:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 11:
--------  
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 12:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 15:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 16:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 17:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 19:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 23:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 24:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 25:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 27:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 28:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 29:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 50:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 71:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 93:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 94:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 95:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 100:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 299:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 399:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 402:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 404:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 405:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 599:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 601:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 1000:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Disabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

 

sh ip igmp snooping c 2950 (у меня на столе, подключен к 2960 транком по сотке):

 

Global IGMP Snooping configuration:
-----------------------------------
IGMP snooping              : Enabled
IGMPv3 snooping (minimal)  : Enabled
Report suppression         : Enabled
TCN solicit query          : Disabled
TCN flood query count      : 2
Last member query interval : 1000

Vlan 1:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 5:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 6:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 7:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 8:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 9:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 11:
--------  
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 12:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 15:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 16:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 17:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 19:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 23:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 24:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 25:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 27:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 28:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 29:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 50:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 71:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 93:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 94:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 95:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 100:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 299:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 399:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 402:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 404:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 405:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 599:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 601:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Vlan 1000:
--------
IGMP snooping                       : Enabled
Immediate leave                     : Disabled
Multicast router learning mode      : pim-dvmrp
Source only learning age timer      : 10
Last member query interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Share this post


Link to post
Share on other sites

конфигурация 2950 (втыкаю модем в 16 или 14 порт и получаю с аплинк порта с 2960 каталиста весь поток):

 

version 12.1
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service dhcp
!
logging console warnings
!
ip subnet-zero
no ip source-route
no ip gratuitous-arps
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host rsh *** root enable
ip rcmd remote-host rsh *** root enable
ip rcmd remote-host rsh *** root enable
ip rcmd source-interface Vlan1000
!
ip ftp source-interface Vlan1000
ip tcp selective-ack
ip tcp path-mtu-discovery
ip tftp source-interface Vlan1000
ip name-server ***
ip name-server ***
!
!
spanning-tree mode rapid-pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
spanning-tree vlan 1-1000 priority 61440
!
!
!
!
interface FastEthernet0/1
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/2
description VLAN-100,19
switchport access vlan 100
switchport trunk native vlan 100
switchport trunk allowed vlan 19,100
switchport mode trunk
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/3
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/4
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/5
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/6
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/7
description VLAN-100
switchport access vlan 16
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/8
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/9
description VLAN-23
switchport access vlan 19
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/10
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
spanning-tree bpdufilter enable
!
interface FastEthernet0/11
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/12
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/13
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/14
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/15
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/16
description VLAN-100
switchport access vlan 100
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
spanning-tree bpdufilter enable
!
interface FastEthernet0/17
description VLAN-23
switchport access vlan 23
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/18
description VLAN-11
switchport access vlan 11
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/19
description --blank--
switchport access vlan 50
switchport trunk native vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
shutdown
no cdp enable
!
interface FastEthernet0/20
description --blank--
switchport access vlan 50
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode access
switchport nonegotiate
load-interval 30
shutdown
no cdp enable
!
interface FastEthernet0/21
description --blank--
switchport access vlan 50
switchport trunk native vlan 50
switchport trunk allowed vlan 50
switchport mode trunk
switchport nonegotiate
load-interval 30
shutdown
no cdp enable
!
interface FastEthernet0/22
description TEST-655
switchport access vlan 50
switchport trunk allowed vlan 785
switchport mode trunk
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/23
description TEST-ADSL
switchport access vlan 50
switchport trunk native vlan 399
switchport trunk allowed vlan 299,399,599
switchport mode trunk
switchport nonegotiate
load-interval 30
no cdp enable
!
interface FastEthernet0/24
description Uplink to 2960
switchport access vlan 100
switchport trunk native vlan 100
switchport mode trunk
load-interval 30
no cdp enable
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan1000
ip address ***
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
load-interval 30
hold-queue 4096 in
hold-queue 4096 out
!
ip default-gateway ***
no ip http server
ip http access-class 3
logging history size 500
logging history debugging
logging trap debugging
logging facility local2
logging source-interface Vlan1000
access-list 1 permit ***
access-list 2 permit ***
access-list 3 deny   any
access-list 10 permit ***
no cdp run
snmp-server community *** RO 2
snmp-server tftp-server-list 10
!
line con 0
exec-timeout 15 0
privilege level 15
logging synchronous
line vty 0 4
access-class 1 in
exec-timeout 15 0
logging synchronous
login
line vty 5 15
access-class 1 in
exec-timeout 15 0
logging synchronous
login
!
ntp source Vlan1000
ntp server ***

Share this post


Link to post
Share on other sites
делал... ничего подозрительного, просто вдруг начинает идти весть поток. Без IGMP подписки...

 

Тогда возможно к вам не всё зеркалится, ищите ХАБ.

 

 

Share this post


Link to post
Share on other sites

В порт 2950 каталиста втыкаю adsl модем (без линии конечно) tplink и... все. На этот порт начинает идти ВЕСЬ iptv поток.

 

Тоесть имеет значение что подключить. Если так, то скорей всего дело в трафике от этого устройства.

Нужно зеркалировать, попробуйте еще раз, поищите хаб. Интересует входящий(ingerss) трафик на порт 2950 от tplink.

Share this post


Link to post
Share on other sites

Наверное есть смысл посмотреть еще вывод команды show ip igmp snooping groups и понять, что там у вас реально снупиться.

На какой версии протоколов вы строите сервис ?

Если это 2-я версия, то посмотрите на компьютере тспдампом, видит ли винда IGMPv2 Query от вашего квериера, сваливается ли она с IGMPv3 в IGMPv2 после этого.

Многие коммутаторы, включают снупинг только если услышат вначале query.

Соответственно, если он потерялся несколько раз, или коммутатор не умеет извлекать таймеры из query, а работает только с зашитыми стандартом, у вас периодически будет флуд.

Выложите также конфиг 3550.

Проверьте, что PIM не сваливается в dence mode, т.е. на интерфейсах строго стоит sparce, что rp сконфигурен.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this