Jump to content
Калькуляторы

Вопросы по настройки Quagga quagga bgp zebra ospf freebsd

Имеем Freebsd 7.2-RELEASE. На нем поднято:

  1. BGP с несколькими пирами.
  2. наш блок адресов xxx.xxx.168.xx/22
  3. арендованный блок /24
  4. pppoed раздающий туннели клиентам
  5. клиентский шейпинг и натинг.
  6. туннель к he.net для получения блока ipv6

сеть поделена:

  1. xxx.xxx.168.0/26 # роутеры
  2. xxx.xxx.169.0/24 # BRAS #1
  3. xxx.xxx.170.0/24 # BRAS #2
  4. xxx.xxx.171.0/24 # BRAS #3

 

xxx.xxx.168.1 (em0)--10.10.10.10(lo0)--(em1)-xxx.xxx.170.127/32 (tun54)

 

При каждом поднятии tunx zebra и ospf дергаются и плюются ошибками:

Зебра

2011/03/17 00:49:54 ZEBRA: warning: connected_add_ipv6 called for interface tun54 with unspecified destination address; ignoring!
2011/03/17 00:49:54 ZEBRA: warning: connected_add_ipv6 called for interface tun54 with peer flag set, but no peer address supplied

 

Оспф

2011/03/17 00:48:41 OSPF: Redistribute[connected]: xxx.xxx.170.127/32 already exists, discard.
2011/03/17 00:48:41 OSPF: ospf_zebra_read_ipv4() : xxx.xxx.170.127 already exists

 

Хочется:

  1. погасить эту ругать.
  2. запустить как-то анонс реального ipv6 адреса клиенту
  3. как-то получать от соседних брасов маршруты к выданным IP

 

Конфиг ospfd.conf

!
router ospf
ospf router-id xxx.xxx.168.1
redistribute connected
network xxx.xxx.168.0/26 area 0.0.0.1
!
access-list localhost-in-only permit 127.0.0.1/32
!
line vty
access-class localhost-in-only
exec-timeout 0 0
!

 

Конфиг bgpd.conf

router bgp 111
network xxx.xxx.168.0/22
...

 

Конфиг zebra.conf

interface em0
ip address  xxx.xxx.168.1/26
no ipv6 nd suppress-ra
!
interface em1
ip address xxx.xxx.170.1/24
no ipv6 nd suppress-ra
!
...
interface tun54
ipv6 nd suppress-ra
!
...
!
ip route 10.0.0.0/8 Null0 254
ip route 10.22.3.1/32 yyy.yyy.92.241
ip route yyy.yyy.72.60/32 yyy.yyy.92.241
ip route xxx.xxx.168.0/22 Null0 254
ip route 172.16.0.0/12 Null0 254
ip route 192.168.0.0/16 Null0 254
!
ip forwarding
ipv6 forwarding
!

Edited by vlad11

Share this post


Link to post
Share on other sites

кваговский radvd жутко криво работает с динамическими интерфейсами: при создании интерфейса не цепляется к мультикаст группе, при удалении - не отцепляется.

Лучше вручную включать/отключать nd при изменении интерфейса:

Создание: /usr/local/bin/vtysh -c "configure terminal" -c "interface $IFACE" -c "ipv6 nd suppress-ra" -c "no ipv6 nd suppress-ra"

Удалении: /usr/local/bin/vtysh -c "configure terminal" -c "interface $IFACE" -c "ipv6 nd suppress-ra"

 

У he.net можно сразу взять сеть /48, и раздавать каждому абоненту по /64. При создании добавить ipv6 nd prefix <абонентская сеть::/64>

Edited by littlesavage

Share this post


Link to post
Share on other sites

и перед этим как-то в конфиге zebra отключить ipv6 ?

Везде на интерфейсах поставил

no ipv6 nd suppress-ra

 

пересобрал кваггу без опции ipv6 nd suppress-ra

 

все равно те же ошибки сыпятся

 

Edited by vlad11

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this