Jump to content
Калькуляторы

Несколько подинтерфейсов, как быть с ВЛАНами?

Есть маршрутизатор с одним езернетом в ЛВС и одним к провайдеру.

И есть необходимость сделать несколько подинтерфейсов на внутреннем Fa0/1, то есть:

 

int fa0/1.10

encapsulation dot1q 10

ip addres x.x.x.x 255.255.255.0

 

int fa0/1.20

encapsulation dot1q 20

ip addres e.e.e.e 255.255.255.0

 

Как обеспечить работу сетей х,х,х,х, и е,е,е,е в любом месте ЛВС? То есть не привязывая порты коммутаторов к ВЛАНам?

 

 

Спасибо

 

Share this post


Link to post
Share on other sites

не делать сабинтерфейс а засунуть порт фа в соответствующие вланы - понятно порт должен быть тегированный ну и эти вланы пробросить дальше куда вам надо

Share this post


Link to post
Share on other sites
не делать сабинтерфейс а засунуть порт фа в соответствующие вланы - понятно порт должен быть тегированный ну и эти вланы пробросить дальше куда вам надо
без сабинтерфейсов не обойтись (нужны для организации VRF, здесь же ранее порекомендовали для маршрутизации нескольких внутренних подсетей на разные же гейтвеи наружу)

предполагаю что если коммутаторы ЛВС понимают МУЛЬТИВЛАНы, то задача разрешилась бы легко и просто, но ЛВС собрана на мыльницах от ДЛИНКа, древних 3СОМах и еще черт знает на чем...

Share this post


Link to post
Share on other sites

вы хотите использовать несколько вланов на мыльницах.. похороните затею.

Share this post


Link to post
Share on other sites
вы хотите использовать несколько вланов на мыльницах.. похороните затею.
Нет, я хотел чтобы на маршрутизаторе были субинтерфейсы и, соотвественно, разные ВЛАНы. А вот в самой ЛВС не было привязки портов к ВЛАНам. Любое ус-во - в любой порт, разница только в разных ИП.

 

Share this post


Link to post
Share on other sites

Нет, я хотел чтобы на маршрутизаторе были субинтерфейсы и, соотвественно, разные ВЛАНы. А вот в самой ЛВС не было привязки портов к ВЛАНам. Любое ус-во - в любой порт, разница только в разных ИП.

Тогда вам будет достаточно N secondary адресов на одном физ. интерфейсе

Share this post


Link to post
Share on other sites
Нет, я хотел чтобы на маршрутизаторе были субинтерфейсы и, соотвественно, разные ВЛАНы. А вот в самой ЛВС не было привязки портов к ВЛАНам. Любое ус-во - в любой порт, разница только в разных ИП.
Тогда вам будет достаточно N secondary адресов на одном физ. интерфейсе

Не, там еще надо чтобы изнутри разные сети ходили наружу через разные шлюзы. Здесь порекомендовали VRF. Если знаете как сделать без ВРФ, то пож-ста, поделитесь.

 

Share this post


Link to post
Share on other sites

варианты:

1 не заниматься извращением

1.1 купить ес20 карточки и сделать нормальный vpls

1.2 изменить дизайн сети так, что бы подобная необходимость отпала

2. заниматься извращениями

2.1 разнести агрегацию и ядро, купив устройства агрегации, резерв доя агрегации обеспечить портченелом, а уже от агрегации по второму уровню разводить на разные порты один и тот же влан

2.2 использовать "перемаркировку тегов": заводим интерфейс роутед, втыкаем его петлёй в другой интерфейс, который настраиваем как аксес

2.3 использовать внешнее устройство с гигабитными или 100мбитными петлями, если жалко портов

2.4 примерно такую же штуку можно сотварить с Q-in-Q

 

ещё дурных идей нагенерировать?

Share this post


Link to post
Share on other sites

int fa 0/1

ip add xx.xx.xx.xx 255.255.XX.XX

ip add yy.yy.yy.yy 255.255.YY.YY secondary

 

 

Сделать вот так.

А первой группе компов прописать адреса из диапазона XX и шлюз xx.xx.xx.xx

Во второй группе компов прописать адреса из диапазона YY и шлюз yy.yy.yy.yy

 

А что-бы из разных сетей через разные ВНЕШНИЕ ip ходило, то

 

access list standard NET1 permit xx.xx.xx.0 0.0.0.255

 

access list standard NET2 permit yy.yy.yy.0 0.0.0.255

 

policy DIFF-DEFF perm 10

mach NET1

set next-hop IP-1

policy DIFF-DEFF perm 20

mach NET2

set next-hop IP-2

 

int fa 0/1

service-policy DIFF-DEFF in

 

 

За грамматическую корректность не ручаюсь, писал по памяти. Пользуйтесь ? в CLI циски

Edited by sol

Share this post


Link to post
Share on other sites
ещё дурных идей нагенерировать?
не, дурных не надо -))

к тому же следующим постом предложено куда более изящное решение чем vrf

через роут-мапы сейчас и краcится траффик, и уходит куда нужно....

 

2сол - спасибо!

 

 

 

 

Share this post


Link to post
Share on other sites

Тогда, для страждущих, можно правильный кусок конфига в студию? А то вопрос на самом деле частый. Что-б было куда ссылку давать.

 

Share this post


Link to post
Share on other sites
Тогда, для страждущих, можно правильный кусок конфига в студию? А то вопрос на самом деле частый. Что-б было куда ссылку давать.

1) на нужном фейсе включаем полиси:

interface FastEthernet0/1

description INside

ip address z.z.z.z. 255,255,255,0 secondary

ip address w.w.w.w 255.255.255.0

ip policy route-map ХРЕН

 

2) делаем ацл для последующих матчей:

ip access-list extended voice

deny ip bla-bla

permit ip bla-bla

ip access-list extended data

deny ip bla-bla

permit ip bla-bla

 

3) сами роутмапы с матчами и указанием куда роутить пакеты попадающие в эти матчи:

route-map ХРЕН permit 10

match ip address voice

set ip next-hop x.x.x.x

!

route-map ХРЕН permit 20

match ip address data

set ip next-hop у.у.у.у.у

 

4) по вкусу (для того, чтобы полиси распрострянялиь и на сам рутер) :

ip local policy route-map ХРЕН

 

5) окраска голоса c присвоением бит преседенс:

class-map match-all Voice-i-video

match access-group name voice

 

policy-map LLQ

class Voice-i-video

priority 1024 60000

set ip dscp cs5

class class-default

fair-queue

set ip dscp default

 

6) очередь на выход:

interface fa0/0

service-policy output LLQ

 

вот как-то так.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this