Jump to content
Калькуляторы

Cisco ip nat для внутренней подсетки включенной в VRF

Cisco 7206vxr.

В ходе работе столкнулся с проблемой, когда включаю внутреннюю подсеть в VRF то перестает работать НАТ для нее.

Пример конфига упростил для исключения ошибок:

giga 0/1 - внешняя сетевая

giga 0/2.25 - внутренняя сетевая

 

interface GigabitEthernet0/2.25
encapsulation dot1Q 25
ip vrf forwarding LOCAL
ip address 192.168.2.1 255.255.255.0
ip nat inside
no cdp enable

interface GigabitEthernet0/1
ip address 92.xx.xx.xx 255.255.255.252
ip nat outside
ip ospf network point-to-point
media-type rj45
speed 1000
duplex full
no negotiation auto
no cdp enable

ip nat inside source list For_LOCAL interface GigabitEthernet0/1 overload
ip access-list standard For_LOCAL
permit 192.168.0.0 0.0.255.255

ip vrf LOCAL
rd 1984:1984

 

Внутренняя сетевая (giga 0/2.25) в VRF обязательна.

 

Если исключить ip vrf forwarding LOCAL - то НАТ работает.

Edited by Macro

Share this post


Link to post
Share on other sites
Cisco 7206vxr.

В ходе работе столкнулся с проблемой, когда включаю внутреннюю подсеть в VRF то перестает работать НАТ для нее.

Пример конфига упростил для исключения ошибок:

giga 0/1 - внешняя сетевая

giga 0/2.25 - внутренняя сетевая

 

interface GigabitEthernet0/2.25
encapsulation dot1Q 25
ip vrf forwarding LOCAL
ip address 192.168.2.1 255.255.255.0
ip nat inside
no cdp enable

interface GigabitEthernet0/1
ip address 92.xx.xx.xx 255.255.255.252
ip nat outside
ip ospf network point-to-point
media-type rj45
speed 1000
duplex full
no negotiation auto
no cdp enable

ip nat inside source list For_LOCAL interface GigabitEthernet0/1 overload
ip access-list standard For_LOCAL
permit 192.168.0.0 0.0.255.255

ip vrf LOCAL
rd 1984:1984

 

Внутренняя сетевая (giga 0/2.25) в VRF обязательна.

 

Если исключить ip vrf forwarding LOCAL - то НАТ работает.

Вполне логично. У вас outside интерфейс находится в другой таблице маршрутизации.

Необходимо либо затянуть Ge0/1 в vrf LOCAL, либо попробовать сделать route leaking(сам не пробовал).

Edited by StSphinx

Share this post


Link to post
Share on other sites

Вам нужен NAT c vrf поддержкой, а так же VRF route leak почитайте.

Cisco позволяет решать подобные задачи.

Share this post


Link to post
Share on other sites

Попробуйте добавить:

ip route vrf LOCAL 0.0.0.0 0.0.0.0 92.xx.xx.xx global

Share this post


Link to post
Share on other sites
Попробуйте добавить:

ip route vrf LOCAL 0.0.0.0 0.0.0.0 92.xx.xx.xx global

Спасибо, заработало с:

ip nat inside source list For_LOCAL interface GigabitEthernet0/1 vrf LOCAL overload
ip route vrf LOCAL 0.0.0.0 0.0.0.0 GigabitEthernet0/1 92.xx.xx.xy

Share this post


Link to post
Share on other sites
Спасибо, заработало с:

ip nat inside source list For_LOCAL interface GigabitEthernet0/1 vrf LOCAL overload
ip route vrf LOCAL 0.0.0.0 0.0.0.0 GigabitEthernet0/1 92.xx.xx.xy

И наверняка с:
interface GigabitEthernet0/1
  ip vrf forwarding LOCAL

Чего не было в изначальных условиях?

Share this post


Link to post
Share on other sites
Спасибо, заработало с:

ip nat inside source list For_LOCAL interface GigabitEthernet0/1 vrf LOCAL overload
ip route vrf LOCAL 0.0.0.0 0.0.0.0 GigabitEthernet0/1 92.xx.xx.xy

И наверняка с:
interface GigabitEthernet0/1
  ip vrf forwarding LOCAL

Чего не было в изначальных условиях?

Нет.

giga 0/1 неизменна:

 

interface GigabitEthernet0/1

description 7600_Uplink

ip address 92.хх.хх.хх 255.255.255.252

ip nat outside

ip ospf network point-to-point

media-type rj45

speed 1000

duplex full

no negotiation auto

no cdp enable

end

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this