Jump to content
Калькуляторы

Помогите плизз разобраться с мультикастом. Зачем весь поток со стримера идет до роутера?

Всем привет.

Ситуация следующая.

Есть сеть с топологией звезда, центр звезды 6506е sup 720 3b. Он же интер Vlan router. Около 10 вланов на нем это разные сегменты домашних сетей. За одной из веток стоит 3560 в роли L2 коммутатора, а за ним стример Luminato. На данный момент в период теста, с луминаты вещается около 15 mpeg 2 каналов с общим битрейтом около 60 мегабит. Стример стримит непосредственно в один из виланов домашних сетей, в моем случае это 102 влан. Поток должен роутица по запросу в интерфейсы vlan 96 - 102.

 

В целом все хорошо, снуппинг работает, pim работает. Лишнего флуда мультикаста нет. Присоединение и отсоединение к группам происходит весьма шустро и своевременно.

 

Вопрос пока только один. Весь поток со стримера, не зависимо от наличия активных групп, т.е. без единого ресивера шпарит от через 3560 до 6506 int vlam 102. Такое ощущение буд-то он статически зареген во всех группах сразу.

 

Нормально ли это?

Можно ли сделать так, что бы от стримера до роутера 6506 был только тот поток, который в данный момент кто-то запрашивает через роутер, а в случае когда нет пользователей, вообще не какого потока небыло?

 

конфиги:

 

С луминаты стримятся группы с 239.10.1.1 - 239.10.1.16

 

стример---->3560L2------>6506e-Vlan102----->сеть

 

3560

 

cat-48d#sh run int gi0/3

interface GigabitEthernet0/3

description *** Luminato strimer ***

switchport access vlan 102

switchport trunk encapsulation dot1q

switchport mode access

switchport nonegotiate

mls qos trust cos

storm-control broadcast level 60.00

storm-control action trap

no cdp enable

spanning-tree guard root

end

cat-48d#sh run int gi0/4

interface GigabitEthernet0/4

description *backbone*

switchport trunk encapsulation dot1q

switchport trunk native vlan 998

switchport mode trunk

switchport nonegotiate

mls qos trust cos

no cdp enable

ip dhcp snooping trust

end

cat-48d#sh run | inc igmp

ip igmp snooping querier

ip igmp snooping vlan 99 immediate-leave

ip igmp snooping vlan 101 immediate-leave

ip igmp snooping vlan 102 immediate-leave

ip igmp snooping vlan 110 immediate-leave

 

cat-48d#sh ip igmp snoo groups vlan 99

Vlan Group Type Version Port List

-----------------------------------------------------------------------

99 239.255.255.250 igmp v3 Gi0/4, Fa0/48

 

cat-48d#sh ip igmp snoo groups vlan 102

Vlan Group Type Version Port List

-----------------------------------------------------------------------

102 239.192.152.143 igmp v2 Gi0/1, Gi0/4

102 239.255.255.250 igmp v2,v3 Gi0/1, Gi0/4,

Fa0/48

Catalyst 6506e

 

cat6506#sh run int vlan 102

 

interface Vlan102

description *** homenet dng. ***

ip address 10.0.0.1 255.255.254.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip multicast ttl-threshold 3

ip igmp version 3

ip igmp explicit-tracking

ip igmp snooping fast-leave

ip igmp snooping last-member-query-interval 100

end

 

ip multicast-routing

ip pim rp-address 10.0.0.1 luminato override

 

cat6506#sh ip access-lists luminato

Standard IP access list luminato

10 permit 239.10.0.0, wildcard bits 0.0.1.255 (86369 matches)

 

cat6506#sh ip igmp groups | inc 239.10.1.

Смотрящих нету.

 

cat6506#sh ip mroute active

Active IP Multicast Sources - sending >= 4 kbps

 

Group: 239.10.1.10, (?)

Source: 10.0.0.5 (?)

Rate: -219 pps/2359 kbps(1sec), 2359 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.11, (?)

Source: 10.0.0.5 (?)

Rate: -237 pps/2549 kbps(1sec), 2497 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.8, (?)

Source: 10.0.0.7 (?)

Rate: -324 pps/3483 kbps(1sec), 3507 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.9, (?)

Source: 10.0.0.5 (?)

Rate: -365 pps/3925 kbps(1sec), 4021 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.14, (?)

Source: 10.0.0.5 (?)

Rate: -375 pps/4036 kbps(1sec), 4036 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.15, (?)

Source: 10.0.0.5 (?)

Rate: -440 pps/4731 kbps(1sec), 4732 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.12, (?)

Source: 10.0.0.5 (?)

Rate: -384 pps/4131 kbps(1sec), 4130 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.13, (?)

Source: 10.0.0.5 (?)

Rate: -375 pps/4036 kbps(1sec), 4036 kbps(last 20 secs), 0 kbps(life avg)

 

Group: 239.10.1.2, (?)

Source: 10.0.0.5 (?)

Rate: -800 pps/8601 kbps(1sec), 8480 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.3, (?)

Source: 10.0.0.7 (?)

Rate: -304 pps/3274 kbps(1sec), 3369 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.1, (?)

Source: 10.0.0.5 (?)

Rate: 422 pps/4542 kbps(1sec), 4544 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.6, (?)

Source: 10.0.0.7 (?)

Rate: -173 pps/1865 kbps(1sec), 2259 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.7, (?)

Source: 10.0.0.7 (?)

Rate: -155 pps/1669 kbps(1sec), 1923 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.4, (?)

Source: 10.0.0.7 (?)

Rate: -365 pps/3934 kbps(1sec), 3404 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.5, (?)

Source: 10.0.0.7 (?)

Rate: -111 pps/1196 kbps(1sec), 1113 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.17, (?)

Source: 10.0.0.5 (?)

Rate: -444 pps/4777 kbps(1sec), 4642 kbps(last 30 secs), 0 kbps(life avg)

 

Group: 239.10.1.16, (?)

Source: 10.0.0.5 (?)

Rate: -292 pps/3141 kbps(1sec), 3141 kbps(last 30 secs), 0 kbps(life avg)

 

В общем что можно сделать для того, что бы весь поток со стримера (если сейчас 15 каналов это 60 мб\сек, то 60 каналов получается 240 мегабит!!!! что весьма не приятно) не шел к роутеру, когда этого не надо, т.е. нету не одного желающего не в одной из групп? Нормально если все каналы кто-то смотрит за роутером, но если они не каму не нужны то какого черта гонять этот трафик зря ума?

 

Заранее спасибо!

 

Share this post


Link to post
Share on other sites

Всем спасибо за внимание ))

 

Почему поток из 16 групп шпарил из стримера до 6506 не разобрался, вопрос открыт.

Нафига он шпарит если нет не единого пдписанного, почему 3560 не снупит?

 

А проблему решил переносом терминации на 3560, сделал там svi интерфейс и перенес туда rp, настроив pim между 6506 и 3560

Share this post


Link to post
Share on other sites
Почему поток из 16 групп шпарил из стримера до 6506 не разобрался, вопрос открыт.

Потому что в твоём случае 6506 шлёт запрос на присоединение к группе 224.0.0.2, после чего 3560 начинает напрямую пропускать весь мультикаст на интерфейс, с которого пришёл этот запрос.

 

Нафига он шпарит если нет не единого пдписанного, почему 3560 не снупит?

Потому что к RP должен идти весь мультикаст от стримера, в твоём случае как я понял RP был на 6506.

 

А проблему решил переносом терминации на 3560, сделал там svi интерфейс и перенес туда rp, настроив pim между 6506 и 3560

Перенёс RP, и теперь 3560 шлёт запросы на 224.0.0.2, если между стримером и 3560 включишь свитч только со снупингом (без пим), то можешь снова получить такую-же картину, промежуточный свитч будет сквозняком гнать весь мультикаст до RP.

Share this post


Link to post
Share on other sites

хм... мне кажется что сие не особо правильно, да и подсказывают с соседнего форума, что стример должен слушать джойны и не стримать просто так. К тому же, незадача в том, что до spars mode пробывал и dense mode, без rp соответственно и картина была тойже, трафик шел до роутера.

Ну а если представить, что это нормальное поведение мультикаста, есть ли какие-то варианты исправить это, не перенося мульткаст роутер ближе к источнику? Все таки я бы хотел решение найти, просто интересно..

Edited by MAXmks

Share this post


Link to post
Share on other sites
хм... мне кажется что сие не особо правильно, да и подсказывают с соседнего форума, что стример должен слушать джойны и не стримать просто так.

Ни один стример так не поступает! Исключением являются те стримеры, на которых установлен дополнительный софт а-ля pimd, xorp, etc.

Задача стримера - стримить, а не заниматься роутингом/слушать igmp. Стример сам должен слать igmp на те группы, которые он вещает.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this