Jump to content
Калькуляторы

Router on a stick cisco + другой вендор

Получалось ли у кого-нибудь ? К примеру Cisco 1721 со свичем D-link 1228/ME ?

Share this post


Link to post
Share on other sites
В чём проблема? 802.1q везде одинаковый.

Я о том же. Но почему то не заработало

Share this post


Link to post
Share on other sites
что конкретно не заработало?

Хоты не видят шлюзы на роутере

Share this post


Link to post
Share on other sites

Делайте зеркалирование порта и смотрите где у вас не хватает тэгов(скорее всего в этом проблема - неверно сконфигурирован "транк" на длинке)

Share this post


Link to post
Share on other sites

Может покажите???

show run
show config

Share this post


Link to post
Share on other sites
Может покажите???

show run
show config

hostname XXXXX

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$9PgB$P4oXqgNsrUcvyB4HZTNEA1

!

no aaa new-model

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

no ip domain lookup

ip domain name XXXX

!

!

!

!

username XXXXXX privilege 15 secret 5 $1$D4v8$HQC.uviAsRmQ3TCFgCIBD1

!

!

!

!

!

!

interface FastEthernet0

no ip address

speed 100

full-duplex

!

interface FastEthernet0.2

description LAN

encapsulation dot1Q 2

ip address A.B.C.D 255.255.255.0

!

interface FastEthernet0.3

description ATM

encapsulation dot1Q 3

ip address A.B.C.D 255.255.255.0

!

interface FastEthernet0.127

description WAN

encapsulation dot1Q 127

ip address A.B.C.D 255.255.255.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 A.B.C.D

!

ip http server

ip http authentication local

no ip http secure-server

!

 

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login local

!

end

Share this post


Link to post
Share on other sites

Длинк отдал , попробовал с циско смалл бизнесс SLM224G линксис тоже самое

 

Порт 2 находиться в 127 влане

Порт 3 настроен как транк

 

post-75004-1286527657_thumb.jpg

 

post-75004-1286527667_thumb.jpg

 

пинг с хоста в 127 влане не идет на интерфейс FastEthernet0.127

Edited by psygex

Share this post


Link to post
Share on other sites
Порт 2 находиться в 127 влане

Порт 3 настроен как транк

но почему то порт 2 и порт 3 вы настроили одинаково.

у вас на обоих портах трафик тегированый. если вы ко 2му порту цепляете компьютер - то на него стоит подавать нетегированный влан.

Share this post


Link to post
Share on other sites
Порт 2 находиться в 127 влане

Порт 3 настроен как транк

но почему то порт 2 и порт 3 вы настроили одинаково.

у вас на обоих портах трафик тегированый. если вы ко 2му порту цепляете компьютер - то на него стоит подавать нетегированный влан.

поменял второй на антагд, не помогло

дибаг айпи пакет выдает это

*Apr 9 02:20:41.135: IP: tableid=0, s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), routed via RIB

*Apr 9 02:20:41.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, sending

*Apr 9 02:20:41.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, encapsulation failed.

*Apr 9 02:20:43.135: IP: tableid=0, s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), routed via RIB

*Apr 9 02:20:43.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, sending

*Apr 9 02:20:43.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, encapsulation failed.

*Apr 9 02:20:45.135: IP: tableid=0, s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), routed via RIB

*Apr 9 02:20:45.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, sending

*Apr 9 02:20:45.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, encapsulation failed.

*Apr 9 02:20:47.135: IP: tableid=0, s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), routed via RIB

*Apr 9 02:20:47.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, sending

*Apr 9 02:20:47.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, encapsulation failed.

*Apr 9 02:20:49.135: IP: tableid=0, s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), routed via RIB

*Apr 9 02:20:49.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, sending

*Apr 9 02:20:49.135: IP: s=10.0.2.58 (local), d=10.0.2.59 (FastEthernet0.127), len 100, encapsulation failed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this