Jump to content
Калькуляторы

BGP роутер и BRAS с OSPF

Есть BGP роутер на 3845, анонсирующий две своих и несколько клиентских сетей, к нему подключено два BRASа, одна из своих сетей зарулена статикой на один их брасов, подключаем второй, на нём заводим OSPF, на тестах вроде всё ок: один /32 маршрут на 3845 появляется в сторону второго браса, всё работает.

Начинаем на новый брас переводить клиентов, соотвественно, маршрутов по оспф появляется-удаляется много.

 

В один прекрасный момент 3845 перестаёт анонсировать (смотрю show ip bgp neighbor x.x.x.x adv ) ту сеть, из которой адреса выдаются клиентам на брасах, так же неожиданно появляется снова и анонсируется и так по кругу.

Напоминаю, что сеть статикой заведена на первый брас, в бгп прописана через network и, редистрибьюции из других протовоколов нету, но сеть временами из моих же анонсов пропадает. Куда копать?

Edited by nevzorofff

Share this post


Link to post
Share on other sites

nevzorofff

Какое количество маршрутов /32 приходит на бордер? Попробуйте перейти на втором брасе с OSPF на iBGP.

Share this post


Link to post
Share on other sites

320 маршрутов самое больше, какое могло быть.

Какие у iBGP преимущества? Оно по 30 секунд будет думать прежде, чем добавит маршрут? Тут такое где-то обсуждалось.

Share this post


Link to post
Share on other sites

nevzorofff

Если 320 маршрутов тогда даже не знаю... Не много это, должно и с OSPF нормально работать.

Share this post


Link to post
Share on other sites

Сейчас попробовал ещё раз - по show ip static routes эта пропадающая сеть присутствует, такое ощущение, что BGP решает в определённый момент, что маршрута к этой сети нет и перестаёт анонсировать.

Share this post


Link to post
Share on other sites
nevzorofff

Не много это, должно и с OSPF нормально работать.

причём на ура

Share this post


Link to post
Share on other sites

Можно конфиги 1) bgp 2) ospf 3) статических маршрутов с бордера?

 

Напишите на бордере маршрут своих белых сетей в null0, думаю проблема уйдет.

Edited by pliskinsad

Share this post


Link to post
Share on other sites
Напишите на бордере маршрут своих белых сетей в null0, думаю проблема уйдет.
да.

все BGP-префиксы на бордере должны быть статически сначала на null0 с метрикой, скажем, 240 заручены.

тогда у бордераменьше мозги скрипеть будут :)

Share this post


Link to post
Share on other sites

Маршруты с метрикой 255 и так присутствовал на нём изначально, но по show ip route static всегда показывался другой маршрут с более низкой метрикой

 

Перестающая анонсироваться сеть - 213.5.240.0/21

 

 

router bgp 42141

no synchronization

bgp router-id 195.110.2.0

bgp log-neighbor-changes

network 195.110.2.0 mask 255.255.254.0

network 213.5.240.0 mask 255.255.248.0

aggregate-address 195.110.2.0 255.255.254.0 summary-only

aggregate-address 213.5.240.0 255.255.248.0 summary-only

 

тут конфигурация нейборов

 

auto-summary

!

 

 

оспф с бордера:

 

router ospf 1

router-id 195.110.2.129

log-adjacency-changes

passive-interface default

no passive-interface GigabitEthernet0/1.900

network 195.110.2.128 0.0.0.15 area 0.0.0.1

!

 

 

белые статические маршруты с бордера

ip route 195.110.2.0 255.255.254.0 Null0

ip route 213.5.240.0 255.255.248.0 195.110.2.130

ip route 213.5.240.0 255.255.248.0 Null0 255

 

 

 

vpn# cat /usr/local/etc/quagga/ospfd.conf

!

! Zebra configuration saved from vty

! 2010/04/14 17:29:46

!

hostname vpn.gtelecom.ru

 

 

log file /var/log/quagga/ospfd.log

!

!

!

interface em0

ip ospf cost 1

ip ospf priority 150

!

interface em1

!

interface ipfw0

!

interface lo0

!

interface ng0

!

router ospf

ospf router-id 195.110.2.131

redistribute connected route-map FILTER

passive-interface default

no passive-interface em0

network 195.110.2.128/28 area 0.0.0.1

!

ip prefix-list FILTER seq 5 permit 213.5.240.0/21 le 32

ip prefix-list FILTER seq 10 permit 192.168.84.0/24 le 32

ip prefix-list FILTER seq 15 permit 195.110.2.0/23 le 32

!

route-map FILTER permit 10

match ip address prefix-list FILTER

!

line vty

!

Edited by nevzorofff

Share this post


Link to post
Share on other sites

На бордере:

добавить

ip route 195.110.2.0 255.255.254.0 Null0

ip route 213.5.240.0 255.255.248.0 Null0

 

 

aggregate-address 195.110.2.0 255.255.254.0 summary-only Убрать

aggregate-address 213.5.240.0 255.255.248.0 summary-only Убрать

ip route 213.5.240.0 255.255.248.0 Null0 255 Убрать

 

Поклирить bgp.

 

 

Share this post


Link to post
Share on other sites
Маршруты с метрикой 255 и так присутствовал на нём изначально, но по show ip route static всегда показывался другой маршрут с более низкой метрикой

 

Перестающая анонсироваться сеть - 213.5.240.0/21

 

ip route 213.5.240.0 255.255.248.0 Null0 255

То, что вы называете метрикой, называется административной дистанцией. 255 - маршрут никогда не будет выбран. Пишите 254 хотя бы или не пишите такую статику вообще.

Share this post


Link to post
Share on other sites

А с брасов анонсить по OSPF-у просуммированные сети не судьба? или вы из одного пула адреса случайным образом по брасам раскидываете?

Share this post


Link to post
Share on other sites

Из одного пула случайным образом отдаёт адреса BGBilling.

 

 

Прописал административную дистанцию 254 — осталось всё тоже самое, только маршруты с анонсов стали пропадать не через 5 минут, а через 30, потом убрал с bgp aggregate-address — ничего не изменилось.

 

Сегодня и 195.110.2.0 стал из анонсов пропадать — в той подсети есть пара десятков абонентов, которым выдаются адреса из этого диапазона.

Share this post


Link to post
Share on other sites

Если вы маршруты дистрибутируете в ospf то они будут приоритетней чем маршруты с административной дистанцией.

BGP анонсирует только те маршруты, которые есть в его локальной таблице маршрутизации. Добавьте их туда полностью, и все у вас заработает нормально!

Я вам выше конфиг написал готовый.

Share this post


Link to post
Share on other sites

Ну по моим мыслям всё так и было:

есть маршрут с OSPF - трафик едет по нему, нету, едет по статитческому маршруту. Статический маршрут есть всегда, ну а раз он есть, то и сеть должна анонсироваться. Или вы предлагаете целиком сеть по OSPF аносировать на бордер?

 

pliskinsad, сейчас у меня статикой прописано так:

 

ip route 195.110.2.0 255.255.254.0 Null0

ip route 213.5.240.0 255.255.248.0 195.110.2.130

ip route 213.5.240.0 255.255.248.0 Null0 254

 

 

Share this post


Link to post
Share on other sites

делим задачу на 2 части

анонсируем в мир bgp:

 

router bgp 42141

no synchronization

bgp router-id 195.110.2.0

bgp log-neighbor-changes

network 195.110.2.0 mask 255.255.254.0

network 213.5.240.0 mask 255.255.248.0

Описание нейборов

 

ip route 195.110.2.0 255.255.254.0 Null0

ip route 213.5.240.0 255.255.248.0 Null0

 

Вот так ваш роутер проанонсирует миру свои сети по bgp

 

 

Теперь поднимайте ospf в одной арии с брасасами

 

 

с redistribute connected networks.

 

More specified маршрут всегда приоритетней.

Edited by pliskinsad

Share this post


Link to post
Share on other sites
More specified маршрут всегда приоритетней.
он приоритетней при выборе маршрута, а при анонсировании в bgp главное его наличие, что собственно и подвердилось опытом: два браса с ospf, статик заёрнут в нуль - анонсы всё равно то появляются, то исчезают.

 

Ночью буду менять ios, посмотрим, что из этого получится.

Edited by nevzorofff

Share this post


Link to post
Share on other sites

почти 3 часа — полёт нормальный.

 

Баги были на c3845-advipservicesk9-mz.124-12.bin

 

Поставил c3845-spservicesk9-mz.124-21.bin, если кто поделиться более новой spservices - буду благодарен, adventerprise есть до 25b, их не надо.

Share this post


Link to post
Share on other sites

В общем глюка и по сей день нет :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this