Jump to content
Калькуляторы

Настройка igmp-proxy на Cisco 871W

Имеется Cisco 871W в качестве роутера с wifi.

Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(15)T3, RELEASE SOFTWARE (fc1)

 

Необходима чтобы компы за маршрутизатором могли смотреть телик.

С таким конфигом работают только те группы на которые подписан сам cisco 871 (вероятно потому что вышестоящие маршрутизаторы ничего не знают о сети 192.168.2.0/24 за натом)

 

fa4 - wan

vlan3 - lan

 

!
ip multicast-routing
!
interface FastEthernet0
switchport access vlan 3
!
!
interface FastEthernet4
ip address 10.1.1.2 255.255.255.0
ip pim sparse-mode
ip nat outside
ip virtual-reassembly
ip igmp join-group 224.2.127.254
ip igmp join-group 224.200.200.1
!
!
interface Vlan3
ip address 192.168.2.1 255.255.255.0
ip pim sparse-mode
ip nat inside
!

 

sh ip pim neighbor 
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.1.1.1    FastEthernet4            01:04:31/00:01:43 v2    100/ DR

 

Подскажите пожалуйста, как это реализовать более правильно. Должен же быть вариант сделать это и без pim?

Share this post


Link to post
Share on other sites

Попробуйте

 

int fa4

ip pim dense-mode

ip igmp helper-address 10.1.1.1

!

int vlan3

ip pim dense-mode

 

 

Share this post


Link to post
Share on other sites
Попробуйте

 

int fa4

ip pim dense-mode

ip igmp helper-address 10.1.1.1

!

int vlan3

ip pim dense-mode

Не помогает.

Мне кажется мультикаст не идёт из за того что запрос приходить от адреса за натом и этой сети нет в таблице маршрутизации во внешней сети. Нужно чтобы cisco 871 выступал в качеcтве прокси, посылая запросы от своего имени (адреса).

 

 

Share this post


Link to post
Share on other sites
Не помогает.

Мне кажется мультикаст не идёт из за того что запрос приходить от адреса за натом и этой сети нет в таблице маршрутизации во внешней сети. Нужно чтобы cisco 871 выступал в качеcтве прокси, посылая запросы от своего имени (адреса).

ip igmp helper-address меняет адрес IGMP Report на собственный. Только его нужно на интерфейсе к которому клиенты подключены писать. А я кажется на upstream его посадил. У Вас - же vlan 3 внутренний интерфейс, так?

Share this post


Link to post
Share on other sites

Да, теперь в vlan3 всё работает.

Можно ли сделать аналогично на bvi интерфейсе?

По аналогии не прокатывает, видно только 224.200.200.1 ( ip igmp join-group 224.200.200.1 ).

 

 

!
ip multicast-routing
!
interface FastEthernet0
switchport access vlan 1
!
!
interface FastEthernet4
ip address 10.1.1.2 255.255.255.0
ip pim dense-mode
ip nat outside
ip virtual-reassembly
!
!
interface Vlan1
no ip address
ip virtual-reassembly
bridge-group 1
!
!
interface BVI1
ip address 192.168.0.1 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly
ip igmp helper-address 10.1.1.1
ip igmp join-group 224.200.200.1
!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this