Jump to content
Калькуляторы

mikrotik shape

Привет Всем

Есть пользователи:

10.200.207.14, 10.200.207.15, 10.200.207.253 и т.д.

Нужно что бы пользователи получали интернет, при этом их скорость шейпилась так вот: если канал свободный - отдаём всем, если забит - гарантируем что кто-то не забьёт один, а все остальные будут страдать

 

 

Пробовал сделать так - создать клас ClassUsers4M-in, к нему подключать листья с самими пользователями: user207-17-from и user207-253-from и точно так же на исходящую скорость

 

Но проблема в том что как Я сделал (пытался по примерам сделать) - не работает

 

 

 

 > /ip firewall export 
# apr/16/2010 23:18:20 by RouterOS 4.5
#
/ip firewall address-list
add address=10.200.207.15 comment="" disabled=no list=inet
add address=10.200.207.11 comment="" disabled=no list=inet
add address=10.200.207.17 comment="" disabled=no list=inet
add address=10.200.207.10 comment="" disabled=no list=inet
add address=10.200.207.18 comment="" disabled=no list=inet
add address=10.200.207.14 comment="" disabled=no list=inet
add address=10.200.207.116 comment="" disabled=no list=inet
add address=10.200.207.19 comment="" disabled=no list=inet
add address=10.200.207.12 comment="" disabled=no list=inet
add address=10.200.207.253 comment="" disabled=no list=inet
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
    tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m \
    udp-timeout=10s
/ip firewall mangle
add action=mark-connection chain=prerouting comment="" disabled=no dst-address=10.200.207.17 new-connection-mark=user207-17-connection-up passthrough=yes
add action=mark-packet chain=forward comment="" connection-mark=user207-17-connection-up disabled=no new-packet-mark=user207-17-up passthrough=yes
add action=mark-connection chain=prerouting comment="" disabled=no new-connection-mark=user207-17-connection-from passthrough=yes src-address=10.200.207.17
add action=mark-packet chain=forward comment="" connection-mark=user207-17-connection-from disabled=no new-packet-mark=user207-17-from passthrough=yes
add action=mark-connection chain=prerouting comment="" disabled=no dst-address=10.200.207.253 new-connection-mark=user207-253-connection-up passthrough=yes \
    src-address=0.0.0.0/0
add action=mark-packet chain=forward comment="" connection-mark=user207-253-connection-up disabled=no new-packet-mark=user207-253-up passthrough=yes
add action=mark-connection chain=prerouting comment="" disabled=no dst-address=0.0.0.0/0 new-connection-mark=user207-253-connection-from passthrough=yes \
    src-address=10.200.207.253
add action=mark-packet chain=forward comment="" connection-mark=user207-253-connection-from disabled=no new-packet-mark=user207-253-from passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="nat from INET list" disabled=no dst-address=!10.0.0.0/8 src-address-list=inet
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no

 

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4096k name=ClassUsers4M-out parent=global-out priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4096k name=ClassUsers4M-in parent=global-in priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k max-limit=4096k name=user207-17-from packet-mark=user207-17-from parent=\
    ClassUsers4M-in priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k max-limit=4096k name=user207-17-up packet-mark=user207-17-up parent=\
    ClassUsers4M-out priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k max-limit=4096k name=user207-253-from packet-mark=user207-253-from parent=\
    ClassUsers4M-in priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k max-limit=4096k name=user207-253-up packet-mark=user207-253-up parent=\
    ClassUsers4M-out priority=8 queue=default

Share this post


Link to post
Share on other sites
/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=4096k max-limit=4096k name=ClassUsers4M-out parent=global-out priority=8

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=4096k max-limit=4096k name=ClassUsers4M-in parent=global-in priority=8

 

приоритеты юзеров выставляются в ветках-парентах priority=8 это наинизший

 

Share this post


Link to post
Share on other sites

QoS_Megis.pdf в этом документе 17 слайд - ваш случай.

далее идет подробное описание настройки.

Share this post


Link to post
Share on other sites
приоритеты юзеров выставляются в ветках-парентах priority=8 это наинизший
Наоборот. микротик думает по другому.
Mikrotik priorities range from 1-8 with 8 being the lowest priority. (This differs from the unrelated but popular LAN CoS priority where 8 is the highest priority.)
Edited by chert

Share this post


Link to post
Share on other sites
Но проблема в том что как Я сделал (пытался по примерам сделать) - не работает
не уточнил - скорость не режется - выдает 35/24Мбит...
QoS_Megis.pdf в этом документе 17 слайд - ваш случай.

далее идет подробное описание настройки.

попробую

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this