Jump to content
Калькуляторы

Проблема с совместимостью Mikrotik и NanoStation5

Привет всем! Интересует информация по следующей проблеме:

есть БС на основе Mikrotik - RouterBoard 532 +R52+RouterOS (версия 3.x, так как пробовались разные, 4 версию пока не ставили).

К базе подключаются до 23 клиентов. Из них около 15 это mikrotik и 8 nanostation5.

А проблема собственно вот в чем. При таком кол-ве клиентов на нанах наблюдается сильная потеря пакетов, до 20-30%. На микротиках все нормально - слегка увеличивается джиттер и средний пинг.

Если отрубить большую часть микротиков (закрываю доступ через access-list), то потери на нанах падают до 1-2%, иногда совсем пропадают.

С производительностью базы никак вроде бы не связано, так как загрузка проца не более 25-30%, да и трафик всего 2-3Мбита на этой базе.

От железа не зависит - комплект полностью менялся и ситуация не изменилась. От уровня сигнала тоже не зависит - потери при сигнале от -65дб до -85дб одни и те же (ну плюс-минус что-то).

 

Может кто сталкивался с подобной проблемой?

Share this post


Link to post
Share on other sites

Сталкивались.

Настроили все как надо, в зависимости от качества связи каждого клиента настраивали его точку, максимальную скорость и т.д.

На базе включили ноис иммунити - помогает когда несколько рядом работающих устройств. Так удалось даже совместить 3 базы на одной частоте. Работают нормально. Средняя прокачка 9 мегабит за день, в пиках до 22.

Share this post


Link to post
Share on other sites
На базе включили ноис иммунити
Простите, а как на mikrotik включить noise immunity? Может у вас все ж не mikrotik базой?

 

Share this post


Link to post
Share on other sites

> interface wireless set wlan1 adaptive-noise-immunity=

ap-and-client-mode client-mode none

 

Share this post


Link to post
Share on other sites

Добрый день!

Включите ноисе имунити, pereodik kalibration. Tx power может поставить не по дефолту.... если есть проблема с CCQ. Если карта 200-ка, тагда ставте гдето порядка 18-21.

Share this post


Link to post
Share on other sites

А рядом никого нет?

Буллеты, наносы и поверстейшены сильно шумят. Сами на этом обожглись, думали откуда шум, а когда убрали их и поставили одни микротики - все сразу без проблем заработало. Причем ставить надо в железных корпусах и заземлять.

 

Это фокус такой есть - суете карточку какую-нито на атеросе в обычный системник и измеряете уровень шума. Потом лезете в биос и начинаете менять всякие параметры - частоту памяти, частоту процессора и т.д. И можно найти такие режимы, в которых уровень шума будет -70, а можно где -98.

 

Причем заметил микротики 300 мегагерц слушают шум - 98, а те что на частоте 680 - 96. ПО крайней мере я так намерял в совершенно чистом эфире с одной и той же карточкой на одну и ту же маленькую антенну.

Share this post


Link to post
Share on other sites

Извините за задержу с ответом.

adaptive-noise-immunity=ap-and-client-mode на базе влючен. Периодическая калибровка тоже включена. Пробовал и так и так - никакого эффекта.

 

 

А рядом никого нет?
Ну как рядом? Клиенты разнесены ну на 1-2км. И друг другу они явно не мешают.

Пока я наблюдаю только одну корреляцию - кол-во клиентов на базе. На одной базе 23 клиента - есть проблемы у наносов. На другой - 8 клиентов, из них 3 наны - пока нет проблем (пинги 1/4/20 100%).

Сегодня ночь проведу еще эксперимент - закрою доступ 10 микротик-клиентам с первой базы (юриков, которые по ночам не работают), посмотрю что будет с наносами.

 

 

Share this post


Link to post
Share on other sites

А ACK у наносов какой?

Поставьте им галочки ноис иммунити и conservative на вкладке advanced.

Share this post


Link to post
Share on other sites
А ACK у наносов какой?
От 35 до 96 - в зависимости от удаления, причем по расстоянию очень похоже.

Микротик на базе у себя выставляет 91-98us

Поставьте им галочки ноис иммунити и conservative на вкладке advanced.
Пробовали включать/выключать нойс иммунити на нанах - не влияет. Режим стоит conservative у всех - его тоже пробовали менять, тоже не виляет.

Сейчас провелил наносы - более или менее нормально. Пинги 99-100% даже пакетами 1000 байт. Вчера вечером и 200 байтные шли с потерями 92-94%. На микротиковских клиента все время нормально 100%.

Блин, не вижу я никакой связи хоть с чем-то...

Share this post


Link to post
Share on other sites

Значит проблема в перекосах сигнала. Хотя тоже странно. Если наносы сидят например на -70/-70 то все работает, а если есть перекос например -70/-75 то уже замечаються проблемы с согласованием скорости, он все время пытаеться поставить скорость выше чем надо, даже в conservative - поэтому подрастают пинги. С прошивкой 3.5 наносы вроде получше работают.

Share this post


Link to post
Share on other sites
Привет всем! Интересует информация по следующей проблеме:

есть БС на основе Mikrotik - RouterBoard 532 +R52+RouterOS (версия 3.x, так как пробовались разные, 4 версию пока не ставили).

К базе подключаются до 23 клиентов. Из них около 15 это mikrotik и 8 nanostation5.

А проблема собственно вот в чем. При таком кол-ве клиентов на нанах наблюдается сильная потеря пакетов, до 20-30%. На микротиках все нормально - слегка увеличивается джиттер и средний пинг.

Если отрубить большую часть микротиков (закрываю доступ через access-list), то потери на нанах падают до 1-2%, иногда совсем пропадают.

С производительностью базы никак вроде бы не связано, так как загрузка проца не более 25-30%, да и трафик всего 2-3Мбита на этой базе.

От железа не зависит - комплект полностью менялся и ситуация не изменилась. От уровня сигнала тоже не зависит - потери при сигнале от -65дб до -85дб одни и те же (ну плюс-минус что-то).

 

Может кто сталкивался с подобной проблемой?

Похожая проблема ((

 

БС - мтик 411АН

клиенты: наносы локо2 и баллеты2. В онлайне около 10 штук.

Пинги с близлежащих наносах к базе оч большие и с потерями (расстояние примерно 200-300 м. от базы).

Напротив, у дальних наносов все ОК. Потерь нет и пинги вменяемые (расстояние примерно от 700 метров до 2 км).

Пробовал уменьшать мощность на наносах - эффекта никакого.

 

Если смотреть с клиентов на базу:

у самого ближнего сигнал -55 дб

у дальнего - 69 дб

у ближнего TX Rate: 24 мбс (зажато в ручную), а RX Rate: 1 мбс

у дальнего TX Rate: 18 мбс (зажато в ручную), а RX Rate: 24 мбс

CCQ в обоих случаях 100%

 

почему у ближних клиентов RX Rate: 1 мбс ?

 

Подскажите куда копать.

Edited by maverick5

Share this post


Link to post
Share on other sites

Вы посмотрите как клиенты базу ловят с какими уровнями? Если есть перекос наносы плохо работают - все время пытаються поставить скорость больше чем надо. Поставьте базу в B-only и посмотрите изменилось что или нет?

Share this post


Link to post
Share on other sites
Вы посмотрите как клиенты базу ловят с какими уровнями? Если есть перекос наносы плохо работают - все время пытаються поставить скорость больше чем надо. Поставьте базу в B-only и посмотрите изменилось что или нет?

Ближайшие к базе уровни от -49 до -55

дальние -68 -70

 

На базе в данный момент G-only на наносах тоже самое.

если поставить базу в B-only - клиенты отвалятся? ведь у них G-only

 

проблема именно с ближайшими к базе клиентами

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this