Jump to content
Калькуляторы

Cisco2600+vlans+HP2512 не проходят пинги, прошу совета

Добрый день!

Пожалуйста, помогите советом.

Ситуация такова - есть свич НР2512 и раутер Cisco2600 с одним ethernet - портом.

На свиче подняты 2 Vlan - а, 1-ый включает порты 1-9, 11 и смотрит в локалку

2-й Vlan включает порт 10, он будет смотреть наружу.

12-й тегированный порт свича подключен к Ethernet - овскому порту раутера.

 

Проблема в том, что из локалки не могу пингануть рутер и наоборот.

 

Рутеру должен быть присвоен IP 192.168.1.253, у свича IP - 192.168.1.253

Конфиги свича и раутера приведены ниже -

 

Свич -

 

hostname "HP ProCurve Switch 2512"

cdp run

snmp-server community "public" Unrestricted

vlan 1

name "Local_Net"

untagged 1-9,11,13-14

ip address 192.168.1.253 255.255.255.0

tagged 12

no untagged 10

exit

vlan 2

name "OUT"

untagged 10

tagged 12

exit

no aaa port-access authenticator active

password manager

 

Раутер -

 

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname "WAY"

!

aaa new-model

aaa authentication login default local

aaa authorization exec default local

ip subnet-zero

!

interface FastEthernet0/0

description link to lan

no ip address

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/0.1

description Local_Net

encapsulation dot1Q 1 native

ip address 192.168.1.254 255.255.255.0

no cdp enable

!

interface FastEthernet0/0.2

description vlan Out

encapsulation dot1Q 2

ip address dhcp

no cdp enable

!

ip classlessip route 0.0.0.0 0.0.0.0 FastEthernet0/0.2

no ip http server

!

*********************************************************

Прошу - помогите пожалуйста советом, что делать. Чтобы полнее представить картину дал несколько команд,

 

ответы на которые привожу ниже -

 

--- на раутере -

 

sh ip route

 

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.1.0/24 is directly connected, FastEthernet0/0.1

 

sh arp

 

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.1.254 - 000b.be6d.74e0 ARPA FastEthernet0/0.1

 

--------------------

С уважением,

И.С.Магницкий

 

 

Share this post


Link to post
Share on other sites

Прошу прощения - небольшая опечатка, IP адрес раутера долженн быть 192.168.1.254

 

Добрый день!

Пожалуйста, помогите советом.

Ситуация такова - есть свич НР2512 и раутер Cisco2600 с одним ethernet - портом.

На свиче подняты 2 Vlan - а, 1-ый включает порты 1-9, 11 и смотрит в локалку

2-й Vlan включает порт 10, он будет смотреть наружу.

12-й тегированный порт свича подключен к Ethernet - овскому порту раутера.

 

Проблема в том, что из локалки не могу пингануть рутер и наоборот.

 

Рутеру должен быть присвоен IP 192.168.1.253, у свича IP - 192.168.1.253

Конфиги свича и раутера приведены ниже -

 

Свич -

 

hostname "HP ProCurve Switch 2512"

cdp run

snmp-server community "public" Unrestricted

vlan 1

name "Local_Net"

untagged 1-9,11,13-14

ip address 192.168.1.253 255.255.255.0

tagged 12

no untagged 10

exit

vlan 2

name "OUT"

untagged 10

tagged 12

exit

no aaa port-access authenticator active

password manager

 

Раутер -

 

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname "WAY"

!

aaa new-model

aaa authentication login default local

aaa authorization exec default local

ip subnet-zero

!

interface FastEthernet0/0

description link to lan

no ip address

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/0.1

description Local_Net

encapsulation dot1Q 1 native

ip address 192.168.1.254 255.255.255.0

no cdp enable

!

interface FastEthernet0/0.2

description vlan Out

encapsulation dot1Q 2

ip address dhcp

no cdp enable

!

ip classlessip route 0.0.0.0 0.0.0.0 FastEthernet0/0.2

no ip http server

!

*********************************************************

Прошу - помогите пожалуйста советом, что делать. Чтобы полнее представить картину дал несколько команд,

 

ответы на которые привожу ниже -

 

--- на раутере -

 

sh ip route

 

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.1.0/24 is directly connected, FastEthernet0/0.1

 

sh arp

 

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.1.254 - 000b.be6d.74e0 ARPA FastEthernet0/0.1

 

--------------------

С уважением,

И.С.Магницкий

Share this post


Link to post
Share on other sites

...

12-й тегированный порт свича подключен к Ethernet - овскому порту раутера.

...

vlan 1

tagged 12

...

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

...

Вот эти строчки между собой не бьются.

Самое просто решение - на vlan1 поставьте untagged 12.

Share this post


Link to post
Share on other sites

Вот эти строчки между собой не бьются.

Самое просто решение - на vlan1 поставьте untagged 12.

Да все там бьется человек не имеет основных понятий

 

2 imagnitsky вы, извините сами не понимаете до конца что делаете.

1. Влан 1 надо было оставить для управления.

2. Ну поскольку есть то что есть влан2 в данной ситуации нафиг не нужен.

3. И "наружу" на НР у вас получается 12 порт поскольку он прописан тегированным в обеих вланах,

если оставите связку такой как она есть то на циске порт тоже должен быть тегированным, в 1 и в 2 влане.

Share this post


Link to post
Share on other sites

Насчет "не понимаю до конца того, что делаю" и "не имею основных понятий" - несколько грубовато. Да, опыт небольшой, но ситуацию вырулил, за что большое спасибо уважаемому SergeiK. Cisco и HP немного по-разному понимают, что такое default vlan, на opennet.ru мелькнуло несколько статей на эту тему. Решилось все относительно просто, создал Vlan №3, да дефолтном Vlane оставил 1 свободный порт, все порты и сетку перенес в №3, и все пошло, пинги побежали.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.