Jump to content
Калькуляторы

Мультикаст на 2950T

Есть два c2950T-24. Потребовалось с одного на другой перобросить MVR. Hа 1м

свитче источником MVR является порт 5. Соединены они по гигабитным портам,

там транк, проброшена куча vlan. Hа первом свитче не удается указать порт транка как

mvr receiver - кошка ругается что транк не может быть приемником

mvr. Однако на втором свитче позволила назначить этот транк как mvr source.

Думал все получится - фиг там. При приходе запроса на подписку через этот

транк, первый свитч ругается что "запрос на мультикаст с порта, не

являющегося mvr".

Отсюда 2 вопроса:

1. Можно ли вообще пробросить mvr корректно через транки?

2. Если подать mvr с первого свитча на второй не транком, а отдельным

кабелем, прописав на первом этот порт как receiver, а на втором как source -

как избежать петель и последующей блокировки портов? Ведь свитчи соединятся

двумя отдельными линками.

 

Share this post


Link to post
Share on other sites

Видимо никто на 2950 такой фигней не страдает. Тогда подскажите, не будет ли таких проблем на 3750 (3760). Подают же люди как-то mvr на коммутаторы доступа, явно в транке причем.

Share this post


Link to post
Share on other sites

MVR на транковом порту работает только на 'операторских' коробках (ME 3400, ME 2400, 3750-ME etc).

Не очень понятно, зачем нужен MVR для того, чтобы подать Multicast на коммутатор доступа. Почему-бы просто не отдать Multicast VLAN в транке?

Share this post


Link to post
Share on other sites

Отдавал в транке. Когда приходит запрос на подписку от клиента за таким транком, то циска ругается "mvr-запрос на НЕ-mvr порту" и ничего не работает. Т.е. порт обязательно должен быть mvr-receiver, а этого как раз циска сделать не дает.

Edited by grfmaniak

Share this post


Link to post
Share on other sites
Отдавал в транке. Когда приходит запрос на подписку от клиента за таким транком, то циска ругается "mvr-запрос на НЕ-mvr порту" и ничего не работает. Т.е. порт обязательно должен быть mvr-receiver, а этого как раз циска сделать не дает.

Я имел ввиду отдавать в транке БЕЗ MVR на верхнем коммутаторе. MVR только на коммутаторе доступа.

Share this post


Link to post
Share on other sites

Там ситуация такая, что нужно с обоих этих свитчей раздавать клиентам мультикаст :)

Share this post


Link to post
Share on other sites
Там ситуация такая, что нужно с обоих этих свитчей раздавать клиентам мультикаст :)

а они оба цепочкой включены?

Share this post


Link to post
Share on other sites

Они в разных зданиях и объединены по гигабитным портам. В один из них мультикаст вещается и раздается, в другой надо прокинуть и тоже раздать.

Share this post


Link to post
Share on other sites

все транковые порты обозначаешь как source, все пользовательские порты обозначаешь как receiver

мультикаст влан на транковых портах должен везде быть прокинут.

 

source—Configure uplink ports that receive and send multicast data as

source ports. Subscribers cannot be directly connected to source ports.

All source ports on a switch belong to the single multicast VLAN.

 

http://www.cisco.com/en/US/docs/switches/l...ide/swgigmp.pdf

 

 

 

если не получится, кидай весь конфиг сюда с обеих свичей

Share this post


Link to post
Share on other sites
все транковые порты обозначаешь как source, все пользовательские порты обозначаешь как receiver

мультикаст влан на транковых портах должен везде быть прокинут.

---

если не получится, кидай весь конфиг сюда с обеих свичей

Кидаю.

 

Свитч с вещателем (в нем успешно принимают мультикаст):

 

mvr vlan 999

mvr

mvr group 239.192.10.1

mvr group 239.192.10.2

mvr group 239.192.10.3

mvr group 239.192.10.4

 

interface FastEthernet0/5

description Media Server eth0 (IPTV)

switchport access vlan 999

switchport mode access

mls qos cos override

mvr type source

spanning-tree portfast

!

 

interface GigabitEthernet0/2

description Link to LAZ

switchport trunk native vlan 100

switchport trunk allowed vlan 100-112,999

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

 

Что на нем видно:

 

sw2#sh mvr in

Port Type Status Immediate Leave

---- ---- ------- ---------------

Fa0/1 RECEIVER ACTIVE/UP DISABLED

Fa0/5 SOURCE ACTIVE/UP DISABLED

Fa0/9 RECEIVER ACTIVE/UP DISABLED

Fa0/10 RECEIVER ACTIVE/UP DISABLED

Fa0/11 RECEIVER ACTIVE/UP DISABLED

Fa0/13 RECEIVER ACTIVE/UP DISABLED

Fa0/14 RECEIVER ACTIVE/UP DISABLED

Fa0/15 RECEIVER ACTIVE/UP DISABLED

Fa0/16 RECEIVER ACTIVE/UP DISABLED

Fa0/17 RECEIVER ACTIVE/DOWN DISABLED

Fa0/18 RECEIVER ACTIVE/UP DISABLED

Fa0/22 RECEIVER ACTIVE/UP DISABLED

 

sw2#sh mvr mem

MVR Group IP Status Members

------------ ------ -------

239.192.10.1 ACTIVE Fa0/5(s)

239.192.10.2 ACTIVE Fa0/5(s)

239.192.10.3 ACTIVE Fa0/5(s), Fa0/22(d)

 

sw2#sh mvr

MVR Running: TRUE

MVR multicast VLAN: 999

MVR Max Multicast Groups: 256

MVR Current multicast groups: 16

MVR Global query response time: 5 (tenths of sec)

MVR Mode: compatible

 

sw2#sh vlan id 999

 

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

999 VLAN0999 active Fa0/5, Fa0/23, Gi0/2

 

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

999 enet 100999 1500 - - - - - 0 0

 

 

 

Свитч во втором здании (в нем клиент на порту 12 пытается принять группу 239.192.10.1, но ничего не выходит):

 

mvr vlan 999

mvr

mvr group 239.192.10.1

mvr group 239.192.10.2

mvr group 239.192.10.3

mvr group 239.192.10.4

 

!

interface FastEthernet0/12

switchport access vlan 100

switchport mode access

mvr type receiver

!

 

interface GigabitEthernet0/2

description Link to building 2

switchport trunk native vlan 100

switchport trunk allowed vlan 100-112,999

switchport mode trunk

switchport nonegotiate

speed 1000

mvr type source

!

 

 

c2950-laz1#sh mvr mem

MVR Group IP Status Members

------------ ------ -------

239.192.10.1 ACTIVE Fa0/12(d), Gi0/2(s)

239.192.10.2 ACTIVE Gi0/2(s)

 

c2950-laz1#sh mvr interface

Port Type Status Immediate Leave

---- ---- ------- ---------------

Fa0/11 RECEIVER ACTIVE/DOWN DISABLED

Fa0/12 RECEIVER ACTIVE/UP DISABLED

Gi0/2 SOURCE ACTIVE/UP DISABLED

 

c2950-laz1#sh mvr

MVR Running: TRUE

MVR multicast VLAN: 999

MVR Max Multicast Groups: 256

MVR Current multicast groups: 16

MVR Global query response time: 5 (tenths of sec)

MVR Mode: compatible

 

c2950-laz1#sh vlan id 999

 

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

999 IPTV active Gi0/1, Gi0/2

 

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

999 enet 100999 1500 - - - - - 0 0

 

 

Логи со свитча, где не удается принять мультикаст, из них видно что в пределах этого свитча клиент на группу подписывается и gi0/2 установлен source:

 

Jun 25 15:12:44 c2950-laz1 1637: 003912: Jun 25 04:12:44.638: IGMPSN: group: MVR takes pkt in Vlan 100

Jun 25 15:12:44 c2950-laz1 1638: 003913: Jun 25 04:12:44.638: MVR: Igsn: processing group report for 239.192.10.

1 on port 11, vlan 100

Jun 25 15:12:44 c2950-laz1 1639:

Jun 25 15:12:44 c2950-laz1 1640: 003914: Jun 25 04:12:44.638: IGMPSN: group: Received V2 report for group 239.19

2.10.1 received on Vlan 999, port Fa0/12

Jun 25 15:12:44 c2950-laz1 1641: 003915: Jun 25 04:12:44.638: IGMPSN: group: Adding client ip 10.3.114.4, port_i

d Fa0/12, on vlan 999 for proxy reporting

Jun 25 15:12:44 c2950-laz1 1642: 003916: Jun 25 04:12:44.638: IGMPSN: group: Added port Fa0/12 to group 239.192.

10.1

Jun 25 15:12:45 c2950-laz1 1643: 003917: Jun 25 04:12:44.638: IGMPSN: group: MVR takes pkt in Vlan 100

Jun 25 15:12:45 c2950-laz1 1644: 003918: Jun 25 04:12:44.642: MVR: Igsn: processing group report for 239.255.255

.250 on port 11, vlan 100

Jun 25 15:12:45 c2950-laz1 1645:

Jun 25 15:12:45 c2950-laz1 1646: 003919: Jun 25 04:12:45.034: Packet type 1 sent to IGMP PI in VLAN 999

Jun 25 15:12:45 c2950-laz1 1647: 003920: Jun 25 04:12:45.034: IGMPSN: router: Received non igmp pak on Vlan 999,

port Gi0/2

Jun 25 15:12:45 c2950-laz1 1648: 003921: Jun 25 04:12:45.034: IGMPSN: router: PIMV2 Hello packet

Jun 25 15:12:49 c2950-laz1 1649: 003922: Jun 25 04:12:48.262: Packet type 0 sent to IGMP PI in VLAN 999

Jun 25 15:12:49 c2950-laz1 1650: 003923: Jun 25 04:12:48.266: IGMPSN: group: MVR takes pkt in Vlan 999

Jun 25 15:12:49 c2950-laz1 1651: 003924: Jun 25 04:12:48.266: MVR: Igsn: processing group report for 224.0.0.13

on port 25, vlan 999

Jun 25 15:12:49 c2950-laz1 1652:

Jun 25 15:12:49 c2950-laz1 1653: 003925: Jun 25 04:12:48.782: Packet type 0 sent to IGMP PI in VLAN 999

Jun 25 15:12:49 c2950-laz1 1654: 003926: Jun 25 04:12:48.782: IGMPSN: group: MVR takes pkt in Vlan 999

Jun 25 15:12:49 c2950-laz1 1655: 003927: Jun 25 04:12:48.782: MVR: Igsn: processing group report for 224.0.0.2 o

n port 25, vlan 999

Jun 25 15:12:49 c2950-laz1 1656:

Jun 25 15:12:51 c2950-laz1 1657: 003928: Jun 25 04:12:50.038: IGMPSN: timer: Vlan 999 report timer expired

 

 

Однако группа не льется с первого свитча, потому как на нем в логах только это:

Jun 25 15:21:45 192.168.1.6 7544: Jun 25 04:21:44.840: Packet type 1 sent to IGMP PI in VLAN 2

Jun 25 15:21:45 192.168.1.6 7545: Jun 25 04:21:44.844: Packet type 1 sent to IGMP PI in VLAN 2

Jun 25 15:21:45 192.168.1.6 7546: Jun 25 04:21:44.844: Packet type 1 sent to IGMP PI in VLAN 999

Jun 25 15:21:45 192.168.1.6 7547: Jun 25 04:21:44.844: IGMPSN: router: Received non igmp pak on Vlan 999, port Fa0/5

 

И никаких признаков запросов через транк gi0/2. Его вообще нет в списке по sh mvr int

 

sw2#sh mvr in

Port Type Status Immediate Leave

---- ---- ------- ---------------

Fa0/1 RECEIVER ACTIVE/UP DISABLED

Fa0/5 SOURCE ACTIVE/UP DISABLED

Fa0/9 RECEIVER ACTIVE/UP DISABLED

Fa0/10 RECEIVER ACTIVE/UP DISABLED

Fa0/11 RECEIVER ACTIVE/UP DISABLED

Fa0/13 RECEIVER ACTIVE/UP DISABLED

Fa0/14 RECEIVER ACTIVE/UP DISABLED

Fa0/15 RECEIVER ACTIVE/UP DISABLED

Fa0/16 RECEIVER ACTIVE/UP DISABLED

Fa0/17 RECEIVER ACTIVE/DOWN DISABLED

Fa0/18 RECEIVER ACTIVE/UP DISABLED

Fa0/22 RECEIVER ACTIVE/UP DISABLED

 

Edited by grfmaniak

Share this post


Link to post
Share on other sites

g0/2 на первом свиче(в конфиге нету) и g0/1 на втором свиче тоже надо обозначить как mvr type source

 

это немного не логично но именно так оно должно работать.

Share this post


Link to post
Share on other sites
g0/2 на первом свиче(в конфиге нету) и g0/1 на втором свиче тоже надо обозначить как mvr type source

 

это немного не логично но именно так оно должно работать.

Заработало :) Огромное Спасибо :) Но совсем непонятно почему :)

В порт g0/1 на втором свитче вообще ничего не подключено, каким боком на нем mvr source? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this