Jump to content
Калькуляторы

вопрос о пачкорде между вланами на Catalyst 2950 непонимаю...

Добрый день!

Есть удаленный офис, у провайдера1 арендован влан точка-точка. Необходимо через этот влан дать интернет от провайдера2. Влан идет на узел связи, там стоит калалист, принимает линк от провайдера 1:

interface FastEthernet0/20
switchport trunk native vlan 411
switchport trunk allowed vlan 383,411
switchport mode trunk
no ip address
mls qos cos 6
no cdp enable

(383 влан точка-точка, 411 влан - интернет).

В этом же каталисте принимается линк от провайдера 2:

interface FastEthernet0/21
switchport trunk native vlan 11
switchport trunk allowed vlan 11,414
switchport mode trunk
no ip address
duplex full
speed 100
mls qos cos 7
no cdp enable

(11 - влан интернета провайдера 2, используется только на этом каталисте, 414 влан - для управления, от этого порта идет линк в цыску 2811.)

Есть порт 18 и 19 .Хочу сделать пачкорд между ними. Порты принадлежат разным вланам.

interface FastEthernet0/18
switchport access vlan 11
no ip address
duplex full
speed 100
no cdp enable
!
interface FastEthernet0/19
switchport access vlan 383
no ip address
duplex full
speed 100
no cdp enable

 

Вставляю пачкор - получается кольцо... Или я чегото не понимаю, или глючит каталист?

 

Switch#sh ver

Cisco Internetwork Operating System Software

IOS ™ C2950 Software (C2950-I6Q4L2-M), Version 12.1(12c)EA1, RELEASE SOFTWARE (fc1)

Copyright © 1986-2002 by cisco Systems, Inc.

Compiled Sun 24-Nov-02 23:31 by antonino

Image text-base: 0x80010000, data-base: 0x80562000

 

ROM: Bootstrap program is CALHOUN boot loader

 

Switch uptime is 36 minutes

System returned to ROM by power-on

System image file is "flash:/c2950-i6q4l2-mz.121-12c.EA1.bin"

 

cisco WS-C2950-24 (RC32300) processor (revision H0) with 21002K bytes of memory.

Processor board ID FOC0708Y1BH

Last reset from system-reset

Running Standard Image

24 FastEthernet/IEEE 802.3 interface(s)

 

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:0C:30:86:5A:C0

Motherboard assembly number: 73-5781-11

Power supply part number: 34-0965-01

Motherboard serial number: FOC07080FX8

Power supply serial number: DAB070516UV

Model revision number: H0

Motherboard revision number: A0

Model number: WS-C2950-24

System serial number: FOC0708Y1BH

Configuration register is 0xF

Share this post


Link to post
Share on other sites

установи на всякий случай на аксесс портах switchport mode access

Share this post


Link to post
Share on other sites

>> Есть порт 18 и 19 .Хочу сделать пачкорд между ними. Порты принадлежат разным вланам.

 

порты эти на каких железках находятся?

Share this post


Link to post
Share on other sites

Подождите, я верно понял, что вы хотите воткнуть патчкорд в два разных порта одного свитча?

Share this post


Link to post
Share on other sites

насколько я понял, человек получил от провайдера влан каторый в его сети не ходит по транспорту и ему нужно поменять этому влану id

Share this post


Link to post
Share on other sites

да, два разных порта одного свитча. порты принадлежат разным вланам. оба порта в режиме access mode.

 

t0ly верно, примерно это и хочу сделать

Share this post


Link to post
Share on other sites

как вариант там может ходить stp трафик

и ты таки пробывал указать switchport mode access?

 

Share this post


Link to post
Share on other sites

Ну ***ец, приехали.

 

Какой ***й аксесс? Как такое вообще в голову могло придти - объединение двух вланов на одном свитче с помощью патчкорда? Кто вам вообще пароль от железки дал?

Share this post


Link to post
Share on other sites

и чего так паниковать? рабочая себе схема ;)

Share this post


Link to post
Share on other sites
Ну ***ец, приехали.

 

Какой ***й аксесс? Как такое вообще в голову могло придти - объединение двух вланов на одном свитче с помощью патчкорда? Кто вам вообще пароль от железки дал?

жду предложений, как сделать иначе

Share this post


Link to post
Share on other sites

жду предложений, как сделать иначе

Каталист не трогайте, на роутере 2811 поднимите интерфейс во влан 383 и разруливайте трафик на L3.

Share this post


Link to post
Share on other sites

в чём проблема? 2950 насколько я помню анализирует и мак и vlanid

Share this post


Link to post
Share on other sites

каталист не глючит, скорее всего это отрабатывает stp. сделайте

interface range FastEthernet0/18 -19

spanning-tree bpdufilter enable

!

PS.

только если по какой-то не обозначенной здесь причине трафик запетлюется, разгребайте сами :)

Edited by Мартен

Share this post


Link to post
Share on other sites
только если по какой-то не обозначенной здесь причине трафик запетлюется, разгребайте сами :)
+1 )

Лучше действительно на роутере, как выше советовали...

Share this post


Link to post
Share on other sites

не спортивно, + бывают варианты когда ... разны случаи вобщем бывают

Share this post


Link to post
Share on other sites

буду пробовать разные варианты завтра или в воскресенье.

Share this post


Link to post
Share on other sites

не совсем понял как на 2811 разрулить траф.

interface FastEthernet0/0

description CLT

ip address 192.168.168.1 255.255.255.0 secondary

ip address 8хх.ххх.ххх.1 255.255.255.0

ip access-group 101 in

ip access-group 102 out

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex full

speed 100

vlan-id dot1q 383

exit-vlan-config

!

traffic-shape group 128 128000 7936 7936 1000

traffic-shape group 129 1024000 25600 25600 1000

traffic-shape group 130 256000 7936 7936 1000

traffic-shape group 131 512000 12800 12800 1000

no cdp enable

no mop enabled

!

или же надо делать fa0/0.383

Суть такая, что мне надо выпускать сетку 8х.ххх.ххх.0/24 в инет. на fa0/1 настроен айпишнек провайдера.

ip route 0.0.0.0 0.0.0.0 81.ууу.ууу.53
Если поднимаю интерфейс 0/0.383, то не могу использовать теже настройки, что и на интерфейсе 0.0

Share this post


Link to post
Share on other sites

А какая у вас адресация в 383 сети используется? Тоже 192.168.168.0?

Share this post


Link to post
Share on other sites

хочется, чтобы адресация в 383 была такая же как и в сети на fa0/0, в этом и был весь смысл извращений

Share this post


Link to post
Share on other sites

secondary адрес на 0/0 служит для сброса статистики НФ.

Share this post


Link to post
Share on other sites

Тогда смысл извращений понятен, извините за эмочиональный ответ ранее.

 

А с провом не получится на q-in-q договориться?

Share this post


Link to post
Share on other sites

q-in-q не вариант... мне не разрулить его каталистом моим. Другого оборудования нету...

Share this post


Link to post
Share on other sites

А вам его и не надо разруливать, для каталиста это будет обычный транковый порт. Главное, чтобы провайдер умел.

Share this post


Link to post
Share on other sites

провайдер1 дает влан между точками. а интернет идет через провайдера2. Не много не понял, где тут ку ин ку?

если что, то на второй точке, там нету вланов, идет чистая маршрутизация.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this