Jump to content
Калькуляторы

Mikrotik тонкая настройка

поставил микротик 3.10 настроил, интернет есть, все хорошо

поставил pppoe-сервер, пользователи подключаются/отключаются без проблем

но вот в чем вопрос: интернет есть в любом случае, авторизован ли пользователь через pppoe или не авторизован

подскажите как разрешить доступ в интернет только авторизованным пользователям

(можно еще неавторизованных отправлять на локальный сайт с темой вроде "авторизуйтесь пож-ста")

заранее спасибо

Share this post


Link to post
Share on other sites

поставь маскарад только для ИП пула ПППоЕ, или сделай денай в форварде для адресов локалки

Share this post


Link to post
Share on other sites

если маскарад поменять с

[admin@MikroTik] > ip firewall nat add chain=srcnat action=masquerade src-address=0.0.0.0/0

на

[admin@MikroTik] > ip firewall nat add chain=srcnat action=masquerade src-address=192.168.0.221

то это ничего не дает, только немного увеличивается время запроса ( странички медленней открываюца, аська медленней грузится(не сама скорость уменьшилась, а увеличилось время запроса)

 

или сделай денай в форварде для адресов локалки
об этом поподробнее плиз
Edited by boo

Share this post


Link to post
Share on other sites

Если медленно открываются странички - значит через другой интерфейс идет ДНС и клиенты дуплятся на нем..

Дай список правил форвардинга и маскарада, я скажу где подправитьт

Share this post


Link to post
Share on other sites
Если медленно открываются странички - значит через другой интерфейс идет ДНС и клиенты дуплятся на нем..

Дай список правил форвардинга и маскарада, я скажу где подправитьт

никаких особых настроек нет

[admin@MikroTik] > ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0   chain=srcnat action=masquerade src-address=0.0.0.0/0
[admin@MikroTik] > ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0  ;;; allow established connections
     chain=input action=accept connection-state=established

1  ;;; allow related connections
     chain=input action=accept connection-state=related

2  ;;; allow UDP
     chain=input action=accept protocol=udp

3  ;;; allow Icmp ping
     chain=input action=accept protocol=icmp

 

а вот с ДНС йа не пойму почему так, потому что у меня в роутере один вход, одих выход, пакет никуда завернуть не мог, DNS провайдера жестко прописаны

 

хотя пока писал понял вроде в чем проблема, это не потому что у меня маскарадица на 0.0.0.0/0, а йа прописывал src-address=192.168.0.221?

Share this post


Link to post
Share on other sites

Люди помогите пожалуйста чайничку !!!

 

Есть две сетки 192.168.X.X и 172.16.X.X, соединены микротиком. Микротик стоит голый, без настроек. Пропускает трафик в обе стороны. Как сделать так, чтобы 192 сеть могла видеть 172, а наоборот - нет (то есть из 172 не видели 192) ??? Какие маршруты и че ваще делать ???

Share this post


Link to post
Share on other sites

UP плиз мою тему, а то так и разрешилась проблема с доступом только через pppoe

Share this post


Link to post
Share on other sites

похоже на проблему с MTU/MRU, что касаемо фаервола - а нафига у тебя эти 3 правила в нате ??

какая у тебя подсетка выдается на ПППоЕ интерфейсы ?

Share this post


Link to post
Share on other sites
похоже на проблему с MTU/MRU, что касаемо фаервола - а нафига у тебя эти 3 правила в нате ??

какая у тебя подсетка выдается на ПППоЕ интерфейсы ?

настраивал по ману, оставил =)

выдается 192.168.0.0

уточните плиз что нужно сделать для правильной работы

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this