Перейти к содержимому
Калькуляторы

2950 dhcp snooping

Есть такой 2950 :

IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA10a, RELEASE SOFTWARE (fc2)
cisco WS-C2950G-48-EI (RC32300) processor (revision J0) with 19918K bytes of memory.
Processor board ID FOC0708Y1AT
Last reset from system-reset
Running Enhanced Image
48 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

Очень бы хотелось настроить на нем dhcp snooping , вроде все элементарно , но не работает :(

Куски конфига относящиеся к этому делу :

show run | include dhcp
ip dhcp relay information option
ip dhcp snooping vlan 2
ip dhcp snooping vlan 33
ip dhcp-server 192.168.25.29


interface Vlan33
ip address 192.168.25.20 255.255.255.192
ip helper-address 192.168.25.29
ip dhcp relay information trusted
no ip route-cache

(UPLINK PORT)
interface FastEthernet0/30
...
switchport trunk allowed vlan ...,33,...
...
ip dhcp snooping trust

vlan 2 - users

vlan 33 - управл.

ip dhcp snooping на vlan 33 в конфиге вкл для эксперимента - включай/выключай все равно нифига не работает.

когда говорим ip dhcp snooping каталист не желает форвардить ничего на dhcp server , в логе видим такую картинку:

 

 

163049: DHCP_SNOOPING: process new DHCP packet, message type: DHCPINFORM
163050: DHCP_SNOOPING: add relay information option.
163051: DHCP_SNOOPING_SW: Encoding opt82 in vlan-mod-port format
163052: DHCP_SNOOPING: binary dump of relay info option, length: 20 data:
0x52 0x12 0x1 0x6 0x0 0x4 0x0 0x2 0x0 0x20 0x2 0x8 0x0 0x6 0x0 0xC 0x31 0x0 0x63 0x40 
163053: pm_mat_get_entry: Unable to find entry in mac table for vlan 2, checking vlan-independent table
163054: pm_mat_get_entry: Unable to find entry in vlan-independent mac table
163055: DHCP_SNOOPING_SW: bridge packet get invalid mat entry: FFFF.FFFF.FFFF, packet is flooded to ingress VLAN: (2)
163056: DHCP_SNOOPING_SW: bridge packet output port set is null, packet is dropped.
1

 

Может кто сталкивался? Что ему не нравится интересно..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

dhcp сервер на каком порту ? Висит на другом свиче за аплинком ?

С той стороны и на порту dhcpd сделан ip dhcp snooping trust ?

 

Это можно убрать:

 

>ip dhcp-server 192.168.25.29

 

Покажи вывод sh ip dhcp snooping

Изменено пользователем kuru

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

sw0-c2950#sho ip dhcp snooping 
Switch DHCP snooping is disabled
DHCP snooping is configured on following VLANs:
2
Insertion of option 82 is enabled
Interface                    Trusted     Rate limit (pps)
------------------------     -------     ----------------
FastEthernet0/30             yes         unlimited
FastEthernet0/41             no          30

 

На "Switch DHCP snooping is disabled" не смотрим.

Сервер на Fa0/30 (вернее туда уходит vlan 33) в котором и живет сервак , между ниме еще неск. свитчей.

С той стороны никакого snooping не включено . Проблема то в том что этот гадский 2950 и посылать то нифига не пытается.

Может ios нужен другой? Хотя вроде последний залит..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

sw0-c2950#sho ip dhcp snooping

Switch DHCP snooping is disabled

 

На "Switch DHCP snooping is disabled" не смотрим.

Это как ? Оно должно быть enabled.

Не достаточно просто сказать ip dhcp snooping vlan 2

Должно быть еще:

>ip dhcp snooping

 

swic32#sh ip dhcp snooping

Switch DHCP snooping is enabled

DHCP snooping is configured on following VLANs:

2,4,6

Insertion of option 82 is enabled

Interface Trusted Rate limit (pps)

------------------------ ------- ----------------

FastEthernet0/1 no 100

FastEthernet0/2 no 100

FastEthernet0/3 no 100

FastEthernet0/4 no 100

...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Понятно что enabled должно быть , вот только свитче юзеры висят :)

Так что переодически что нибудь меняю , говорю ip dhcp snooping , убеждаюсь что оно

опять не работает , ну и no ip dhcp snooping.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Юзерам от этого ничего не будет.

Я бы dhcp snooping limit rate включил.

 

На L3 интерфейсе вилана 2 должен быть ip helper

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ставил. Не помогает (да и странно если бы помогло - он же shutdown полюбому). Вобщемто я уже попробовал сделать все что только можно. Может какая _ббааалллььшая_ хитрость там есть о которой надо знать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Есть несколько Cisco Catalyst 2950.

Хочется воспользоваться Option 82 в связке c ISC DHCP.

В связи с чем несколько вопросов:

 

1. Option-82 работает только c EMI или SMI тоже подойдет ?

2. Возможно ли использовать Option-82 без DHCP Snooping ?

3. 2950 вроде как L2, как и когда он изменяет DHCP запросы ?

4. Trust нужно выставить на порту DHCP сервера или на клиентских тоже?

5. Если в качестве роутера поставить L3 свич (3550 или 3750), будут ли отличия в настройках ?

6. Какая версия ISC DHCP предпочтительней 3 или 4, и есть ли особенности при сборке?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Попробовал собрать стенд. DHCP выдает, но Option 82 на сервак не приходит.

Снифернул траффик - в пакетах его действительно нет.

 

Куда копать ?!?!

 

_____

 

Схема:

 

ISC DHCP Сервер - Cisco Catalyst 2950 - Клиент

 

FastEthernet0/1 - Сервер

FastEthernet0/2 - Клиент

 

Немного из конфига:

 

# show version

Cisco Internetwork Operating System Software

IOS C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA11, RELEASE SOFTWARE (fc2)

...

Running Enhanced Image

...

Model number: WS-C2950T-24

...

 

# show ip dhcp snooping

Switch DHCP snooping is enabled

DHCP snooping is configured on following VLANs:

401

Insertion of option 82 is enabled

Interface Trusted Rate limit (pps)

------------------------ ------- ----------------

FastEthernet0/1 yes unlimited

FastEthernet0/2 yes unlimited

FastEthernet0/3 yes unlimited

FastEthernet0/4 yes unlimited

 

# show running-config | include dhcp

ip dhcp relay information option

ip dhcp snooping vlan 401

ip dhcp snooping

ip dhcp snooping trust

ip dhcp snooping trust

 

# show running-config

...

interface FastEthernet0/1

switchport access vlan 401

switchport mode access

switchport nonegotiate

ip dhcp snooping trust

!

interface FastEthernet0/2

switchport access vlan 401

switchport mode access

switchport nonegotiate

ip dhcp snooping trust

...

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хоть тема и старая, но для меня актуальная.

Релаьно ли настроить на WS-C2950G-48-EI DHCP opt 82 ?? Где то вроде попадалась инфа что именно в серии "...-EI" опц.82 не полностью рабочая.

У кого получилось стукните в личку или в асю 330735784, буду очень признателен, за реальную помощь в настройке согласен поделиться небольшим количеством финансов))))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хоть тема и старая, но для меня актуальная.

Релаьно ли настроить на WS-C2950G-48-EI DHCP opt 82 ?? Где то вроде попадалась инфа что именно в серии "...-EI" опц.82 не полностью рабочая.

У кого получилось стукните в личку или в асю 330735784, буду очень признателен, за реальную помощь в настройке согласен поделиться небольшим количеством финансов))))

 

Все там отлично работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас