Jump to content
Калькуляторы

VLAN IPTV по WI-FI

Доброго времени суток. Есть такая задача.

Приходит шнурок от Ростелеком в hAP ac^2 на первый интерфейс. В шнурке влан 3040 на интернет и 553 на иптв. Нужно создать вифи мост из двух hAP ac^2, передать по этому мосту 553 влан на иптв, и подключить ТВ приставку ко второму микротику. Выкладываю текущие конфиги.

Скрытый текст

[admin@MikroTik] > export compact 
# mar/24/2020 16:24:01 by RouterOS 6.46.4
# software id = FJY0-JVHW
#
# model = RBD52G-5HacD2HnD
# serial number = B4A00BB3382C
/interface bridge
add name=lan
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n disabled=no frequency=auto mode=ap-bridge ssid=MikroTik-2
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-Ceee disabled=no frequency=auto mode=ap-bridge ssid=MikroTik-5
/interface vlan
add interface=ether1 name=vlan553_iptv vlan-id=553
add interface=ether1 name=vlan3040_internet vlan-id=3040
/interface pppoe-client
add add-default-route=yes dial-on-demand=yes disabled=no interface=vlan3040_internet name=pppoe-out password=****** use-peer-dns=yes user=******
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=30m mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=******
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=lan ranges=192.168.88.100-192.168.88.200
/ip dhcp-server
add address-pool=lan disabled=no interface=lan lease-time=1d name=lan
/interface bridge port
add bridge=lan interface=wlan1
add bridge=lan interface=wlan2
add bridge=lan interface=ether2
add bridge=lan interface=ether3
add bridge=lan interface=ether4
add bridge=lan interface=ether5
add bridge=lan interface=vlan553_iptv
/ip address
add address=192.168.88.1/24 interface=lan network=192.168.88.0
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall filter
add action=accept chain=input comment="accept establish & related INPUT" connection-state=established,related
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=drop chain=input comment="drop all not from lan" in-interface=!lan
add action=accept chain=forward comment="accept established & related FORWARD" connection-state=established,related
add action=drop chain=forward comment="drop invalid" connection-state=invalid
add action=drop chain=forward comment="drop all from WAN to LAN" connection-nat-state=!dstnat connection-state=new in-interface=pppoe-out
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out
/system clock
set time-zone-name=Europe/Moscow
 

Скрытый текст

[admin@MikroTik] > export compact 
# jan/05/1970 04:27:20 by RouterOS 6.46.4
# software id = ZLVD-63WU
#
# model = RBD52G-5HacD2HnD
# serial number = BEEB08C26F25
/interface bridge
add name=bridge1
add name=iptv protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=0 country=no_country_set \
    frequency-mode=manual-txpower mode=station-bridge ssid=MikroTik-2
set [ find default-name=wlan2 ] antenna-gain=0 band=5ghz-n/ac channel-width=\
    20/40/80mhz-Ceee country=no_country_set disabled=no frequency=auto \
    frequency-mode=manual-txpower mode=station-bridge ssid=MikroTik-5
/interface vlan
add interface=wlan2 name=vlan553_iptv vlan-id=553
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=********
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=wlan1
add bridge=iptv interface=vlan553_iptv
add bridge=iptv interface=ether5
/ip address
add address=192.168.88.3/24 interface=ether1 network=192.168.88.0
/ip dns
set servers=192.168.88.1
/ip route
add disabled=yes distance=1 gateway=192.168.88.1

 

При такой настройке иптв приставка получает по DHCP от Ростелекома ип адрес и т.д., но затыкается с ошибкой "Невозможно синхронизировать время с сервером".

Если я объединяю влан553 и пятый интерфейс на первом роутере и включаю туда шнурком приставку, то она получает точно такой же ип адрес, но ошибки синхронизацию времени нет. 

 

Для наглядности прикрепляю картинку. Что я делаю не так?

fullsizeoutput_739.jpeg

 

UPD. Разобрался. На втором роутере нужно было просто WLAN и ether5 в мост объединить, vlan там не нужен.

 

Все заработало, но картинка тормозит и на 2,4 и на 5ГГц. Каналы свободны, трафик потока идет всего 4мбит. Можно чего накрутить или по вафле не будет ИПТВ нормально показывать?

Edited by rembrent

Share this post


Link to post
Share on other sites

мультикаст в вафле, внутри  вафли подымите eoip туннель и по нему уже подключите приставку, проблема исчезнет. 

Share this post


Link to post
Share on other sites

На первом роутере назначил на wlan1 адрес 172.16.0.1. Создал еоип туннель с ремоут адресом 172.16.0.3. Объединил wlan1, eoip, vlan553 в мост.

На втором роутере назначил на wlan1 адрес 172.16.0.3. Создал еоип туннель с ремоут адресом 172.16.0.1. Объединил wlan1, eoip, ether5 в мост.

1

Скрытый текст

[admin@MikroTik] > export compact

# mar/25/2020 17:36:13 by RouterOS 6.46.4

# software id = FJY0-JVHW

#

# model = RBD52G-5HacD2HnD

# serial number = B4A00BB3382C

/interface bridge

add name=iptv protocol-mode=none

add name=lan

/interface eoip

add disabled=yes mac-address=02:D3:FC:92:25:50 name=eoip-iptv remote-address=\

    172.16.0.3 tunnel-id=1

/interface vlan

add interface=ether1 name=vlan553_iptv vlan-id=553

add interface=ether1 name=vlan3040_internet vlan-id=3040

/interface bridge port

add bridge=iptv interface=wlan1

add bridge=lan interface=ether2

add bridge=lan interface=ether3

add bridge=lan interface=ether4

add bridge=lan interface=ether5

add bridge=iptv interface=vlan553_iptv

add bridge=lan interface=wlan2

add bridge=iptv interface=eoip-iptv

/ip address

add address=192.168.88.1/24 interface=lan network=192.168.88.0

add address=172.16.0.1/24 interface=wlan1 network=172.16.0.0

2

Скрытый текст

[admin@MikroTik] > export compact

# mar/25/2020 17:25:05 by RouterOS 6.46.4

# software id = ZLVD-63WU

#

/interface bridge

add name=bridge1

add name=iptv protocol-mode=none

/interface eoip

add disabled=yes mac-address=02:A5:65:B3:D9:81 name=eoip-iptv remote-address=\

    172.16.0.1 tunnel-id=1

/interface bridge port

add bridge=bridge1 interface=wlan2

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether2

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether4

add bridge=iptv interface=wlan1

add bridge=iptv interface=ether5

add bridge=iptv interface=eoip-iptv

/ip address

add address=192.168.88.3/24 interface=bridge1 network=192.168.88.0

add address=172.16.0.3/24 interface=wlan1 network=172.16.0.0

 

 

Приставка запускается, вместо видео черный экран, и звук "как кассету жует". 

 

При этом в логе первого роутера

Скрытый текст

17:16:50 interface,warning eoip-iptv: bridge port received packet with own address as source address (c4:ad:34:75:43:f5), probably loop 
17:16:55 interface,warning eoip-iptv: bridge port received packet with own address as source address (c4:ad:34:75:43:f5), probably loop 
17:17:00 interface,warning eoip-iptv: bridge port received packet with own address as source address (c4:ad:34:75:43:f5), probably loop 
17:17:05 interface,warning eoip-iptv: bridge port received packet with own address as source address (c4:ad:34:75:43:f5), probably loop 
17:17:10 interface,warning eoip-iptv: bridge port received packet with own address as source address (c4:ad:34:75:43:f5), probably loop 
17:17:15 interface,warning wlan1: bridge port received packet with own address as source address (02:d3:fc:92:25:50), probably loop 
17:17:20 interface,warning wlan1: bridge port received packet with own address as source address (02:d3:fc:92:25:50), probably loop 
17:17:25 interface,warning wlan1: bridge port received packet with own address as source address (02:d3:fc:92:25:50), probably loop 

второй роутер

Скрытый текст

17:18:42 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:18:47 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:18:52 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:18:57 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:02 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:07 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:12 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:17 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:22 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:27 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:32 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
17:19:37 interface,warning eoip-iptv: bridge port received packet with own address as source address (cc:2d:e0:91:6c:2e), probably loop 
 

 

Edited by rembrent

Share this post


Link to post
Share on other sites

адреса вешать не на wlan а на бридж

 

создаете еще один бридж в который :  на стороне приставки добавляете порты   ether и eoip

стороне роутера  в бридж добавляете  vlan 553 и eoip

 

а вы намешали все в кучу.

Share this post


Link to post
Share on other sites

Что намешал - согласен, каюсь.

Я wlan1 отдал чисто для моста между роутерами, зачем мне его в этом случае в lan бридж добавлять?

Может тогда нужно адреса для еоип тунеля все таки назначить на wlan1 на роутерах, создать бриджи как вы сказали - vlan553 и eiop на первом и eoip и ether5 на втором?

 

upd. Попробовал так сделать. Приставка получает ип адрес от провайдера, но до конца не загружается. Выпадает с ошибкой "Невозможно получить настройки от балансировщика"

 

Скрытый текст

/interface eoip
add mac-address=02:D3:FC:92:25:50 name=eoip-iptv remote-address=172.16.0.3 tunnel-id=1
/interface bridge port
add bridge=lan interface=ether2
add bridge=lan interface=ether3
add bridge=lan interface=ether4
add bridge=lan interface=ether5

add bridge=lan interface=wlan2

add bridge=iptv interface=vlan553_iptv
add bridge=iptv interface=eoip-iptv
/ip address
add address=192.168.88.1/24 interface=lan network=192.168.88.0
add address=172.16.0.1/24 interface=wlan1 network=172.16.0.0
 

Скрытый текст

/interface eoip
add mac-address=02:A5:65:B3:D9:81 name=eoip-iptv remote-address=172.16.0.1 tunnel-id=1
/interface bridge port
add bridge=lan interface=wlan2
add bridge=lan interface=ether1
add bridge=lan interface=ether2
add bridge=lan interface=ether3
add bridge=lan interface=ether4
add bridge=iptv interface=ether5
add bridge=iptv interface=eoip-iptv
/ip address
add address=192.168.88.3/24 interface=lan network=192.168.88.0
add address=172.16.0.3/24 interface=wlan1 network=172.16.0.0
 

 

Edited by rembrent

Share this post


Link to post
Share on other sites

читайте внимательно что вам пишут и  подписывайте от какого роутера показываете конфиг  и у вас лажа

 

и зачем вам еще адреса для туннеля?  есть же адреса на LAN

Share this post


Link to post
Share on other sites

Мне не нужно wlan1 (2.4ггц) пускать в lan, я хочу чтобы wlan1 передавал только iptv и все. wlan2 (5ггц) работает в бридже lan.

 

Я тогда не понимаю как еще мне создать еоип тунель внутри интерфейсов wlan1-wlan1 роутеров.

Для него же нужны ип адреса, соответственно, если wlan1 не состоит ни в каком бридже, то ип адреса я вешаю прямо на него. Создаю еоип тунель, в нем с обоих сторон прописываю ип адреса wlan1 и тунель поднимается. Дальше на первом роутере я делаю мост из еоип и vlan553, на втором роутере делаю мост из еоип и ether5 (куда подключена приставка).

 

Конфиги первого и второго роутера соответственно.

 

Я все внимательно прочитал и сделал как посоветовали (кроме бриджа wlan1). Объясните пожалуйста почему лажа и что я тут недопонимаю?

Edited by rembrent

Share this post


Link to post
Share on other sites

ну тогда я просто недопонял по вашим схемам,  .... но идея такая, уже лет так 10 наверное у мя в загородный дом мультикаст от прова с тв приходит, 3,6 км эфир уже засран но работает ровно.

Share this post


Link to post
Share on other sites

Может надо роутер DD-RWT заменить тоже на микротик?

Share this post


Link to post
Share on other sites

надеюсь  роутеры соединяете по радио в режиме прозрачного моста? (wds)

Share this post


Link to post
Share on other sites

Роутеры были в режиме AP bridge <> Station Bridge. Сделал WDS небольшие затыки в видео остались, но не критично. Пробовал еоип внутри wds сделать - приставка не запускается. Забил, оставил как есть. Параллельно выявил проблему с потеряй пакетов при подключении второго роутера, но это уже в другой топик. Спасибо за помощь. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this