Jump to content
Калькуляторы

Mikrotik & SIP

Настраиваю Asterisk. Провайдер (Beeline) авторизует по IP, без логина и пароля.

Настроил проброс портов IP-провайдера:5060 => IP-Asterisk:5060, естественно только с IP-провайдера.

Запускаю Asterisk – peer unreachable (недоступен). Лезу в Winbox — пакетов 0. Проверяю настройки, все Ок (вроде не дурак я).

Запускаю Wiresnark — пакеты идут ! Микротик — 0 пакетов ! В задумчивости чешу репу и иду курить интернет.

Накурившись вдоволь узнаю, что в Mikrotik есть встроеный обработчик SIP протокола. Поэтому пакеты и не видны в Firewall.

По умолчанию он включен, рекомендуют отключить. С радостью отключаю и предвкушая решение всех проблем проверяю.

Пакеты уходят, провайдер отвечает… и пакеты теряются в недрах Микротика, но не все!

Часть фиксируются как прошедшие через NAT (очень редко).

Кто нибудь настраивал Микротик для Asterisk (или подобные) и может помочь ?

Share this post


Link to post
Share on other sites

Конфиг то будет? С астериксом там ваще изи. В этом случае АЛГ лучше отключить. На астерикс делаете проборос SIP и RTP. Ну и астерик должен проксировать конечно, иначе пляски будут

Share this post


Link to post
Share on other sites

Я со включенным sip alg настраивал как-то (даже не вспомнил про него), но микротик подменял адрес источника (с белого на серый) у пакетов, идущих на сервер РТ. Решил банально, отключил получение default route (неважно какая метрика) в серой сети.

 

Кроме проброса портов, трафик еще в forward разрешить надо. Есть какая-то хитрая галочка типа "connection nat state", но я не пробовал.

Share this post


Link to post
Share on other sites

Ну как то так в Mikrotik и на Asterisk в настройках SIP 

 

/ip firewall filter
add action=accept chain=forward comment="voip asterisk" dst-port=5060-5065,5160,4569,10000-20000 in-interface=bridge_wan protocol=udp src-address-list=voip
add action=accept chain=forward dst-address-list=voip dst-port="" out-interface=bridge_wan protocol=udp src-port=5060-5065,5160,4569,10000-20000

 

/ip firewall nat
add action=dst-nat chain=dstnat comment="FREEPBX SIP" dst-port=5060-5065,5160,4569,10000-20000 in-interface=bridge_wan protocol=udp src-address-list=voip to-addresses=XXX.XXX.XXX.XXX

 

/ip firewall address-list
add address=sip.zebra.ru list=voip
add address=sip.zadarma.ru list=voip

 

/ip firewall service-port

set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes ports=5060,5061,5160 sip-direct-media=no
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
 

###################################################################

 

Файл sip_general_additional.conf

 

;--------------------------------------------------------------------------------;
;          Do NOT edit this file as it is auto-generated by FreePBX.             ;
;--------------------------------------------------------------------------------;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO - Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate.                                                         ;
;--------------------------------------------------------------------------------;
faxdetect=no
useragent=FPBX-14.0.13.4(13.22.0)
language=ru
disallow=all
allow=alaw
allow=ulaw
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41
alwaysauthreject=yes
limitonpeers=yes
allowguest=no
progressinband=yes
prematuremedia=no
rtpend=20000
context=from-sip-external
callerid=Unknown
rtpstart=10000
tcpenable=no
callevents=yes
bindport=5160
jbenable=no
checkmwi=10
maxexpiry=3600
minexpiry=60
srvlookup=no
tlsenable=no
allowguest=no
notifyhold=yes
rtptimeout=30
canreinvite=no
tlsbindaddr=[::]:5161
rtpkeepalive=0
videosupport=no
defaultexpiry=120
notifyringing=yes
maxcallbitrate=384
rtpholdtimeout=300
g726nonstandard=no
registertimeout=20
tlsclientmethod=tlsv1
registerattempts=0
nat=no
ALLOW_SIP_ANON=no
tlscafile=/etc/pki/tls/certs/ca-bundle.crt
localnet=XXX.XXX.XXX.XXX/24

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.