Jump to content
Калькуляторы

snr 2965 loopback-detection

Доброго времени суток. Столкнулся с такой ситуацией. На линии стоит Dlink DGS-3420-26SC оптическим портом соединён с SNR 2965_24T в 25 порт. С SRN 2965_24T в 23 порт воткнута магистраль на следующее оборудование snr 2965_8T в 7 порт. Со стороны snr 2965_8T идёт петля и не один из двух snr её не замечает. Тем самым вырубается оптический порт на Dlink DGS-3420-26SC. Можете ткнуть пальцем где я и что не правильно настроил?

 

Конфиг 2965_24T

 

SNR-S2965-24T#sh version
  SNR-S2965-24T Device, Compiled on Sep 12 11:18:50 2018
  sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
  CPU Mac f8:f0:82:78:2f:b9
  Vlan MAC f8:f0:82:78:2f:b8
  SoftWare Version 7.0.3.5(R0241.0276)
  BootRom Version 7.2.33
  HardWare Version 2.0.1
  CPLD Version N/A
  Serial No.:SW073420H914003059
  Copyright (C) 2018 NAG LLC
  All rights reserved
  Last reboot is cold reset.
  Uptime is 0 weeks, 0 days, 18 hours, 17 minutes
 

 

service password-encryption
!
!
ssh-server enable
!
snmp-server enable
snmp-server securityip *.*.*.*
snmp-server securityip *.*.*.*
snmp-server community ro 7 *******
snmp-server user initial initial
snmp-server group ****** noauthnopriv read Community
snmp-server view CommunityView 1. include
snmp-server view CommunityView 1.3.6.1.6.3. exclude
snmp-server enable traps
!
ip forward-protocol udp bootps
!
!
ip dhcp snooping enable
!
!
!
logging *.*.*.*
!
!
!
!
!
loopback-detection interval-time 10 3
!
loopback-detection control-recovery timeout 30
!
loopback-detection trap enable
!
vlan 1 
!
vlan *
 name управляющий влан
!
ip multicast source-control
!
storm-control pps
!
firewall enable
!
access-list 110 deny tcp any-source any-destination d-port 135
access-list 110 deny tcp any-source any-destination d-port 136
access-list 110 deny tcp any-source any-destination d-port 137
access-list 110 deny tcp any-source any-destination d-port 138
access-list 110 deny tcp any-source any-destination d-port 139
access-list 110 deny tcp any-source any-destination d-port 445
access-list 110 deny tcp any-source any-destination d-port 1900
access-list 110 deny tcp any-source any-destination d-port 2869
access-list 110 deny udp any-source any-destination d-port 135
access-list 110 deny udp any-source any-destination d-port 136
access-list 110 deny udp any-source any-destination d-port 137
access-list 110 deny udp any-source any-destination d-port 138
access-list 110 deny udp any-source any-destination d-port 139
access-list 110 deny udp any-source any-destination d-port 445
access-list 110 deny udp any-source any-destination d-port 1900
access-list 110 deny udp any-source any-destination d-port 2869
access-list 110 permit ip any-source any-destination
access-list 110 deny tcp any-source s-port 135 any-destination
access-list 110 deny udp any-source s-port 135 any-destination
access-list 110 deny tcp any-source s-port 136 any-destination
access-list 110 deny udp any-source s-port 136 any-destination
access-list 110 deny tcp any-source s-port 137 any-destination
access-list 110 deny udp any-source s-port 137 any-destination
access-list 110 deny tcp any-source s-port 138 any-destination
access-list 110 deny udp any-source s-port 138 any-destination
access-list 110 deny tcp any-source s-port 139 any-destination
access-list 110 deny udp any-source s-port 139 any-destination
access-list 110 deny tcp any-source s-port 445 any-destination
access-list 110 deny udp any-source s-port 445 any-destination
access-list 110 deny tcp any-source s-port 1900 any-destination
access-list 110 deny udp any-source s-port 1900 any-destination
access-list 110 deny tcp any-source s-port 2869 any-destination
access-list 110 deny udp any-source s-port 2869 any-destination
 
!
userdefined-access-list standard offset window1 l4start 0 window2 l4start 2 
userdefined-access-list standard 1204 deny packet-type ipv4 window1 89 ffff window2 89 ffff
userdefined-access-list standard 1204 deny packet-type ipv4 window1 8a ffff window2 8a ffff
!
Interface Ethernet1/0/1
 switchport mode trunk
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/21
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 ip dhcp snooping trust
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/22
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 ip dhcp snooping trust
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/23 /// Уход на SNR 2965_8T
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 ip dhcp snooping trust
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/24
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 ip dhcp snooping trust
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/25 // Приход с Dlink DGS-3420-26SC
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан
 ip dhcp snooping trust
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
interface управляющий влан
 ip address *.*.*.* 255.0.0.0
 
!
sntp server *.*.*.* version 2
!
no login
!
!
captive-portal
!
end

 

 

Конфиг с 2965_8T

 

ip forward-protocol udp bootps
!
!
ip dhcp snooping enable
!
!
!
!
!
!
!
loopback-detection interval-time 10 3
!
loopback-detection control-recovery timeout 30
!
loopback-detection trap enable
!
vlan 1 
!
vlan *
 name управляющий влан
!
ip multicast source-control
!
firewall enable
!
access-list 110 deny tcp any-source any-destination d-port 135
access-list 110 deny tcp any-source any-destination d-port 136
access-list 110 deny tcp any-source any-destination d-port 137
access-list 110 deny tcp any-source any-destination d-port 138
access-list 110 deny tcp any-source any-destination d-port 139
access-list 110 deny tcp any-source any-destination d-port 445
access-list 110 deny tcp any-source any-destination d-port 1900
access-list 110 deny tcp any-source any-destination d-port 2869
access-list 110 deny udp any-source any-destination d-port 135
access-list 110 deny udp any-source any-destination d-port 136
access-list 110 deny udp any-source any-destination d-port 137
access-list 110 deny udp any-source any-destination d-port 138
access-list 110 deny udp any-source any-destination d-port 139
access-list 110 deny udp any-source any-destination d-port 445
access-list 110 deny udp any-source any-destination d-port 1900
access-list 110 deny udp any-source any-destination d-port 2869
access-list 110 permit ip any-source any-destination
access-list 110 deny tcp any-source s-port 135 any-destination
access-list 110 deny udp any-source s-port 135 any-destination
access-list 110 deny tcp any-source s-port 136 any-destination
access-list 110 deny udp any-source s-port 136 any-destination
access-list 110 deny tcp any-source s-port 137 any-destination
access-list 110 deny udp any-source s-port 137 any-destination
access-list 110 deny tcp any-source s-port 138 any-destination
access-list 110 deny udp any-source s-port 138 any-destination
access-list 110 deny tcp any-source s-port 139 any-destination
access-list 110 deny udp any-source s-port 139 any-destination
access-list 110 deny tcp any-source s-port 445 any-destination
access-list 110 deny udp any-source s-port 445 any-destination
access-list 110 deny tcp any-source s-port 1900 any-destination
access-list 110 deny udp any-source s-port 1900 any-destination
access-list 110 deny tcp any-source s-port 2869 any-destination
access-list 110 deny udp any-source s-port 2869 any-destination
 
!
userdefined-access-list standard offset window1 l4start 0 window2 l4start 2 
userdefined-access-list standard 1204 deny packet-type ipv4 window1 89 ffff window2 89 ffff
userdefined-access-list standard 1204 deny packet-type ipv4 window1 8a ffff window2 8a ffff
!
Interface Ethernet1/0/1
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/2
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/3
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/4
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/5
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/6
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 loopback-detection specified-vlan 1;управляющий влан
 loopback-detection control shutdown
 ip dhcp snooping action blackhole recovery 3600
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/7 //// Приход с 2965_24T
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан
 ip dhcp snooping trust
 loopback-detection specified-vlan 1
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic
!
Interface Ethernet1/0/8
 switchport mode trunk
 switchport trunk allowed vlan управляющий влан 
 ip dhcp snooping trust
 loopback-detection specified-vlan 1
 loopback-detection control shutdown
 storm-control broadcast 16
 storm-control multicast 16
 storm-control unicast 16
 ip access-group 110 in traffic-statistic

 

 

Не один из SNR не видит петлю. Заранее спасибо за отзыв.

Share this post


Link to post
Share on other sites

52 minutes ago, Aleksey Sonkin said:

@Egro 
Добрый день!
С какого порта S2965-8T идет петля? Какое оборудование там подключено?

 

на 5 порту 2965_8T видна петля. В него воткнут неуправляемый коммутатор с абонентами. В логах обнаружил выключение порта. Но почему она пробегает дальше и её не вырубает 2965_24T? У него в логах вообще не фиксируется петля.

Edited by Kroys

Share this post


Link to post
Share on other sites

20 минут назад, Kroys сказал:

Но почему она пробегает дальше и её не вырубает 2965_24T

попробуйте сократить интервал с 10 до 1 секунды. скорей всего 3420 просто видит петлю первым и тушит ее. 

Share this post


Link to post
Share on other sites

2 minutes ago, darkagent said:

попробуйте сократить интервал с 10 до 1 секунды. скорей всего 3420 просто видит петлю первым и тушит ее. 

 

Поставил 5 это минимальное значение. Спасибо за ответ. Посмотрим что будет дальше

Share this post


Link to post
Share on other sites

27 минут назад, darkagent сказал:

попробуйте сократить интервал с 10 до 1 секунды. скорей всего 3420 просто видит петлю первым и тушит ее. 

 

25 минут назад, Kroys сказал:

Поставил 5 это минимальное значение. Спасибо за ответ. Посмотрим что будет дальше

 

48 минут назад, Kroys сказал:

на 5 порту 2965_8T видна петля. В него воткнут неуправляемый коммутатор с абонентами. В логах обнаружил выключение порта. Но почему она пробегает дальше и её не вырубает 2965_24T? У него в логах вообще не фиксируется петля.

Скорее всего действительно проблема с таймингом. Менять в этой ситуации нужно второе значение. Первое - это частота отправки в момент, когда петля уже обнаружена и порт заблокирован. "Пробегает" дальше (точнее SNR-S2965-24T не блокирует порт), потому что SNR-S2965-8T при включенном loopback-detection будет отбрасывать lbd-пакеты от SNR-S2965-24T, таков механизм работы loopback-detection.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.