Jump to content
Калькуляторы

Балансировка агрегированного трафика на WS-C3550-12G

Приветствую.

Собрал агрегированный линк на WS-C3550-12G (с одной стороны) и Foundry BigIron с другой. Линк работает, по кольцу не падает, но с балансировкой не понятно что.

Настройка cisco такова:

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,3,511,555,556
 switchport mode trunk
!
...
!
interface GigabitEthernet0/9
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,3,511,555,556
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet0/10
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,3,511,555,556
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
...


Как выполнить балансировку?

Спасибо.

 

Возможно пригодится:

IPTV_158#show lacp ?
  <1-64>    Channel group number
  counters  Traffic information
  internal  Internal information
  neighbor  Neighbor information
  sys-id    LACP System ID

IPTV_158#show lacp 1 ?
  counters  Traffic information
  internal  Internal information
  neighbor  Neighbor information

IPTV_158#show lacp 1 ?
  counters  Traffic information
  internal  Internal information
  neighbor  Neighbor information

IPTV_158#show lacp 1 counters 
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 1
Gi0/9       31089  28743    0      0        0      0         0     
Gi0/10      31087  28744    0      0        0      0         0     

IPTV_158#show lacp 1 internal 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     

Channel group 1
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi0/9     SA      bndl      32768         0x1       0x1     0xA         0x3D  
Gi0/10    SA      bndl      32768         0x1       0x1     0xB         0x3D  

IPTV_158#show lacp 1 neighbor 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     

Channel group 1 neighbors

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi0/9     SP      1         0004.8074.6f00   3s    0x0    0x9C40 0x145   0x3C  
Gi0/10    SP      1         0004.8074.6f00   3s    0x0    0x9C40 0x146   0x3C


 

З.Ы. Сторона Foundry не интересна, т.к. на подобном примере трафик успешно агрегируется на линке Foundry BigIron -> Dlink DGS. Балансировка успешна.

Edited by default_vlan

Share this post


Link to post
Share on other sites
1 минуту назад, Butch3r сказал:

show etherchannel load-balance

#show etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
        dst-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Destination MAC address
  IPv4: Destination MAC address

 

Share this post


Link to post
Share on other sites

Поменяйте на src-dst-ip

conf t

port-channel load-balance src-dst-ip

Share this post


Link to post
Share on other sites
1 час назад, Butch3r сказал:

port-channel load-balance src-dst-ip

IPTV_158(config)#port-channel load-balance ?         
  dst-mac  Dst Mac Addr
  src-mac  Src Mac Addr

Или, или. выбрать src-mac?

UPD. К сожалению, чуда не произошло. Есть ли вероятность того, что в cisco можно агрегировать порты с "начала железа", скажем, только  gi0/1 и gi0/2 и прочее, а не 9 и 10, как в моем случае?

Edited by default_vlan

Share this post


Link to post
Share on other sites
#show etherchannel detail 
		Channel-group listing: 
		----------------------

Group: 1 
----------
Group state = L2 
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 1
Protocol:   LACP
Minimum Links: 0
		Ports in the group:
		-------------------
Port: Gi0/9
------------

Port state    = Up Mstr Assoc In-Bndl 
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi0/9     SA      bndl      32768         0x1       0x1     0xA         0x3D  

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi0/9     SP      1         0004.8074.6f00  28s    0x0    0x9C40 0x145   0x3C  

Age of the port in the current state: 10d:00h:18m:40s

Port: Gi0/10
------------

Port state    = Up Mstr Assoc In-Bndl 
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi0/10    SA      bndl      32768         0x1       0x1     0xB         0x3D  

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi0/10    SP      1         0004.8074.6f00  29s    0x0    0x9C40 0x146   0x3C  

Age of the port in the current state: 10d:00h:18m:39s

		Port-channels in the group: 
		---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 10d:01h:18m:41s
Logical slot/port   = 1/0          Number of ports = 2
HotStandBy port = null 
Port state          = Port-channel Ag-Inuse 
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel: 

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi0/9    Active             0
  0     00     Gi0/10   Active             0

Time since last port bundled:    10d:00h:18m:41s    Gi0/10
Time since last port Un-bundled: 10d:00h:18m:56s    Gi0/10

 

Share this post


Link to post
Share on other sites

Вам нужно выставить одинаковые методы балансировки с обеих сторон и всё получится.

Share this post


Link to post
Share on other sites

Номера портов на алгоритм балансировки не влияют.

Если железо умеет только по МАС-адресам, то что ещё Вы хотите?

 

9 минут назад, Butch3r сказал:

Вам нужно выставить одинаковые методы балансировки с обеих сторон и всё получится.

Это с какого бодуна? С каждой стороны надо выставлять метод балансировки в зависимости от необходимости. На другую сторону это не влияет.

Если с одной стороны 100500 МАС-адресов, а с другой всего один, то с первой надо ставить по src-mac, со второй по dst-mac.

Share this post


Link to post
Share on other sites
58 минут назад, Butch3r сказал:

Вам нужно выставить одинаковые методы балансировки с обеих сторон и всё получится.

В том и сложность, что связка Dlink DGS -> Foundry Работает без нареканий. В агрегации 8 портов.
Тут же - не понятно.

Share this post


Link to post
Share on other sites
57 минут назад, UglyAdmin сказал:

Номера портов на алгоритм балансировки не влияют.

Если железо умеет только по МАС-адресам, то что ещё Вы хотите?

 

Это с какого бодуна? С каждой стороны надо выставлять метод балансировки в зависимости от необходимости. На другую сторону это не влияет.

Если с одной стороны 100500 МАС-адресов, а с другой всего один, то с первой надо ставить по src-mac, со второй по dst-mac.

Я честно сказать никогда не использовал метод балансировки по макам. Я имел ввиду, что если с одной стороны стоит по mac то и сдругой стороны надо поставить по mac. А как именно - смотреть по факту. У меня везде src-dst-ip и работает отлично.

Share this post


Link to post
Share on other sites
8 минут назад, Butch3r сказал:

У меня везде src-dst-ip и работает отлично.

Когда есть src-dst-ip - никакой другой и не надо...

 

@default_vlan, а что у Вас не так с балансировкой и что за трафик в канале?

Share this post


Link to post
Share on other sites

eos/eol 3550 случился почти 10 лет назад. о чем речь вообще? вы хотите заставить мамонта делать то что он не умеет. стюардессу пора закопать. 

Share this post


Link to post
Share on other sites
6 минут назад, UglyAdmin сказал:

а что у Вас не так с балансировкой

image.thumb.png.4170a63b3db5226bc98ff351a5249371.png 
см. картинку.

 

 

7 минут назад, UglyAdmin сказал:

что за трафик в канале?

Пользовательский трафик до сервера доступа, мониторинг, офис и мультикаст

Share this post


Link to post
Share on other sites

Может, что и умеет:

https://www.cisco.com/c/ru_ru/support/docs/lan-switching/etherchannel/12023-4.html#cat2950_3550

Цитата

В коммутаторах серии 3550, когда используется пересылка МАС-адреса источника, распределение нагрузки на основе IP-адреса источника и назначения также активируется для маршрутизируемого IP-трафика. Все маршрутизируемые IP-трафики выбирают порт на основе IP-адреса источника и назначения.

Но src-dst-ip не умеет точно.

Share this post


Link to post
Share on other sites
5 минут назад, UglyAdmin сказал:

Может, что и умеет:

 

применительно к мультикасту не может, и не умеет. балансировка мультикаста - в принципе не тривиальная задача. и даже на форуме нага эта тема стабильно раз в 3 месяца поднимается.

google -> multicast etherchannel load-balance. 

Share this post


Link to post
Share on other sites
6 минут назад, default_vlan сказал:

image.thumb.png.4170a63b3db5226bc98ff351a5249371.png 
см. картинку.

В данном случае балансировку надо настраивать не на 3550, это в его сторону перегрузка, а не от него.

От него тоже не баланс, но до перегрузки ещё очень далеко.

 

3 минуты назад, darkagent сказал:

применительно к мультикасту не может, и не умеет. балансировка мультикаста - в принципе не тривиальная задача. и даже на форуме нага эта тема стабильно раз в 3 месяца поднимается.

Мультикаст - такой же IP-трафик, с src-IP (адрес источника) и dst-IP (адрес группы), его точно так же можно балансировать. На более-менее современных железках проблем не возникает...

Share this post


Link to post
Share on other sites
1 час назад, darkagent сказал:

применительно к мультикасту не может, и не умеет. балансировка мультикаста - в принципе не тривиальная задача. и даже на форуме нага эта тема стабильно раз в 3 месяца поднимается.

Разве? Нормально балансируется.

Share this post


Link to post
Share on other sites

Тут дело даже не в мультикасте. Я его и зарубить могу.
Проблема в том, что Foundry может балансировку сделать по L4, L3, L2, но только на JetCore. Этого слота у меня нет. Вывод - юзать то, что есть. А есть у нас один бегемот, который не балансирует никак, а второй - только с маками работает.
Балансировку не получится настроить, к сожалению.

Точнее не так.  Получится, но только после полной замены Foundry на что-то вменяемое.
Я хз как какая-то DGS может успешно балансировать 5Гбит/с трафика на 8 интерфейсах, а тут 2 в 2 не получается.

Edited by default_vlan

Share this post


Link to post
Share on other sites
29 минут назад, zhenya` сказал:

L3 ecmp?

Возможно. Это со стороны провайдера.

Share this post


Link to post
Share on other sites

Если это к магистралу, то просите разобрать портченел и вторую сессию дать. Medом разбалансите трафик.

Share this post


Link to post
Share on other sites
17 часов назад, pppoetest сказал:

Разве? Нормально балансируется.

А потом на другой стороне пакеты нормально приходят? в нужной очередности? В свое время на эти грабли наступали, на том оборудовании что было в то время так и не победили. Проще оказалось на 10-ку перейти

Share this post


Link to post
Share on other sites

Ну так всё же очевидно. У провайдера src-dst-ip а у вас по макам. Вот и балансирует на других свичах. По макам не будет такой красивой балансировки, меняйте железку.

Share this post


Link to post
Share on other sites
30 минут назад, Butch3r сказал:

меняйте железку

Этого мнения и придерживаюсь.

Всем спасибо.

Share this post


Link to post
Share on other sites
7 часов назад, Sacrament сказал:

А потом на другой стороне пакеты нормально приходят? в нужной очередности? В свое время на эти грабли наступали, на том оборудовании что было в то время так и не победили. Проще оказалось на 10-ку перейти

Вроде да. QoS настроен, дальше маркировка сохраняется.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now