Jump to content
Калькуляторы

LACP Port-channel ASR1004 - switch

Всем привет,

назрела потребность в расширении канала между маршрутизатором ASR1004 и коммутатором. Что сейчас имеется на ASR:

 

interface TenGigabitEthernet0/2/0
 no ip address
!
interface TenGigabitEthernet0/2/0.2
 description 1_SEGM
 encapsulation dot1Q 2
 ip address 192.168.0.1 255.255.255.0
!
interface TenGigabitEthernet0/2/0.4
 description 2_SEGM
 encapsulation dot1Q 4
 ip address 192.168.1.1 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key 26542587
 ip ospf priority 250
!
interface TenGigabitEthernet0/2/0.10
 description Other
 encapsulation dot1Q 10
 ip address 192.168.2.1 255.255.255.0

Можно ли сделать так на маршрутизаторе

interface Port-channel1
 no ip address
!
interface Port-channel1/0.2
 description 1_SEGM
 encapsulation dot1Q 2
 ip address 192.168.0.1 255.255.255.0
!
interface Port-channel1/0.4
 description 2_SEGM
 encapsulation dot1Q 4
 ip address 192.168.1.1 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key 26542587
 ip ospf priority 250
!
interface Port-channel1/0.10
 description Other
 encapsulation dot1Q 10
 ip address 192.168.2.1 255.255.255.0
!
interface TenGigabitEthernet0/1/0
description LACP to Switch
no ip address
channel-group 1 mode active
!
interface TenGigabitEthernet0/2/0
description LACP to Switch
no ip address
channel-group 1 mode active

Пробовать к сожалению времени нет. И не отвалится OSPF при этом?

 

Спасибо.

Share this post


Link to post
Share on other sites

Еще надо port-channel load-balance режим задать (иначе возможны приключения, и кстати надо читать доки глубоко, какие режимы поддерживаются самой cisco и на другой стороне одновременно), ну и надо понимать, что QoS потом на port-channel навешивать будет боль и страдание. 

Share this post


Link to post
Share on other sites

Отвалится всё. Ну точнее моргнёт, пока вы будете применять конфигурацию. Потому что вам сперва нужно будет очистить настройки порта TenGigabitEthernet0/1/0 и только потом на него пропишется channel-group

Лучше такие работы проводить с консоли, чтоб быть уверенным во всём

Share this post


Link to post
Share on other sites

Как уже сказали отвалится все во время изменения конфигурации. В данном случае лучше делать ecmp на OSPF, нет необходимости в ещё одно протоколе , нет l2, возможность «проапгрейдить» на лету и в дополнение второй интерфейс включить в другой свитч добавив таким образом resiliency 

Share this post


Link to post
Share on other sites
6 часов назад, Butch3r сказал:

Отвалится всё. Ну точнее моргнёт, пока вы будете применять конфигурацию. Потому что вам сперва нужно будет очистить настройки порта TenGigabitEthernet0/1/0 и только потом на него пропишется channel-group

Лучше такие работы проводить с консоли, чтоб быть уверенным во всём

Ну понятно что может моргнуть и отвалиться и ессно буду делать с консоли, это бгп бордер, времени более 5-10 мин нет, ну можно ночью не больше часа повозиться, а для опытов второй железки нет к сожалению, спасибо

 

20 часов назад, jffulcrum сказал:

Еще надо port-channel load-balance режим задать (иначе возможны приключения, и кстати надо читать доки глубоко, какие режимы поддерживаются самой cisco и на другой стороне одновременно), ну и надо понимать, что QoS потом на port-channel навешивать будет боль и страдание. 

поизучаю, сенкс

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this