Jump to content
Калькуляторы

vlan-trunk с помощью brdige (6.41+): доступ по arp

Здравствуйте!

С целью передачи двух раздельных сетей на удаленную точку посредством 1 кабеля использую vlan'ы на RB951 (прошивка 6.41.7). С одной стороны завожу 2 сети в роутер А, связываю транком роутеры А и Б, с другой стороны с роутера Б выдаю 2 сети клиентам (схема прилагается).

Screenshot_2.thumb.png.3999c0943bb2dee8ea1b86d62db79bf8.png

Конфиги:

Spoiler

Роутер А:

/interface bridge
add name=bridge1 vlan-filtering=yes
/interface vlan
add interface=bridge1 name=vlan101 vlan-id=101
add interface=bridge1 name=vlan102 vlan-id=102
/interface bridge port
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether1 pvid=101
add bridge=bridge1 interface=ether2 pvid=102
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether5 untagged=ether1 vlan-ids=101
add bridge=bridge1 tagged=bridge1,ether5 untagged=ether2 vlan-ids=102
/ip address
add address=10.0.1.55/24 interface=vlan101 network=10.0.1.0
add address=10.20.0.26/24 interface=vlan102 network=10.20.0.0

 

Spoiler

Роутер Б

/interface bridge
add name=bridge1 vlan-filtering=yes
/interface vlan
add interface=bridge1 name=vlan101 vlan-id=101
add interface=bridge1 name=vlan102 vlan-id=102
/interface bridge port
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether1 pvid=101
add bridge=bridge1 interface=ether3 pvid=102
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether5 untagged=ether1 vlan-ids=101
add bridge=bridge1 tagged=bridge1,ether5 untagged=ether3 vlan-ids=102
/ip address
add address=10.0.1.56/24 interface=vlan101 network=10.0.1.0
add address=10.20.0.27/24 interface=vlan102 network=10.20.0.0

 

Проблема: в WinBox сканирую соседние устройства, оба роутера отображаются. Но по ARP могу подключиться лишь к Роутеру А. К Роутеру Б получается подключится только по IP.

Вопрос: что я недонастроил, что не могу соединиться WinBox'ом с Роутером Б по ARP?

Share this post


Link to post
Share on other sites

Что значит подключиться по АРП? Вы про мак-телнет?

 

Share this post


Link to post
Share on other sites
On 31.08.2018 at 1:05 PM, VolanD666 said:

Что значит подключиться по АРП? Вы про мак-телнет?

 

Абсолютно верно. При этом если подключить ноут к любому эксесс-порту, то по мак-телнет винбокс заходит.

Edited by stakado

Share this post


Link to post
Share on other sites

Нельзя сделать нормальный доступ на роутер? Трафик идет на роутер когда пытаетесь подключиться (я про tool sniffer)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this