Jump to content
Калькуляторы

Загрузка Микротика с tftp

Доброго времени суток коллеги, возникла необходимость залить на SXT Lite5, новый образ в виде файла  Cn7-vmlinux-init.elf

перекопал кучу манов,  в частности по Tftpd64, но результата так и не получил, железка получает по DHCP ip адрес, а вот до загрузки дело не доходит.


Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:08.321]
DHCP: proposed address 10.0.90.11 [20/02 21:50:08.823]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:08.829]
DHCP: proposed address 10.0.90.11 [20/02 21:50:09.331]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:09.339]
DHCP: proposed address 10.0.90.11 [20/02 21:50:09.841]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:09.844]
DHCP: proposed address 10.0.90.11 [20/02 21:50:10.345]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:10.353]
DHCP: proposed address 10.0.90.11 [20/02 21:50:10.856]
 

Share this post


Link to post
Share on other sites
3 часа назад, rdmitrich сказал:

Доброго времени суток коллеги, возникла необходимость залить на SXT Lite5, новый образ в виде файла  Cn7-vmlinux-init.elf

перекопал кучу манов,  в частности по Tftpd64, но результата так и не получил, железка получает по DHCP ip адрес, а вот до загрузки дело не доходит.


Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:08.321]
DHCP: proposed address 10.0.90.11 [20/02 21:50:08.823]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:08.829]
DHCP: proposed address 10.0.90.11 [20/02 21:50:09.331]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:09.339]
DHCP: proposed address 10.0.90.11 [20/02 21:50:09.841]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:09.844]
DHCP: proposed address 10.0.90.11 [20/02 21:50:10.345]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 4C:5E:0C:74:2E:F5 [20/02 21:50:10.353]
DHCP: proposed address 10.0.90.11 [20/02 21:50:10.856]
 

 

А там в tftp64 баг в dhcp и именно из за этого микротик с него и не грузится. Используйте другой микротик в качестве dhcp/tftp или linux.

Share this post


Link to post
Share on other sites
1 минуту назад, adron2 сказал:

 

А там в tftp64 баг в dhcp и именно из за этого микротик с него и не грузится. Используйте другой микротик в качестве dhcp/tftp или linux.

пробовали, чет не взлетело , а у вас работало при такой схеме ?

Share this post


Link to post
Share on other sites

Вроде как на openwrg.org инфа есть.

Share this post


Link to post
Share on other sites
4 минуты назад, DAF сказал:

Вроде как на openwrg.org инфа есть.

Ага, читал )) Вы не вкурсе, есть нормальный tftp под винду ??

Share this post


Link to post
Share on other sites
17 minutes ago, rdmitrich said:

Ага, читал )) Вы не вкурсе, есть нормальный tftp под винду ??

cм. выше ответ от adron2.

И микрот и линукс можно в виде виртуалки. В качестве виртуальной линукс- машины под tftp-сервер вполне пойдет OpenWRT/LEDE-образ.

Сам использую как tftp-сервер свой RB2011. Так же на  ноуте стоит Virtual Box, в нем есть ВМ - mikrotik, LEDE, lubuntu. Все варианты рабочие.

 

Немного не по теме: микротик-ВМ на ноуте (сеть в режиме моста) дает дает массу возможностей, как-то: работать с vlan (если сетевая ноута не умеет) дополнительный удобный файервол, легко менять TTL при тетеринге через yota-планшет, много еще чего. 

Edited by DAF

Share this post


Link to post
Share on other sites
В 20.02.2018 в 20:55, rdmitrich сказал:

пробовали, чет не взлетело , а у вас работало при такой схеме ?

Я микротик только и использую в качестве tftp + dhcp. Уже пару сотен Хап/Хекс лайтов перешил так в LEDE. Никаких проблем.

Микротик настраивается как то так:

/ip pool
    add name=tmp-perexod-pool ranges=192.168.88.10-192.168.88.100
/ip dhcp-server
    add address-pool=tmp-perexod-pool authoritative=yes bootp-support=dynamic \
    disabled=no interface=ether1 lease-time=10s name=perexod-dhcp
/ip dhcp-server network
    add address=192.168.88.0/24 boot-file-name=/linux_t1.bin \
    gateway=192.168.88.1 netmask=24 next-server=192.168.88.1
/ip tftp
    add ip-addresses=192.168.88.0/24 real-filename=/linux_t1.bin req-filename=/linux_t1.bin

И на ether1 адрес вешаете 192.168.88.1/24

Ну и дальше bin/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf файл по ftp на него закидываете и называете этот файл linux_t1.bin.

Share this post


Link to post
Share on other sites
7 часов назад, adron2 сказал:

Я микротик только и использую в качестве tftp + dhcp. Уже пару сотен Хап/Хекс лайтов перешил так в LEDE. Никаких проблем.

Микротик настраивается как то так:


/ip pool
    add name=tmp-perexod-pool ranges=192.168.88.10-192.168.88.100
/ip dhcp-server
    add address-pool=tmp-perexod-pool authoritative=yes bootp-support=dynamic \
    disabled=no interface=ether1 lease-time=10s name=perexod-dhcp
/ip dhcp-server network
    add address=192.168.88.0/24 boot-file-name=/linux_t1.bin \
    gateway=192.168.88.1 netmask=24 next-server=192.168.88.1
/ip tftp
    add ip-addresses=192.168.88.0/24 real-filename=/linux_t1.bin req-filename=/linux_t1.bin

И на ether1 адрес вешаете 192.168.88.1/24

Ну и дальше bin/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf файл по ftp на него закидываете и называете этот файл linux_t1.bin.

Ну спасибо вам )) Сейчас заценим этот метод ))

Share this post


Link to post
Share on other sites
7 hours ago, adron2 said:

Я микротик только и использую в качестве tftp + dhcp.

Однако категорично.

Прошу прощения у ТС за то, что не совсем по теме (хотя и близко, вроде как ответ на вопрос "А собственно, зачем?". 

 

Предупреждение: все, что ниже - исключительно ИМХО.

При всех глюках неясной природы, закрытости и не самой свежей версии ядра лично мне гораздо комфортнее в CLI и особенно в Winbox от RoS, чем в WinSCP или консоли OpenWRT/LEDE. По Webfig и Luci скажу проще - первое всегда disabled, второе просто не ставлю. А от глюков RoS можно избавиться, если соблюдать несколько простых правил.

- Заметил, что часто остаются "хвосты" от старых настроек. Так однажды я вывел конфиг через export verbose вместо привычного export compact, и увидел давно ставшие ненужными new-route-mark="name" disabled=yes. Winbox и export compact ничего такого не показывали, но если зайти винбоксом в ip route, кликнуть + и раскрыть Routing Mark, то там кроме  main и действующих марок можно было выбрать name. И все просто - если новые правила всегда создавать, ненужные всегда удалять, но только НЕ редактировать одно в другое (особенно в Винбоксе), то таких "хвостов" не будет - проверено.

 

- Забыть о QuickSet. Совсем забыть.

 

- Девайс "искаропки" первым делом познакомить с Netintall, причем прошить отдельные пакеты, а не общий .npk (мне в большинстве случаев достаточно шести пакетов: advenced-tools, dhcp, ppp, security, system, wireless). При обновлениях прошивки не забывать обновлять загрузчик.

 

- При первом входе в систему после нетинсталл-чистки сразу сделать /system backup file=true-virgin.backup :) - всегда пригодится. Если есть готовый *.rsc, не копипастить его целиком в /, а последовательно по пунктам и с учетом зависимостей: назначить IP-адрес еще несуществующему bridge не получится. А после export compact порядок у настроек часто строго от балды.

 

- Ну и по мелочи: всегда явно указывать MAC для bridge, иначе он будет от первого поднявшегося интерфейса в мосте. Как такая ситуация: бридж это dhcp-клиент, dhcp-сервер выдает static-only аренды, порты бриджа - eoip1 и wlan1. EoIP поверх l2tp, wlan mode=ap-bridge, имеется только удаленный доступ. Неподалеку от ТД постоянно шляются смартфоны с верным паролем, а l2tp из-за неправильного MTU постоянно падает... Когда-то я чуть с ума не сошел пытаясь понять, почему вай-фай "все-все-как-в-родном-офисе-хотя-мы-в-гостях" то работает то нет.

Так же лучше будет в /ip route шлюзом по возможности назначать IP  а не интерфейс.

 

Еще раз - всё вышеописанное - ИМХО. Но я давно придерживаюсь этих правил и глюков в моих RoS-девайсах не замечал.

 

P.S. а вот если для OpenWRT/LEDE появится похожий на Winbox GUI..... 

 

 

 

Edited by DAF

Share this post


Link to post
Share on other sites
2 часа назад, rdmitrich сказал:

Не выходит каменный цветок....

tftp1.jpg

Все верно. А вы ребутните эту глючную хрень. У меня тоже как то было такое что команды ввел а он писал что permissions denied для tftp. Ребут помог :-D

Share this post


Link to post
Share on other sites
2 hours ago, rdmitrich said:

Не выходит каменный цветок....

tftp1.jpg

Слэш перед именем файла лишний. в real-filename точно

Edited by DAF

Share this post


Link to post
Share on other sites
8 часов назад, DAF сказал:

Однако категорично.

Прошу прощения у ТС за то, что не совсем по теме (хотя и близко, вроде как ответ на вопрос "А собственно, зачем?". 

 

Предупреждение: все, что ниже - исключительно ИМХО.

При всех глюках неясной природы, закрытости и не самой свежей версии ядра лично мне гораздо комфортнее в CLI и особенно в Winbox от RoS, чем в WinSCP или консоли OpenWRT/LEDE. По Webfig и Luci скажу проще - первое всегда disabled, второе просто не ставлю. А от глюков RoS можно избавиться, если соблюдать несколько простых правил.

...

 

 

 

 

Полностью с Вами согласен. Luci просто ужасен. В нем куча багов. Его лучше вообще не использовать. Да и стиль программирования на котором он написан мягко сказать странный. Трудно что либо быстро понять.

У меня свои разработки для управления и мониторинга LEDE роутеров. Они собственно и устраняют проблему с удобством настройки. Но к сожалению разработки коммерческие.

Share this post


Link to post
Share on other sites

req filename             запрашиваемое имя файла - должно соответствовать запросу

real-filename             реальное имя файла - соответствие в files

Share this post


Link to post
Share on other sites
5 минут назад, DAF сказал:

Слэш перед именем файла лишний. в real-filename точно

 

Нет. Там все верно. Вот скрит с работающего роутера:

image.thumb.png.49b3b5845861a33d884937117ef5e149.png

Share this post


Link to post
Share on other sites
4 minutes ago, adron2 said:

Нет. Там все верно. Вот скрит с работающего роутера:

image.thumb.png.49b3b5845861a33d884937117ef5e149.png

тогда в файлах потерялся. или нельзя с ним

 

повторюсь:

 

req filename             запрашиваемое имя файла - должно соответствовать запросу от клиента

real-filename             реальное имя файла - должно соответствитствовать имени в files

 

Edited by DAF

Share this post


Link to post
Share on other sites
37 minutes ago, adron2 said:

У меня свои разработки для управления и мониторинга LEDE роутеров. Они собственно и устраняют проблему с удобством настройки. Но к сожалению разработки коммерческие.

А demo/video имеется?

 

16 hours ago, adron2 said:

Я микротик только и использую в качестве tftp + dhcp. Уже пару сотен Хап/Хекс лайтов перешил так в LEDE. Никаких проблем.

Микротик настраивается как то так:


/ip pool
    add name=tmp-perexod-pool ranges=192.168.88.10-192.168.88.100
/ip dhcp-server
    add address-pool=tmp-perexod-pool authoritative=yes bootp-support=dynamic \
    disabled=no interface=ether1 lease-time=10s name=perexod-dhcp
/ip dhcp-server network
    add address=192.168.88.0/24 boot-file-name=/linux_t1.bin \
    gateway=192.168.88.1 netmask=24 next-server=192.168.88.1
/ip tftp
    add ip-addresses=192.168.88.0/24 real-filename=/linux_t1.bin req-filename=/linux_t1.bin

И на ether1 адрес вешаете 192.168.88.1/24

Ну и дальше bin/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf файл по ftp на него закидываете и называете этот файл linux_t1.bin.

так linux_t1.bin или /linux_t1.bin ?

Edited by DAF

Share this post


Link to post
Share on other sites
48 минут назад, DAF сказал:

А demo/video имеется?

 

так linux_t1.bin или /linux_t1.bin ?

 

пробовал и так, и так 

 в логах ERROR code0 strihg permission denied

Share this post


Link to post
Share on other sites
14 minutes ago, rdmitrich said:

пробовал и так, и так 

 в логах ERROR code0 strihg permission denied

Порт 69 случаем в файрволе не отключен? и глянь в контраке нет ли зависших tftp коннектов.

если не помогло, сноси все нах, ребоот и кофиг по новой. 

 

вообще я не заморачиваюсь с именами файлов если файл единственный, ставлю * и там и там (* - любой файл)

 

в смысле имя файла любое

 

Share this post


Link to post
Share on other sites

firewall вообще отключен, да и конфиг пару раз сбрасывал

Share this post


Link to post
Share on other sites
3 hours ago, rdmitrich said:

Не выходит каменный цветок....

tftp1.jpg

меня смущает скрин из этого поста. здесь тоже пробовал переименовывать?

 

file lbst --> file name

Share this post


Link to post
Share on other sites

тоже, с / и без него, а почему с расширением elf нельзя сразу залить ???

 

Edited by rdmitrich

Share this post


Link to post
Share on other sites
3 minutes ago, rdmitrich said:

тоже, с / и без него, а почему с расширением elf нельзя сразу залить ???

 

 

вообще зачем там нужно разрешение?

блин, прямо щас uart+tftp=раскирпичил tp-link никакого расшрения, имя tplink, прошивка влетела с первого запроса - как слива в ж...

тфтп на рб2011

 

пойду гляну wiki owrt

 

Share this post


Link to post
Share on other sites
В 21.02.2018 в 00:53, adron2 сказал:

 

А там в tftp64 баг в dhcp и именно из за этого микротик с него и не грузится. Используйте другой микротик в качестве dhcp/tftp или linux.

а он от 64 отличается ??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this