Jump to content
Калькуляторы

Не работает NAT с определенным выходным ip

Коллеги имеется сетка публичных адресов  x.x.x.130/28 interface=ether1-WAN network=84.x.x.128

обычный masquerade отрабатывает

однако src-nat не отрабатывает на выходной x.x.x.140  ( хотя делаю как там написанно https://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT#Source_nat_to_specific_address )

 

/ip firewall export
# dec/09/2017 17:55:20 by RouterOS 6.40.5
# software id = PL61-TESI
#
# model = CCR1036-12G-4S
# serial number = 851A07BC50A7
/ip firewall address-list
add address=193.y.71.0/24 list=nat_for_finance
/ip firewall nat
add action=src-nat chain=srcnat comment="for finance nat" out-interface=ether1-WAN src-address-list=nat_for_finance to-addresses=x.x.x.140

/ip address
add address=84.x.x.130/28 comment=general interface=ether1-WAN network=84.x.x.128
add address=193.y.71.1/24 interface=Finance network=193.y.71.0

 

Share this post


Link to post
Share on other sites
6 часов назад, shafiev сказал:

делаю как там написано

Нет не так, вы невнимательно читали. В вашем случае src-nat будет работать только с терминированным адресом, добавляйте x.x.x.140 на ether1-WAN.

Share this post


Link to post
Share on other sites
В 12/10/2017 в 01:28, DRiVen сказал:

Нет не так, вы невнимательно читали. В вашем случае src-nat будет работать только с терминированным адресом, добавляйте x.x.x.140 на ether1-WAN.

То есть мне достаточно добавить еще один ip для этого интерфейса и сделать на нем src nat ?

Share this post


Link to post
Share on other sites
В 12/10/2017 в 01:28, DRiVen сказал:

Нет не так, вы невнимательно читали. В вашем случае src-nat будет работать только с терминированным адресом, добавляйте x.x.x.140 на ether1-WAN.

То есть мне надо создать еще один айпи на интерфейсе и его указывать как выходной

Share this post


Link to post
Share on other sites

Да. К написанному вами выше нужно просто добавить

/ip address
add address=84.x.x.140/28 comment="for finance nat" interface=ether1-WAN network=84.x.x.128

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now