Jump to content
Калькуляторы

Ubuntu + Catalyst 3550 + Q-in-Q Не работает

Привет всем.

Не могу заставить работать Ubuntu с портотм 802.1Q-tunnel.

Конфиг Ubuntu:

# The loopback network interface
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual
post-up ip link add link eno1 eno1.440 type vlan proto 802.1ad id 440
post-up ip link set eno1.440 up

auto eno1.440
iface eno1.440 inet manual
post-up ip link add link eno1.440 eno1.440.1 type vlan proto 802.1Q id 1
post-up ip link set eno1.440.1 up
post-up ip link add link eno1.440 eno1.440.770 type vlan proto 802.1Q id 770
post-up ip link set eno1.440.770 up
post-up ip link add link eno1.440 eno1.440.771 type vlan proto 802.1Q id 771
post-up ip link set eno1.440.771 up

auto eno1.440.1
iface eno1.440.1 inet static
	address 10.10.254.253
	netmask 255.255.0.0
	dns-nameservers 8.8.8.8
	up route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.10.0.1
	up route add -net 192.168.0.0 netmask 255.255.0.0 gw 10.10.0.1
	up route add -net 10.160.1.0 netmask 255.255.255.0 gw 10.10.0.8
	up route add -net 10.160.4.0 netmask 255.255.255.0 gw 10.10.0.8
	up route add -net 10.160.8.0 netmask 255.255.255.0 gw 10.10.0.17
	up route add -net 10.160.2.0 netmask 255.255.255.0 gw 10.10.0.3

auto eno1.440.770
iface eno1.440.770 inet static
        address 10.140.1.253
        netmask 255.255.255.0
		network 10.140.1.0
        broadcast 10.140.1.255
        vlan_raw_device eno1

auto eno1.440.771
iface eno1.440.771 inet static
        address 10.140.2.253
        netmask 255.255.255.0
		network 10.140.2.0
        broadcast 10.140.2.255
        vlan_raw_device eno1

И конфиг 3550:

Building configuration...

Current configuration : 2886 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TEST_3550_24
!
enable secret 5 $1$S8x8$zsHUcwS0PvQm8OHs65bOE0
enable password ena1
!
no aaa new-model
ip subnet-zero
ip routing
!
vtp domain CISCO
vtp mode transparent
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 1
 tb-vlan1 1002
 tb-vlan2 1003
!
vlan 440,770-771,1000 
!
vlan 1002
 tb-vlan1 1
 tb-vlan2 1003
!
vlan 1003
 tb-vlan1 1
 tb-vlan2 1002
 parent 1005
!
vlan 1004
 bridge 1
 stp type ibm
!
vlan 1005
 bridge 1
!
!
! 
!
!
!
interface FastEthernet0/1
 switchport access vlan 440
 switchport mode dot1q-tunnel
 switchport nonegotiate
 no cdp enable
!
interface FastEthernet0/2
 switchport mode dynamic desirable
!
interface FastEthernet0/3
 switchport mode dynamic desirable
!
interface FastEthernet0/4
 switchport mode dynamic desirable
!
interface FastEthernet0/5
 switchport mode dynamic desirable
!
interface FastEthernet0/6
 switchport mode dynamic desirable
!
interface FastEthernet0/7
 switchport mode dynamic desirable
!
interface FastEthernet0/8
 switchport mode dynamic desirable
!
interface FastEthernet0/9
 switchport mode dynamic desirable
!
interface FastEthernet0/10
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
!
interface FastEthernet0/12
 switchport mode dynamic desirable
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
 switchport mode dynamic desirable
!
interface FastEthernet0/23
 switchport mode dynamic desirable
!
interface FastEthernet0/24
 switchport mode dynamic desirable
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,770
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 440
 switchport mode dot1q-tunnel
 no cdp enable
!
interface Vlan1
 ip address 10.10.13.75 255.255.0.0
!
interface Vlan770
 ip dhcp relay information trusted
 ip address 10.140.1.1 255.255.255.0
 ip helper-address 10.10.254.127
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.254.253
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
 password nag
 login
line vty 5 15
 password nag
 login
!
end

ping'а с 10.10.254.253 на 10.10.13.75 нет, равно как и нет пинга на 10.140.1.1.

В обычное тегирование работает.

 

Спасибо.

Share this post


Link to post
Share on other sites

В интерфейсных скриптах нужно vconfig использовать.

Share this post


Link to post
Share on other sites
9 минут назад, alibek сказал:

В интерфейсных скриптах нужно vconfig использовать.

auto eno1.1
iface eno1.1 inet static
	address 10.10.254.253
	netmask 255.255.0.0
#	gateway 10.10.0.1
	dns-nameservers 8.8.8.8
	up route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.10.0.1
	up route add -net 192.168.0.0 netmask 255.255.0.0 gw 10.10.0.1
	up route add -net 10.160.1.0 netmask 255.255.255.0 gw 10.10.0.8
	up route add -net 10.160.4.0 netmask 255.255.255.0 gw 10.10.0.8
	up route add -net 10.160.8.0 netmask 255.255.255.0 gw 10.10.0.17
	up route add -net 10.160.2.0 netmask 255.255.255.0 gw 10.10.0.3
        vlan_raw_device eno1

#auto eno1.1000

auto eno1.770
iface eno1.770 inet static
        address 10.140.1.253
        netmask 255.255.255.0
	network 10.140.1.0
        broadcast 10.140.1.255
        vlan_raw_device eno1

auto eno1.771
iface eno1.771 inet static
        address 10.140.2.253
        netmask 255.255.255.0
	network 10.140.2.0
        broadcast 10.140.2.255
        vlan_raw_device eno1

без vconfig и работает

Share this post


Link to post
Share on other sites
27 минут назад, zhenya` сказал:

А вы уверены, что S тэг у вас proto 802.1ad?

Так вроде же на интерфейсе создается vlan 440 (802.1ad), а потом, на уже созданный ифейс, вешается 802.1Q с тегами для нужного vlan.

https://www.atraining.ru/vlan-tag-switching-in-detail/ 

Технология 802.1ad – двойная метка
Как указывалось выше, у данной технологии есть и другие названия. QinQ, к примеру, или Stacked VLAN – всё это тоже имеет отношение к 802.1ad. 

Edited by default_vlan

Share this post


Link to post
Share on other sites

http://myhomelab.blogspot.ru/2014/02/qinq-with-cisco-catalyst-switches.html

 

Судя по этой статье и дампу из нее 

23:10:43.282757 00:10:a3:09:e6:bb > 00:e0:4c:36:00:0a, ethertype 802.1Q (0x8100), length 1450: vlan 1800, p 0, ethertype 802.1Q, vlan 20, p 0, ethertype IPv4, 20.20.20.2 > 20.20.20.1: ICMP echo request, id 8509, seq 524, length 1408  
 23:10:43.284015 00:e0:4c:36:00:0a > 00:10:a3:09:e6:bb, ethertype 802.1Q (0x8100), length 1450: vlan 1800, p 0, ethertype 802.1Q, vlan 20, p 0, ethertype IPv4, 20.20.20.1 > 20.20.20.2: ICMP echo reply, id 8509, seq 524, length 1408  
 23:10:43.323901 00:e0:4c:36:00:0a > 00:10:a3:09:e6:bb, ethertype 802.1Q (0x8100), length 1350: vlan 1800, p 0, ethertype 802.1Q, vlan 10, p 0, ethertype IPv4, 10.10.10.1 > 10.10.10.2: ICMP echo request, id 5068, seq 196, length 1308  
 23:10:43.324633 00:10:a3:09:e6:bb > 00:e0:4c:36:00:0a, ethertype 802.1Q (0x8100), length 1350: vlan 1800, p 0, ethertype 802.1Q, vlan 10, p 0, ethertype IPv4, 10.10.10.2 > 10.10.10.1: ICMP echo reply, id 5068, seq 196, length 1308  

 

при таком конфиге будет у S и C vlana езертайп 0х8100.

У классического ad езертайп 88a8.

 

Поэтому я и спросил.

имхо тазик ожидает 88a8 8100, а он подает ему 8100 8100.

Share this post


Link to post
Share on other sites
56 минут назад, zhenya` сказал:

имхо тазик ожидает 88a8 8100, а он подает ему 8100 8100.

auto eno1
iface eno1 inet manual
post-up ip link add link eno1 eno1.440 type vlan proto 802.1Q id 440
post-up ip link set eno1.440 up

auto eno1.440
iface eno1.440 inet manual
post-up ip link add link eno1.440 eno1.440.1 type vlan proto 802.1Q id 1
post-up ip link set eno1.440.1 up

Так?

 

Вопрос тогда, dot1q-tunnel  в cisco в каком стандарте? 802.1Q или ad?

Edited by default_vlan

Share this post


Link to post
Share on other sites

выше ссылку смотрите. да и по вашей ссылке они на интерфейсе эзертайп задают.

Опять же – если коммутатор просто не знает других типов транкинга, кроме 802.1Q, он не сможет выполнить эту команду. Что тоже, в общем-то, не страшно. Эту команду надо делать до переключения интерфейса в транк по той причине, что иначе переключение просто не произойдёт. Теперь фиксируем EtherType транка – помним, что он может не всегда быть 0x8100:

host(config-if)# switchport dot1q ethertype тип

эта настройка как раз касается S тэга.

Share this post


Link to post
Share on other sites
1 час назад, zhenya` сказал:

host(config-if)# switchport dot1q ethertype тип

эта настройка как раз касается S тэга.

TEST_3550_24(config-if)#switchport ?
  access         Set access mode characteristics of the interface
  backup         Set backup for the interface
  block          Disable forwarding of unknown uni/multi cast addresses
  host           Set port host
  mode           Set trunking mode of the interface
  nonegotiate    Device will not engage in negotiation protocol on this interface
  port-security  Security related command 
  priority       Set appliance 802.1p priority
  protected      Configure an interface to be a protected port
  trunk          Set trunking characteristics of the interface
  voice          Voice appliance attributes
  <cr>
TEST_3550_24(config-if)#switchport mode ?
  access        Set trunking mode to ACCESS unconditionally
  dot1q-tunnel  set trunking mode to TUNNEL unconditionally
  dynamic       Set trunking mode to dynamically negotiate access or trunk mode
  trunk         Set trunking mode to TRUNK unconditionally
TEST_3550_24(config-if)#switchport tr encapsulation ?
  dot1q      Interface uses only 802.1q trunking encapsulation when trunking
  isl        Interface uses only ISL trunking encapsulation when trunking
  negotiate  Device will negotiate trunking encapsulation with peer on interface

Пару статей находил, там было switchport nonegotiate. Не спасет?

Share this post


Link to post
Share on other sites

Я тебе уже сказал же, по дефолту на 3550 оба тэга 8100.

можешь в tcpdump глянуть на eno1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this