Jump to content
Калькуляторы

Dude + SNMP Странный глюк

Имеется Dude 4.0beta3 сервер с кучей девайсов, долгое время тащит инфу по SNMP V1. Периодически перестает тянуть данные с части устройств.

В этот список не попадают Ubiquiti радио всякие разные и UBNT Tough свичи, они как ни в чем не бывало продолжают передавать SNMP данные в дудку.

Лечится перезагрузкой DUDE или всего сервера с DUDE. Имеется резервный DUDE и прочие SNMP тянучки типа PRTG, на которые вся SNMP продолжает поступать как ни в чем ни бывало.

Резервный Dude иногда страдает той же проблемой. Девайсы, с которых пропадает статистика, находятся как в том же вилане/подсети, что и дудка, так и в других вланах/подсетях.

 

Что такого особенного в UBNT? Как полечить DUDE?

 

PS: RouterOS статистика поступает без перебоев, глюк касается только SNMP

Share this post


Link to post
Share on other sites

трафик на сервере с дудой смотрели? она перестает слать запросы к железкам или железки не успевают на них отвечать, до следующего цикла запросов? отфильтруйте по проблемному девайсу и посмотрите что происходит в момент "перестает тянуть данные".

посмотрите в сторону настройки таймаута snmp в дуде.

 

ubnt может быстрее обрабатывать данные запросы, нежели другие вендоры (предположение). у нас подобная ситуация наблюдалась с dlink 3627g, которые дольше остальных длинков отдают любой запрос по snmp. проверялось вручную snmpget'ами на проблемное железо.

Share this post


Link to post
Share on other sites

Было тоже самое на 4.0beta3 и так не полечилось у меня, просто рестартовал Dude после того как все железки отваливаются, это были длинк и прочее. Таймауты как только не тюнил, удалось лишь снизить этот период когда оно перестаёт всё опрашивать. Думал может там в sysctl на стороне ОС какие то нюансы таймингов, но видимо проблема в самой Dude. Вроде на стабильной версии такого не было.

 

P.S. я кстати даже сейчас у них на сайте не нашёл дистрибутива The Dude под win.

Edited by hsvt

Share this post


Link to post
Share on other sites

Такая проблема есть и никак не лечится. Тоже сталкивались с подобной, приходилось по разу в 2 недели сервис перезапускать.

Рекомендую Вам обновиться до версии 6.хх , которая работает из под RouterOS - там подобных проблем уже нет. Работаем уже несколько месяцев.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this