Jump to content
Калькуляторы

GRE IPsec Cisco 881 880 настройки

Народ, добрый день.

Не могу понять в чем проблема, поднял туннель между 2 cisco 881 и 880.

При попытке пропинговать хост через туннель, в ip src подставляется адрес туннеля, вместо ip шлюза. Если пинговать с этой же cisco, то все хорошо.

Куда копать?

 

interface Tunnel100

no ip address

tunnel source FastEthernet4

tunnel destination 10.0.0.2

tunnel protection ipsec profile transform-2-prof

!

interface FastEthernet4

description Inet

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

Share this post


Link to post
Share on other sites

Если я правильно понял вопрос - циска выбирает сорс с ближайшего к дестинейшену интефейса.

UPDATE. Посмотрел конфиг, не пойму, в чем задумка? Адрес туннеля -не адрес физ. порта?

PS Диплом?

Edited by furai

Share this post


Link to post
Share on other sites

Вот конфиг с одной стороны, с другой аналогичен.

настраивал по https://www.opennet.ru/openforum/vsluhforumID6/21741.html.

Cisco соединил через WAN порты, на котором поднял туннель. К портам привязал ip 10.0.0.1 и 10.0.0.2.

Остальные сети сидят на свичевых портах. Проблема в том что, когда хочу пропинговать с одной сети, хосты в другой через туннель. Пакет выходит на нужный мне FE (маршруты верны), но подставляется 10.0.0.2 (FE wan).

А хотело бы видеть ip interface Vlan1.

В чем может быть проблема, не могу понять. Опыта мало.

 

interface Tunnel100

no ip address

tunnel source FastEthernet4

tunnel destination 10.0.0.2

!

interface FastEthernet0

description to Asus

no ip address

!

interface FastEthernet1

switchport access vlan 10

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

description Inet

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

ip address dhcp

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 172.16.4.1

ip route 192.168.10.0 255.255.255.0 10.0.0.2

Share this post


Link to post
Share on other sites

В таком варианте тунель не используется совсем. Это раз.

Во вторых если ты с самого роутера что-то пингаешь, то соурс адрес берется с интерфейса, куда смотрит маршрут до узла назначения. Так обычно поступает любой узел в IP сети.

 

Налицо вообще полное непонимание как работает IP сеть, почитай буквари чтоли.

Share this post


Link to post
Share on other sites

Да бывал на isnd курсах cisco, но было давно и практики не было, больше с серверами работал

Настраивал по примеру, я так понял на сам интерфейс туннеля нужно вешаю ip. Если не изменяет память, то это на заголовок 3 уровня накладывается еще один с ip которые я укажу в туннеле?

Я понимаю что адрес берется с интерфейса, но у железки только 1 wan интерфейс, остальные свичевые порты, на них нельзя повесить адрес, только привязать в vlan интерфейсу.

Share this post


Link to post
Share on other sites

При попытке пропинговать хост через туннель, в ip src подставляется адрес туннеля, вместо ip шлюза. Если пинговать с этой же cisco, то все хорошо.

Вот тут написано непонятно что.

Откуда пинговал, чего пинговал, какая "эта же" циска и что было до этого? В каком месте взялся адрес тоннеля, если у тоннеля вообще адрес не назначен?

Не можете объяснить по русски - сделайте скриншоты чтоли.

Share this post


Link to post
Share on other sites

Вот сейчас какая схема.

Когда пингую с ноутбука сеть 192.168.123.0. То с интерфейса на Cisco 1 FE0 вылетает пакет, в котором src ip 10.0.0.2

45f5cf3e8e5b2d8189d3a11f00442c8e-full.jpg

Cisco-1

Current configuration : 106 bytes

!

interface Tunnel100

ip unnumbered Vlan1

tunnel source FastEthernet4

tunnel destination 10.0.0.2

end

Share this post


Link to post
Share on other sites

show run полностью, без выпиливания "не имеет отношения", кроме паролей.

Зачем на тунелях использовать unnumbered? что, мало серого диапазона, чтобы отрезать /30?

 

Скорее всего на Cisco-2 включен НАТ и он и работает. А тунель по прежнему не работает, потому что не настроена на него маршрутизация.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.