Jump to content
Калькуляторы

Asterisk + Cisco 79xx Проблемы со звуком

Добрый день, коллеги!

 

После не скольких месяцев мучений решил по пробовать найти ответ в комьюнити.

Имеем: сервер Asterisk 13.10.0 + patch (usecallmanager 13.10.0) + Телефоны Cisco 7941 и 7961, региональную сеть предприятия. Схема прилагается.

Проблема: В центральном офисе где установлен сервер и телефоны проблем со звуком нет, на удаленном участке ИНОГДА ПОЯВЛЯЕТСЯ проблемы с одно сторонней слышимостью (участок не слышит только когда ему звонят) когда участок звонит, проблем нет. NAT нет, связь между участком организованно посредством VPN. Проблема касается также и внутрених звонков, при этом запись разговора пишется с нормальной слышимостью.

 

Нужна помощь комьюнити.

 

Результаты Debug (возможно локализовал проблему)

 

Когда звук есть

Sent RTP packages to IP:22222

Got RTP packages from IP:22222

 

Когда звука нет

Sent RTP packages to IP:11111

Got RTP packages from IP:1025

 

RTP пакеты отправляются на другой порт, справедливо что звука нет, вопрос остался как исправить?

Pic.pdf

Edited by netadmin11

Share this post


Link to post
Share on other sites

Проблему вроде решил установкой парамметра nat=comedia ранее стоял nat=no

Из сделаных звонков 20 из 20 успешных.

Продолжаю наблюдать.

Edited by netadmin11

Share this post


Link to post
Share on other sites

Ну, снимите полный дамп PCAP как минимум на астериске, как максимум - еще поближе к телефону.

Share this post


Link to post
Share on other sites

Пару дней прошло, проблем нет.

 

Почему при nat=no происходили рандомное изменение порта, я так и не понял. Возможно это баг версии 13.10.0 или же это из-за патча, а может это фича телефонов.

 

Почему собственно nat=comedia? Все просто "...отправляет RTP пакеты обратно на IP адрес и порт, с которого они были получены, игнорируя информацию из сообщения SDP"

 

Всем спасибо!

Тему закрываем!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this