Jump to content
Калькуляторы

CRS125 mac vlan

Пробую настроить mac vlan на этом девайсе с терминацией L3 на нем - же .

кусок конфига:

/interface ethernet

set [ find default-name=ether1 ] name=e1-inet

set [ find default-name=ether2 ] name=e2-local

set [ find default-name=ether24 ] master-port=e2-local name=e24-uplink

set [ find default-name=ether3 ] master-port=e2-local

set [ find default-name=ether4 ] master-port=e2-local

set [ find default-name=ether5 ] master-port=e2-local

set [ find default-name=ether6 ] master-port=e2-local

set [ find default-name=ether7 ] master-port=e2-local

set [ find default-name=ether8 ] master-port=e2-local

set [ find default-name=ether9 ] master-port=e2-local

set [ find default-name=ether10 ] master-port=e2-local

set [ find default-name=ether11 ] master-port=e2-local

set [ find default-name=ether12 ] master-port=e2-local

set [ find default-name=ether13 ] master-port=e2-local

set [ find default-name=ether14 ] master-port=e2-local

set [ find default-name=ether15 ] master-port=e2-local

set [ find default-name=ether16 ] master-port=e2-local

set [ find default-name=ether17 ] master-port=e2-local

set [ find default-name=ether18 ] master-port=e2-local

set [ find default-name=ether19 ] master-port=e2-local

set [ find default-name=ether20 ] master-port=e2-local

set [ find default-name=ether21 ] master-port=e2-local

set [ find default-name=ether22 ] master-port=e2-local

set [ find default-name=ether23 ] master-port=e2-local

set [ find default-name=sfp1 ] master-port=e1-inet

/interface vlan

add interface=e2-local name=vlan150 vlan-id=150

/interface wireless security-profiles

set [ find default=yes ] supplicant-identity=MikroTik

/interface ethernet switch egress-vlan-translation

add customer-vid=150 new-customer-vid=0 ports=e2-local

/interface ethernet switch mac-based-vlan

add new-customer-vid=150 src-mac-address=00:15:65:12:0E:B5

add new-customer-vid=150 src-mac-address=00:15:65:11:49:E9

add new-customer-vid=150 src-mac-address=00:15:65:12:0E:87

add new-customer-vid=150 src-mac-address=00:15:65:12:11:21

add new-customer-vid=150 src-mac-address=00:15:65:82:F9:3D

add new-customer-vid=150 src-mac-address=00:15:65:12:10:C7

add new-customer-vid=150 src-mac-address=00:15:65:5D:AE:82

add new-customer-vid=150 src-mac-address=00:15:65:12:0E:3D

add new-customer-vid=150 src-mac-address=00:15:65:11:49:91

add new-customer-vid=150 src-mac-address=00:15:65:12:11:5F

add new-customer-vid=150 src-mac-address=00:15:65:12:0F:8F

add new-customer-vid=150 src-mac-address=00:15:65:7A:C7:F8

add new-customer-vid=150 src-mac-address=00:15:65:82:F9:A5

add new-customer-vid=150 src-mac-address=00:15:65:12:10:2B

/interface ethernet switch port

set 1 egress-vlan-mode=untagged

set 2 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 3 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 4 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 5 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 6 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 7 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 8 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 9 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged egress-vlan-tag-table-lookup-key=according-to-bridge-type

set 10 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 11 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 12 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 13 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 14 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 15 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 16 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 17 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 18 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 19 allow-fdb-based-vlan-translate=yes egress-vlan-mode=untagged

set 20 allow-fdb-based-vlan-translate=yes

set 21 allow-fdb-based-vlan-translate=yes

set 22 allow-fdb-based-vlan-translate=yes

/interface ethernet switch vlan

add ports=e2-local,switch1-cpu vlan-id=150

[code]

 

На интерфейс vlan150 пакеты успешно прилетают (там повешен ip и на нем dhcp) , но вот судя по всему в ответ не долетают.

/interface ethernet switch egress-vlan-translation пробовал делать и на e2-local и на конечных портах - не помогает.

Может есть у кого рабочий пример mac-vlan с терминацией его н этом же устройстве?

Share this post


Link to post
Share on other sites

А что вы вообще хотите получить? В вашем конфиге по этой теме - терминация вланов по L3 нет ничего.

 

Вы хотите сразу IP на нужный влан повесить, или на порт? Или на основе мака абонента?

Share this post


Link to post
Share on other sites

Ну , неважные моменты не включал в конфиг и так простыня большая.

 

Оно вот так:

/ip address

add address=192.168.0.14/24 comment="Local network" interface=e2-local network=192.168.0.0

add address=192.168.85.1/24 interface=vlan150 network=192.168.85.0

 

Я вешаю ip на 150 влан. Прилетающие пакеты в случае совпадения с настроенным маком попадают в 150 vlan , там запущен dhcp

 

 

/ip dhcp-server

add address-pool=voip1 disabled=no interface=vlan150 name=server1

/ip dhcp-server network

add address=192.168.85.0/24 dns-server=8.8.8.8 gateway=192.168.85.1 netmask=24

 

DHCP видит прилетающие пакеты в 150 vlan

 

# ADDRESS MAC-ADDRESS HOST-NAME SERVER RATE-LIMIT STATUS

0 D 192.168.85.250 00:15:65:12:11:5F SIP-T22P server1 offered

1 D 192.168.85.249 00:15:65:12:0E:3D SIP-T22P server1 offered

2 D 192.168.85.248 00:15:65:12:10:2B SIP-T22P server1 offered

3 D 192.168.85.247 00:15:65:11:49:91 SIP-T28P server1 offered

 

 

Сниффером на интерфейсе vlan150 видны ответы клиентам , но до клиентов они не долетают.

 

Тоесть мне нужно поместить некоторое количество клиентов в на основе mac в vlan. В одну сторону это явно работает , а вот ответы untag'om обратно не приходят.

Share this post


Link to post
Share on other sites

Добавил влан на порты , заработало , хотя Forward Invalid VLAN установлен...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this