Перейти к содержимому
Калькуляторы

Сложности с созданием VLAN на Микротиках Необходимо создать два VLAN на двух Микротиках

Возникла потребность пропустить два канала от двух разных провайдеров по одному кабелю. Схема проста, поэтому рисовать не буду. Имеются в наличии 3 устройства, но нам понадобятся только два из них, только выбрать не знаю какие. И так имеем RB 750, RB 750GL, RB 260GS. Кстати на RB 260GS удалось всё настроить, но возникла проблема с RB 750, RB 750GL. Вообщем я использую микротики как умные свитчи, настройки были сброшены на дефолт, конфиг по умолчанию удалён, затем просто пятый порт был выбран мастер портом и остальные порты добавлены в него в режиме Slave. Исползовать решил тегированный VLAN, схема выглядит так:

VLAN id 20 Макснет

VLAN id 30 МТС

1) Микротик 260

2 порт VLAN 20(untag)

3 порт VLAN 30(untag)

4 порт VLAN 30,VLAN 20(tag)

VLAN id ip адрес

VLAN 20 10.10.20.2

VLAN 30 10.10.30.2

2) Микротик 750

2 порт VLAN 20(untag)

3 порт VLAN 30(untag)

4 порт VLAN 30,VLAN 20(tag)

VLAN id ip адреса

VLAN 20 10.10.20.1

VLAN 30 10.10.30.1

ip адреса даны только для того что бы проверить работу VLAN.

Вообщем 4 порт на обоих тиках это транковый порт, ещё раз повторюсь на rb 260gs всё получилось, но оно и понятно - это же и есть управляемый свитч. Но когда начал настраивать rb 750gl по статье в нете http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN, то не выходит ничего, проходят следующие команды:

/interface vlan

add interface=ether4 name=eth4-vlan20 vlan-id=20

add interface=ether4 name=eth4-vlan30 vlan-id=30

Add bridges for each VLAN

/interface bridge

add name=bridge-vlan20

add name=bridge-vlan30

Add VLAN interfaces to their corresponding bridges and ethernet interfaces where untagged traffic is necessary

/interface bridge port

add bridge=bridge-vlan20 interface=eth4-vlan20

add bridge=bridge-vlan20 interface=ether2

И после этой команды дело дальше не идёт, терминал выдаёт: failure: ether2 is already slave. Невзирая на это продолжаем вводить команды:

add bridge=bridge-vlan30 interface=eth4-vlan30

add bridge=bridge-vlan30 interface=ether3

Опять та же ситуация: failure: ether3 is already slave

То есть получается что VLAN добавляется в бридж, а порт не может.Подскажите пожалуйста в чём тут загвоздка? Может есть какой то другой простой способ. Я понимаю конечно что лучше использовать настоящии умные свитчи, те же D-LINK, настраиваются легко и просто, но вот нет их, а валяются без дела.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ether2 и 3 находятся в еще одном бридже?

Ну конечно же каждый в своём бридже:ether2 привязан к name=bridge-vlan20 , а ether3 привязан к name=bridge-vlan30, в том то и дело, что их не удаётся привязать к бриджу, терминал выдаёт ошибку которую я указал выше. Ещё раз указываю на статью по которой делал http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всё верно подсказал DRiVen, что необходимо исключить мастер порт из программируемого порта. Я то по простоте душевной надеялся на аппаратную реализацию VLAN, но видно придётся юзать программную реализацию. Проверю в деле отпишусь об своих впечатлениях

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас