Jump to content

Mikrotik - NAT с разных src-адресов. Mikrotik + NAT + BGP

Всем доброго дня. Имеем

RB CCR1036-4S

Стык с аплинком /30 + BGP

Свою сеть /24

 

Задача: Есть куча хостов

10.0.1.0/24

10.0.2.0/24

10.0.3.0/24

10.0.4.0/24

10.0.5.0/24

 

Есть потребность натить каждую подсеть со отдельного ip из нашего внешнего пула /24

 

К примеру.. наш пул 77.78.79.0/24

Сеть 10.0.1.0/24 выходит в инет с 77.78.79.1

Сеть 10.0.2.0/24 выходит в инет с 77.78.79.2

Сеть 10.0.3.0/24 выходит в инет с 77.78.79.3

и т.д.

 

Понятно что все сети нужно отмаркировать адреслистом, пометить коннкты,пакеты.

Вопрос в том как заставить их выходить с разным src-ip с интерфейса аплинка?

Share this post


Link to post
Share on other sites

/ip firewall nat
add action=src-nat chain=srcnat src-address=10.0.1.0/24 to-addresses=77.78.79.1 out-interface=UPLINK
add action=src-nat chain=srcnat src-address=10.0.2.0/24 to-addresses=77.78.79.2 out-interface=UPLINK
add action=src-nat chain=srcnat src-address=10.0.3.0/24 to-addresses=77.78.79.3 out-interface=UPLINK
....
add action=src-nat chain=srcnat src-address=10.0.254.0/24 to-addresses=77.78.79.254 out-interface=UPLINK

Edited by infery

Share this post


Link to post
Share on other sites

infery все верно написал. Никаких маркировке и адрес-листов не нужно, только нат подобным образом настроите, и все заработает.

Share this post


Link to post
Share on other sites

infery все верно написал. Никаких маркировке и адрес-листов не нужно, только нат подобным образом настроите, и все заработает.

infery Спасибо. Именно так и есть, вся суть http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT

...

masquerade - replace source address of an IP packet to IP determined by routing facility

в то время как...

src-nat - replaces source address of an IP packet to values specified by to-addresses and to-ports parameters

 

Тема закрыта - всем спасибо.

Share this post


Link to post
Share on other sites

Добрый день, провайдер выдает нам /24 подсеть белых маршрутизируя ее на нас, мы принимаем эту подсеть на бридж и указываем в маршрутах соответствующие правила.

Теперь встала потребность на этом же микротике натить несколько серых подсетей /24 на разные белые IP из той сетки которую нам выдают. Подскажите пожалуйста как это реализовать? Спасибо!

Share this post


Link to post
Share on other sites

Добрый день, подскажите, возможно ли на адрес лист серых подсеток подключить одним правилом Nat несколько белых ip? 
заметил что в src-Nat можно указать диапазон. Так же вопрос есть ли смысл ограничивать количество соединений на каждого абонента за нат, если да то как это проще реализовать ? Спасибо за ответы.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.