Jump to content
Калькуляторы

ORION Beta B52X Проблема с доступом

Здравствуйте!

Вчера с НАГа привезли сабджевый коммутатор.

Требуется от него тупая агрегация.

 

Версия ПО коммутатора:

 

Beta-B52X#sh ver

 

Product Name: Beta-B52X

Hardware Version: A.03

Bootstrap Version: 5.2.1

Software Version: NOS_1.2.1639

PCB Version: A.1

FPGA Version: --

CPLD Version: 1.1

NOS Version: --

BOM Version: A1.2

Compiled May 08 2015, 12:42:04

 

System MacAddress: F8F0.8271.33EF

Serial number: 140207000603S15527S0092G

128 M bytes DRAM

32 M bytes Flash Memory

 

 

 

Конфиг:

 

Beta-B52X#sh running-config

 

System current configuration:

!command in view_mode

!

!command in config_mode first-step

create vlan 5,100-500 active

!

!command in aclmap_mode

!

!command in enable_mode

enable encrypt-password crS31vC89mHszw+wqPWJ7Q==

user name admin encrypt-password p0LmuBIy4pNnQg/1T8dZOw== privilege 15

!

!command in region_mode

!

!command in ip igmp profile mode

!

!command in evc mode

!

!command in aggregation_mode

!

!command in qos mapping mode

!

!command in wred mode

!

!command in l2cpprofile_mode

!

!command in sla thresholdprofile_mode

!

!command in port_mode

!

interface port 1

switchport trunk native vlan 5

switchport mode trunk

!

interface port 2

switchport trunk native vlan 5

switchport mode trunk

!

interface port 3

switchport trunk native vlan 5

switchport mode trunk

!

interface port 4

switchport access vlan 5

!

interface port 5

switchport trunk native vlan 5

switchport mode trunk

!

interface port 6

switchport trunk native vlan 5

switchport mode trunk

!

interface port 7

switchport trunk native vlan 5

switchport mode trunk

!

interface port 8

switchport trunk native vlan 5

switchport mode trunk

!

interface port 9

switchport trunk native vlan 5

switchport mode trunk

!

interface port 10

switchport trunk native vlan 5

switchport mode trunk

!

interface port 11

switchport trunk native vlan 5

switchport mode trunk

!

interface port 12

switchport trunk native vlan 5

switchport mode trunk

!

interface port 13

switchport trunk native vlan 5

switchport mode trunk

!

interface port 14

switchport trunk native vlan 5

switchport mode trunk

!

interface port 15

switchport trunk native vlan 5

switchport mode trunk

!

interface port 16

switchport trunk native vlan 5

switchport mode trunk

!

interface port 17

switchport trunk native vlan 5

switchport mode trunk

!

interface port 18

switchport trunk native vlan 5

switchport mode trunk

!

interface port 19

switchport trunk native vlan 5

switchport mode trunk

!

interface port 20

switchport trunk native vlan 5

switchport mode trunk

!

interface port 21

switchport trunk native vlan 5

switchport mode trunk

!

interface port 22

switchport trunk native vlan 5

switchport mode trunk

!

interface port 23

switchport trunk native vlan 5

switchport mode trunk

!

interface port 24

switchport trunk native vlan 5

switchport mode trunk

!

interface port 25

switchport trunk native vlan 5

switchport mode trunk

!

interface port 26

switchport trunk native vlan 5

switchport mode trunk

!

interface port 27

switchport trunk native vlan 5

switchport mode trunk

!

interface port 28

switchport trunk native vlan 5

switchport mode trunk

!

interface port 29

switchport trunk native vlan 5

switchport mode trunk

!

interface port 30

switchport trunk native vlan 5

switchport mode trunk

!

!command in vlan configuration mode

!

vlan 5

name managed

!

!command in dhcp-pool mode

!

!command in dhcp6-pool mode

!

!command in ip interface mode

!

interface ip 0

ip vlan 5

ip address 10.107.8.10 255.255.255.0

ipv6 address dhcp

!

!command in loopback interface mode

!

!command in traffic policer mode

!

!command in cmap_mode

!

!command in pmap_mode

!

!command in bandwidth profile mode

!

!command in hcos_mode

!

!command in hvlan_mode

!

!command in e_service_mode

!

!command in config_mode

system mtu 10218

management-port ip address 192.168.0.1 255.255.255.0

ip default-gateway 10.107.8.1

loopback-detection mode vlan-based

loopback-detection down-time 360

loopback-detection enable port-list 1-47,49-51

loopback-detection loop discarding port-list 1-47

ntp server 10.107.8.1 version v2

!

!command in service_mode

!

 

После установки в стойку, и подключении SFP модулей начал тупить терминал, - после ввода любой команды перестал возвращать результат выполнения оной. При этом зависала терминальная сессия, но не сбрасывалась. Можно было повторно залогиниться но результат опять такой же. Даже по COM порту такая же ситуация. При этом у пользователей интернет работал в их вланах, т.е. он их пропускал.

Когда вынули все модули и ребутнули все стало просто замечательно - и телнет и ssh заработал и ком порт раздуплился. В чем трабл?

Такая же конфигурация работает на двух х900 аллиедах, но увы заканчиваются порты. Хотели заменить их этой чудо железякой...

Edited by Pharaoh

Share this post


Link to post
Share on other sites
management-port ip address 192.168.0.1 255.255.255.0

ip default-gateway 10.107.8.1

IP интерфейса управления и шлюза из сильно разных сетей - ИМХО неправильно.

Может из-за этого девайс и тупит по управлению?

Share this post


Link to post
Share on other sites

Не думаю, что это как то коррелирует. Тем паче, как я понял этот 192 адрес доступен только из порта управления на самой железке который. Я им управлял через транковый порт в 5м влане на Layer3 интерфейсе.

Edited by Pharaoh

Share this post


Link to post
Share on other sites

IP интерфейса управления и шлюза из сильно разных сетей - ИМХО неправильно.

Может из-за этого девайс и тупит по управлению?

путаете горячее с красным. менеджмент - это отдельный порт, не маршрутизируемый. а для сетевого управления на этой железеке висит

ip vlan 5

ip address 10.107.8.10 255.255.255.0

В чем трабл?

Чудеса с распознованием китайского idprom и ddm в процессе первой вставки. Этим очень многие грешат.

Share this post


Link to post
Share on other sites

Чудеса с распознованием китайского idprom и ddm в процессе первой вставки. Этим очень многие грешат.

 

Есть ли, какое-то решение? Была надежда на этот свитч.

Share this post


Link to post
Share on other sites

Есть ли, какое-то решение? Была надежда на этот свитч.

Перевоткнуть проблемную сфп, или заменить ее. а поймать ее относительно просто - переставлять сфп не сразу, а выдерживая интервал в 5-10 секунд и параллельно отслеживать состояние коммутатора. Проблемную сфп можно перешить на более приличную.

Share this post


Link to post
Share on other sites

Да, спасибо. Наверное придется одного вендора модули ставить.

Share this post


Link to post
Share on other sites

путаете горячее с красным. менеджмент - это отдельный порт, не маршрутизируемый. а для сетевого управления на этой железеке висит

Действительно, не углядел с первого захода, что у железки есть oob менеджмент на отдельном порту.

Share this post


Link to post
Share on other sites

к слову, с момента написания мною обзора тестирования http://forum.nag.ru/forum/index.php?showtopic=101500

железка в продакшне еще ни разу не вызвала ни одного нарекания в эксплуатации.

Beta-B52X#sh version

 

Product Name: Beta-B52X

Hardware Version: A.02

Bootstrap Version: 5.2.1

Software Version: NOS_1.2.241

PCB Version: A.1

FPGA Version: --

CPLD Version: 1.0

NOS Version: --

BOM Version: A1.2

Compiled Jan 15 2014, 10:24:58

 

System MacAddress: F8F0.8271.1213

Serial number: 140207000602B14126B0002S

128 M bytes DRAM

32 M bytes Flash Memory

 

System uptime is 120 days, 10 hours, 3 minutes

как-то так.

Share this post


Link to post
Share on other sites

Прям, засада какая-то. Повезло мне.

Share this post


Link to post
Share on other sites

Четыре модуля воткнули с клиентами:

 

Beta-B52X(config)#show cpu-utilization dynamic

CPU threshold trap enable: Disable

Rising threshold: 100

Fallingthreshold: 1

Trap transfer observation interval(second): 60

 

Dynamic statistics period: 1 second

Last 1 second CPU utilization: 67%

 

 

Last 5 seconds CPU utilization: 35%

Total CPU utilization: 11%

 

 

 

Last 1 second CPU utilization: 67%

Вот эта строчка прыгает от 16 до 70%

 

Сделал по совету саппорта:

transceiver ddm disable

Это нормально? И как выяснить, что его так грузит?

В Аллиедах не было такой загрузки...

Edited by Pharaoh

Share this post


Link to post
Share on other sites

Это нормально? И как выяснить, что его так грузит?

Если честно, жесть, у меня эти показатели стабильно на низком уровне:

Last 1 second CPU utilization:     19%
Last 5 seconds CPU utilization:    17%
Last 1 minute CPU utilization:     14%
Last 10 minutes CPU utilization:   15%
Last 2 hours CPU utilization:      15%
Total CPU utilization:             15%

 

стоит покрутить дебаг, заодно покрутить "защитные" конструкции (storm-control, igmp snooping/filter, multicast filter и т.д.)

Share this post


Link to post
Share on other sites

Хм, вот типичная статистика по одному из портов:

Speed during 2 seconds Statistics:

Interface: port2

------------------------------------------------

Input Normal Statistics:

InOctets: 14,925,730,838

InUcastPkts: 33,172,309

InMulticastPkts: 41,328

InBroadcastPkts: 32,043

Output Normal Statistics:

OutOctets: 48,834,975,637

OutUcastPkts: 44,818,791

OutMulticastPkts: 144,390

OutBroadcastPkts: 2,100,215

Bit Statistics:

Ingress Bits: 119,405,846,704

Egress Bits: 390,679,805,096

Speed during 2 seconds Statistics:

Ingress Speed(bps): 4,876,535

Egress Speed(bps): 9,976,811

Ingress Speed(pps): 1,307

Egress Speed(pps): 1,770

Bandwidth Utilization during 2 senconds Statistics:

Ingress Bandwidth Utilization: 0

Egress Bandwidth Utilization: 0

Please press <Ctrl+C> to stop.

 

Может, что-то посоветуете?

Share this post


Link to post
Share on other sites

Pharaoh, а что говорит саппорт НАГ?

 

Я вот сейчас на этапе выбора подобной железки B52X и меня напрягают подобные тикеты.

Share this post


Link to post
Share on other sites

Я вот сейчас на этапе выбора подобной железки B52X и меня напрягают подобные тикеты.

Ни что не мешает взять железку на тест ;) у себя уже 6шт таких расставил и пока тьфу тьфу тьфу все гладко.

Share this post


Link to post
Share on other sites

Мы тоже взяли одну, как настрою, поставлю вместо двух длинков

Share this post


Link to post
Share on other sites

Сегодня пересоздал заявку. Советовали вот это transceiver ddm disable

 

Не помогло. Пока не втыкаем другие модули, боимся, что поляжет.

Share this post


Link to post
Share on other sites

SW_1#show run
syscli.c LINE 1403: Can not alloc memory

 

Кто-нибудь сталкивался с подобным на данном коммутаторе?

По консоли цепляться не пробовал, так как коммутатор на узле стоит. Перезагружать тоже побаиваюсь

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this