Jump to content
Калькуляторы

QinQ похоже я совсем тупой стал

Приветствую вас коллеги. Мне нужен взгляд со стороны, а то мне кажется я уже просто зациклился.

Хотим прогнать несколько вланов в 1 влане с точки а в точку б. Собрал стенд такой.

cisco 6505 и cisco 3550.

делаем через qinq loop

настройка на cisco6505

!

interface GigabitEthernet3/11

switchport

switchport access vlan 900

switchport mode dot1q-tunnel

no cdp enable

end

!

interface GigabitEthernet3/12

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900

switchport mode trunk

!

interface GigabitEthernet3/13

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 19,110,111

switchport mode trunk

!

Порт 3/13 подключен в 3/11 порт 3/12 смотрит в сторону cisco 3550 порт 0/9 все вланы существуют.

 

на cisco 3550

настройки

 

interface GigabitEthernet0/9

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900

switchport mode trunk

!

interface GigabitEthernet0/10

switchport

switchport access vlan 900

switchport mode dot1q-tunnel

no cdp enable

end

!

interface GigabitEthernet0/11

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 19,110,111

switchport mode trunk

!

 

порт 0/11 соединен с портом 0/10 порт 0/9 смотрит в сторону cisco6505 порт 3/12

 

на cisco 6505

!

interface Vlan19

ip address 19.19.1.222 255.255.255.0

!

 

на cisco 3550

!

interface Vlan19

ip address 19.19.1.223 255.255.255.0

!

 

И пинг не идёт ни с одного железки на другую...

на 3550 mtu я поднял на 1504

результатов никаких нет :(

И вот собсвтенно уперся я в стенку и не могу понять что не так делаю. Доки уже устал читать и вычитывать в общем вопрос вопрос.

Share this post


Link to post
Share on other sites

Чтоб ходил qinq mtu 1522 нужен?

для проверки логики пингами ему достаточно и дефолтного не?

Share this post


Link to post
Share on other sites

для проверки логики пингами ему достаточно и дефолтного не?

не знаю, у меня был вопрос :)

Share this post


Link to post
Share on other sites

Чтоб ходил qinq mtu 1522 нужен?

 

на 1500 должно работать, и пинги будут стандартные. Не будет такого пинга: ping 1.1.1.1 size 1500 df-bit

 

А так на 3550 system mtu 1504, а на c6500 (Там же IOS XR?) - 1518

 

По конфигу топикстартера все правильно, я qiniq-loop так между двумя WS-C3560C-8PC-S делал. Все работало.

Share this post


Link to post
Share on other sites

И так ответы

насчёт прошивки....

#sh version

Cisco IOS Software, s3223_rp Software (s3223_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXI12, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2013 by Cisco Systems, Inc.

Compiled Fri 30-Aug-13 09:55 by prod_rel_team

 

ROM: System Bootstrap, Version 12.2(17r)SX3, RELEASE SOFTWARE (fc1)

 

teneta.mlc.border uptime is 2 weeks, 3 days, 6 hours, 26 minutes

Uptime for this control processor is 2 weeks, 3 days, 6 hours, 25 minutes

Time since teneta.mlc.border switched to active is 2 weeks, 3 days, 6 hours, 24 minutes

System returned to ROM by power on (SP by power on)

System image file is "sup-bootdisk:s3223-adventerprisek9_wan-mz.122-33.SXI12.bin "

Last reload reason: power-on

 

 

 

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

 

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

 

If you require further assistance please contact us by sending email to

export@cisco.com.

 

cisco WS-C6506 (R7000) processor (revision 3.0) with 458752K/65536K bytes of memory.

Processor board ID SAL0751QQWP

R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache

Last reset from power-on

320 Virtual Ethernet interfaces

97 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

1915K bytes of non-volatile configuration memory.

 

65536K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102

 

но мне хочется верить что прошивка имеет такой потенциал :)

 

насчет stp

 

#show spanning-tree interface gigabitEthernet 3/11

Vlan Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0900 Desg FWD 4 128.267 P2p

 

#show spanning-tree interface gigabitEthernet 3/12

Vlan Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0900 Desg FWD 4 128.268 P2p Peer(STP)

 

#show spanning-tree interface gigabitEthernet 3/13

Vlan Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0019 Desg FWD 4 128.269 P2p

 

насчёт stp конфигу я чутка поменял загоняю сейчас только 1 влан 19

то есть не

!

interface GigabitEthernet0/11

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 19,110,111

switchport mode trunk

!

 

а стало

!

interface GigabitEthernet0/11

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 19

switchport mode trunk

!

но к сожалению всё равно не вышло

на 6500 mtu стоит на портах 1500....

и можно поставить только

 

#mtu ?

<9216-9216> MTU size in bytes

 

но ставили и такие мту и оставляли 1500 по дефолту в общем результат 0 :\

Share this post


Link to post
Share on other sites

Попробуйте собрать для начала без QinQ loop, так сказать по полной.

Возникали проблемы с запуском QinQ на коммутаторах cisco SF-300 и linksys типа sps2024G4 - был сделан вывод что те циски банально не работают с лупом, может быть у вас такая же проблема.

 

Когда будете уверены, что QinQ в принципе функционирует на ваших девайсах, будете усложнять схему.

Share this post


Link to post
Share on other sites

Попробуйте собрать для начала без QinQ loop, так сказать по полной.

Возникали проблемы с запуском QinQ на коммутаторах cisco SF-300 и linksys типа sps2024G4 - был сделан вывод что те циски банально не работают с лупом, может быть у вас такая же проблема.

 

Когда будете уверены, что QinQ в принципе функционирует на ваших девайсах, будете усложнять схему.

 

 

Канечна для чистоты експеримента можно и так сделать.

Но свободного оборудования нету.

1)100500% что qinq собирают на 3550 причём на такой же прошивке и всё работает. интернет испещрён этими постами и примерами.

2)собирают также qinq loop и на двух 6500 конфиги аналогичны и тоже всё там делается в 2 присеста ед момент там с натив влан бывают замарочки. но тоже схема рабочая...

 

я не думаю что результат изменится если добавить в схему ещё 2 циски...

Я пока тут перебором команд занимаюсь...

завтра буду пробывать на более похожих на 3750 и на 3550...

но что-то хочется вот 6500 подружить с 3550 )

по поводу завтрашнего теста я тоже отпишусь.

Share this post


Link to post
Share on other sites

Чтоб ходил qinq mtu 1522 нужен?

 

 

необязательно. У магистрала на одном из узлов очень простое железо, а нам там стык был кровь из носу нужен в авральном порядке и нужно было ещё строить qinq. Админский доступ к дальним железякам мы сразу же потеряли, на сетёвке скинули мту на 24 байта, и всё взлетело.

Share this post


Link to post
Share on other sites

Попробуйте собрать для начала без QinQ loop, так сказать по полной.

Возникали проблемы с запуском QinQ на коммутаторах cisco SF-300 и linksys типа sps2024G4 - был сделан вывод что те циски банально не работают с лупом, может быть у вас такая же проблема.

 

Когда будете уверены, что QinQ в принципе функционирует на ваших девайсах, будете усложнять схему.

 

 

Канечна для чистоты експеримента можно и так сделать.

Но свободного оборудования нету.

1)100500% что qinq собирают на 3550 причём на такой же прошивке и всё работает. интернет испещрён этими постами и примерами.

2)собирают также qinq loop и на двух 6500 конфиги аналогичны и тоже всё там делается в 2 присеста ед момент там с натив влан бывают замарочки. но тоже схема рабочая...

 

я не думаю что результат изменится если добавить в схему ещё 2 циски...

Я пока тут перебором команд занимаюсь...

завтра буду пробывать на более похожих на 3750 и на 3550...

но что-то хочется вот 6500 подружить с 3550 )

по поводу завтрашнего теста я тоже отпишусь.

 

 

 

необязательно циски юзать, любые управляемые коммутаторы подойдут, чтобы разобрать петлю.

 

Просто выплёвываете нужные виланы на том коммутаторе тегом - включаете в 11ый порт 6505 (другой коммутатор в 10ый порт 3550) ну и соединение оставляете как было. От результатов пляшете дальше, в своё время порядочно времени угробил уговаривая SF300 взлететь.

Кстати по опыту d-link там была особенность с TPID, может разные значения? Если свободные порты есть - можно попробовать зеркалировать трафик и стать анализатором типа wireshark, если второй тег появляется - вы это увидите. Зная кто вешает 2ой тег, а кто нет - будет больше информации о том кого лечить.

Как сказали выше - по логике конфигов, всё верно.

 

В своё время собирал схемку из прикрепления, там одна из сторон без лупа.

qinq.jpg

qinq.jpg

Share this post


Link to post
Share on other sites

Спасибо за ответы иза потраченное вами время.

Вчера в конце дня пробывал подружить 3750 с 3550 на прямую результата 0.

В общем полезу теперь в серверную на весь день буду разбирать петли...

Что выйдет расскажу попоже.

Share this post


Link to post
Share on other sites

собрал схему

CISCO2950-(trunk19)--------qinq(900)-CISCO3550----trunk(900)---CISCO3750-qinq(900)--------(trunk19)-CISCO2950

упаковывал я 19 Vlan в 900 в общем cisco2950 увидели друг друга

А фишка с Loop не завелась никак.

В общем считаю тему закрытой эксперимент удался, теперь скорее всего будем общаться с провайдерами чтобы они сделали нам qinq.

Если у кого есть какие дополнения или желания высказаться то пишите :).

Чуть позже если руки дойдут я попробую qinq loop но уже на двух одинаковых 3550 и позыпаю варишарком что там будет. Пока оборудования нет.

Спасибо всем за участие и удачного дня.

Edited by DruGoe_DeLo

Share this post


Link to post
Share on other sites

Расскажите потом, какой из коммутаторов и на какой прошивке хочет/нехочет работать с loop, вдруг кому-то пригодится.

Share this post


Link to post
Share on other sites

Да тут скорее надо мак адреса на портах поменять, циска не лупит потому что мак адреса одинаковые. У нас также "петля" через SCE не хотела работать, пока маки не поменяли

Share this post


Link to post
Share on other sites

А почему в процессе отладки не используется снифер пакетов? воткнилсь ноутом поочередно в порты 3/12 и 0/9 и посмотри снифером, сколько тегов прилетает и вообще какието данные собери, там же можно даже двойной тег создать, какойнить eth0.900.19 и на него нужный ip повесить

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this