Jump to content
Калькуляторы

проблема со сборкой Port-channel

Коллеги. Нужна помощь - не получается собрать Port-channel между 6509 и d-link 3052.

 

На d-link

show link_aggregation

Command: show link_aggregation

 

Link Aggregation Algorithm = MAC_source

 

Group ID : 1

Type : LACP

Master Port : 51

Member Port : 51-52

Active Port : 51

Status : Enabled

Flooding Port : 51

 

Total Entries : 1

 

порты в актив

 

show lacp_port

 

....

51 Active

52 Active

 

На циске

 

Router#sh run int gi1/46

Building configuration...

 

Current configuration : 212 bytes

!

interface GigabitEthernet1/46

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11

switchport mode trunk

lacp rate fast

channel-protocol lacp

channel-group 1 mode active

end

 

Router#sh run int gi1/47

Building configuration...

 

Current configuration : 212 bytes

!

interface GigabitEthernet1/47

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11

switchport mode trunk

lacp rate fast

channel-protocol lacp

channel-group 1 mode active

end

 

Router#sh run int po1

Building configuration...

 

Current configuration : 138 bytes

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11

switchport mode trunk

end

 

 

При этом 1 из портов шлёт больше пакетов

Router# show lacp count

LACPDUs Marker Marker Response LACPDUs

Port Sent Recv Sent Recv Sent Recv Pkts Err

---------------------------------------------------------------------

Channel group: 1

Gi1/46 1880 1086 0 0 0 0 0

Gi1/47 2678 1086 0 0 0 0 0

 

 

show etherchan 1 det

Group state = L2

Ports: 2 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Minimum Links: 0

Ports in the group:

-------------------

Port: Gi1/46

------------

 

Port state = Up Mstr In-Bndl

Channel group = 1 Mode = Active Gcchange = -

Port-channel = Po1 GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0xFF Protocol = LACP

 

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

A - Device is in active mode. P - Device is in passive mode.

 

Local information:

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi1/46 FA bndl 32768 0x1 0x1 0x12F 0x3F

Partner's information:

 

Partner Partner LACP Partner Partner Partner Partner Partner

Port Flags State Port Priority Admin Key Oper Key Port Number Port State

Gi1/46 FA bndl 1 0x0 0x33 0x34 0x3F

 

Age of the port in the current state: 0d:00h:13m:25s

 

Port: Gi1/47

------------

 

Port state = Up Mstr Not-in-Bndl

Channel group = 1 Mode = Active Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = LACP

 

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

A - Device is in active mode. P - Device is in passive mode.

 

Local information:

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi1/47 FA not-bnd 32768 0x1 0x1 0x130 0x7

 

Partner's information:

 

Partner Partner LACP Partner Partner Partner Partner Partner

Port Flags State Port Priority Admin Key Oper Key Port Number Port State

Gi1/47 FA not-bnd 1 0x0 0x33 0x33 0x77

 

Age of the port in the current state: 3050584830d:14h:25m:39s

 

Port-channels in the group:

----------------------

 

Port-channel: Po1 (Primary Aggregator)

Age of the Port-channel = 0d:03h:21m:34s

Logical slot/port = 14/1 Number of ports = 2

HotStandBy port = null

Port state = Port-channel Ag-Inuse

Protocol = LACP

Fast-switchover = disabled

Load share deferral = disabled

 

Ports in the Port-channel:

 

Index Load Port EC state No of bits

------+------+------+------------------+-----------

0 FF Gi1/46 Active 8

 

Time since last port bundled: 0d:00h:00m:00s Gi1/47

Time since last port Un-bundled: 0d:00h:00m:00s Gi1/47

 

Last applied Hash Distribution Algorithm: Fixed

 

Уже и порты попробовал поменять -взял соседний свободный порт.. всё равно 1 из портов в

GigabitEthernet1/47 is up, line protocol is down (notconnect)

 

 

Перезагрузил d-link- порты поменялись местами, в смысле 47 в ап ушёл..а 46 в line protocol is down

 

Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9-M), Version 12.2(33)SXH8, RELEASE SOFTWARE (fc1)

Share this post


Link to post
Share on other sites

Сделайте с одной стороны passive, с другой active.

Проблем между Cisco и D-Link в плане LACP не замечал ни разу.

"lacp rate fast" можете убрать.

Share this post


Link to post
Share on other sites

Сделайте с одной стороны passive, с другой active.

Проблем между Cisco и D-Link в плане LACP не замечал ни разу.

"lacp rate fast" можете убрать.

 

lacp rate fast убирал. В результате 1 порт

SA, а 2 FA.

Причём если моргнуть линками то могут местами поменяться..

 

Убрал lacp rate fast

d-link сделал пассивом.

 

сделал shu/ no shu po1и физ линкам.

на мгновение оба порат ушли в P - bundled in port-channel..и тут же 1 из портов ушёл в stand-alone

 

Да если важно.. но не думаю что играет роль. Со стороны циски 2 sfp междных наговских

Share this post


Link to post
Share on other sites

Что ещё в глаза бросается - если убрать lacp rate fast

то 1 порт

FA, а 2 становится SA

Share this post


Link to post
Share on other sites

покажите снова:

sh runn int gi1/46

sh runn int gi1/47

sh runn int po1

sh etherchan po1 sum

 

А в логи циска ничего не пишет про mismatch чегонибудь ... ?

Ну и, как вариант, попробуйте коммутаторам актив/пассив местами поменять.

Share this post


Link to post
Share on other sites

Вот тут было что-то про dlink, cisco, lacp и active/passive: http://www.dlink.ru/ru/faq/62/250.html

 

Да в общем-то так оно и сделано. Единственная разница - на портах входящих в LACP включен vlan со стороны длинка и на самом po со стороны циски

 

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11

switchport mode trunk

Share this post


Link to post
Share on other sites

покажите снова:

sh runn int gi1/46

sh runn int gi1/47

sh runn int po1

sh etherchan po1 sum

 

А в логи циска ничего не пишет про mismatch чегонибудь ... ?

Ну и, как вариант, попробуйте коммутаторам актив/пассив местами поменять.

 

 

Логи чистые. Их 1 делом смотрел.

Теперь уже в ПН выложу логи.

 

 

А так при no shu po1

 

1 из портов сразу в P - bundled in port-channel

2 порт сначала в

w - waiting to be aggregated

потом тк же на мгновение становится

P - bundled in port-channel и далее уже сваливается в

I - stand-alone

 

А так сильно не нравится что

show lacp count показывает сильно разные цифры в Sent по портам, и что 1 порт SA, а 2 FA.

Share this post


Link to post
Share on other sites

stalker86,

А untagged vlan (любой) есть в на портах с lacp (ну или на самом lacp)? Попробуйте добавить - где-то я такое встречал.

Можно "глухой", который никуда больше не смотрит.

Share this post


Link to post
Share on other sites

stalker86,

А untagged vlan (любой) есть в на портах с lacp (ну или на самом lacp)? Попробуйте добавить - где-то я такое встречал.

Можно "глухой", который никуда больше не смотрит.

 

 

На длинке или на кошке?

Share this post


Link to post
Share on other sites

Да длинке, pvid на порту должен быть реально существующий. Для 3120 это точно актуально, но вот помоему для 3028 это не нужно

Share this post


Link to post
Share on other sites

На длинке или на кошке?

Да заведите для проверки и там, и там.

 

Ещё покажите версию паршивки 3052.

Share this post


Link to post
Share on other sites

stalker86,

А untagged vlan (любой) есть в на портах с lacp (ну или на самом lacp)? Попробуйте добавить - где-то я такое встречал.

Можно "глухой", который никуда больше не смотрит.

 

И на циске (native) и на длинке (pvid), если не задан явно, то по-умолчанию всегда равен единице.

Сомневаюсь, что дело в этом.

 

Мне кажется, что где-то порты настроены по-разному. Может, действительно, pvid, stp, storm-control-ы ...

Просмотрите на обеих железках весь конфиг полностью и досконально.

Edited by g3fox

Share this post


Link to post
Share on other sites

Странные проблемы у вас. Обычно никаких вопросов не возникает. Начните с обновления прошивки длинка, это может быть вероятной причиной.

Конфиги работающей связки ниже, правда свитч 3200-52 С1.

 

cisco (ws-x6748-ge-tx)

interface GigabitEthernet4/3
description - CORE-RACK:       OFFICE SWITCH 1    -
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 666
switchport mode trunk
channel-protocol lacp
channel-group 12 mode active
!
interface GigabitEthernet4/4
description - CORE-RACK:       OFFICE SWITCH 2    -
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 666
switchport mode trunk
channel-protocol lacp
channel-group 12 mode active
!
interface Port-channel12
description - CORE-RACK:       OFFICE SWITCH 2G   -
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 666
switchport mode trunk

 

dlink

# LACP

config link_aggregation algorithm ip_source_dest
create link_aggregation group_id 1 type lacp
config link_aggregation group_id 1 master_port 51 ports 51-52 state enable
config lacp_port 1-50 mode passive
config lacp_port 51-52 mode active

Share this post


Link to post
Share on other sites

И на циске (native) и на длинке (pvid), если не задан явно, то по-умолчанию всегда равен единице.

Сомневаюсь, что дело в этом.

Опять же, на 3120, это работает, если первый влан подан на этот порт. А если его нет - pvid нужно сменить на тот, который реально подан на порт. Я у себя ставлю пвид управляющего влана.

Мне кажется, что где-то порты настроены по-разному. Может, действительно, pvid, stp, storm-control-ы ...

Просмотрите на обеих железках весь конфиг полностью и досконально.

Если на 3028 сам lacp собрался, то значит все настройки впорядке. Но проверить всё же стоит, мож баг какой.

Share this post


Link to post
Share on other sites

И на циске (native) и на длинке (pvid), если не задан явно, то по-умолчанию всегда равен единице.

Сомневаюсь, что дело в этом.

Опять же, на 3120, это работает, если первый влан подан на этот порт. А если его нет - pvid нужно сменить на тот, который реально подан на порт. Я у себя ставлю пвид управляющего влана.

Кстати, да, у нас такая-же практика, пвидом делать управляющий влан. Но по другой причине: если пвидом будет какой-то левый влан, который никуда не выкинут - ломается stp.

Share this post


Link to post
Share on other sites

И на циске (native) и на длинке (pvid), если не задан явно, то по-умолчанию всегда равен единице.

Сомневаюсь, что дело в этом.

Мне кажется, что где-то порты настроены по-разному. Может, действительно, pvid, stp, storm-control-ы ...

Просмотрите на обеих железках весь конфиг полностью и досконально.

 

Циска с почти ещё дефолтным конфигом. Завтра доберусь до железки выложу конфиг. d-link - stp отключал, да и если бы stp в логах была бы ругань как минимум.

Share this post


Link to post
Share on other sites

Странные проблемы у вас. Обычно никаких вопросов не возникает. Начните с обновления прошивки длинка, это может быть вероятной причиной.

Конфиги работающей связки ниже, правда свитч 3200-52 С1.

 

dlink

# LACP

config link_aggregation algorithm ip_source_dest
create link_aggregation group_id 1 type lacp
config link_aggregation group_id 1 master_port 51 ports 51-52 state enable
config lacp_port 1-50 mode passive
config lacp_port 51-52 mode active

 

Да вот сам не ожидал тут проблем словить.

Конфиг циски почти пустой, d-link stp отключал, да и в логах тишина.

В глаза сильно бросается что на циске 1 порт в FA, а второй сваливается в SA

Прошивка d-link последняя.

Вопрос а vlan (который тегированный) Вы вешаете на оба интерфейса в аггрегации или только на тот, который мастер?

Share this post


Link to post
Share on other sites

Надо на оба, но вроде бы если повесить на мастера, то он довесится сам. По крайней мере на 3120 так.

Настройки портов должны быть идентичны во всем. И pvid и набор вланов.

Share this post


Link to post
Share on other sites

Надо на оба, но вроде бы если повесить на мастера, то он довесится сам. По крайней мере на 3120 так.

Настройки портов должны быть идентичны во всем. И pvid и набор вланов.

 

Да так и сделано. Собрал на d-link аггрегацию, повесил на порныт входящие в аггрегацию нужный vlan.

Остаётся ещё раз проверить версию прошивки и насвежую голву завтра ещё раз сравнить настройки портов. И разве что отресетить d-link попробовать

Share this post


Link to post
Share on other sites

В общем помогло обновить прошивку до последней (2.94.B07, была 2.06) и отключение gvrp.

просто обновление прошивки было мало.

 

Теперь при падении 1 из линков теряется пакетика 3-5 и потом летим на 2 ноге.

Share this post


Link to post
Share on other sites

Так оба порта стали активны в show link_agg ?

на длинке они и были в актив и в аггпегации.

Но циска не верила длинку :) и 1 порт выпадал в осадок на циске. Актив но не в бандлере.

Сейчас оба

Router#show etherchannel summ

Flags: D - down P - bundled in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use N - not in use, no aggregation

f - failed to allocate aggregator

 

M - not in use, no aggregation due to minimum links not met

m - not in use, port not aggregated due to minimum links not met

u - unsuitable for bundling

d - default port

 

w - waiting to be aggregated

Number of channel-groups in use: 1

Number of aggregators: 1

 

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Gi1/46(P) Gi1/47(P)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this