Jump to content
Калькуляторы

ASR фантомный маршрут УДИВИТЕЛЬНО !!!

История такая, в таблицу маршрутизации попал ip адрес и числится как локальный при том что его реально на интерфейсе нет

 

asr-1002#show running-config interface Loopback1
Building configuration...

Current configuration : 1243 bytes
!
interface Loopback1
ip address 10.100.22.1 255.255.254.0 secondary
ip address 192.168.199.1 255.255.255.0 secondary
ip address 195.242.216.1 255.255.254.0 secondary
ip address 10.100.32.1 255.255.240.0 secondary
ip address 10.100.48.1 255.255.240.0 secondary
ip address 91.238.222.1 255.255.254.0 secondary
ip address 10.100.0.1 255.255.254.0 secondary
ip address 10.100.2.1 255.255.254.0 secondary
ip address 10.100.4.1 255.255.254.0 secondary
ip address 10.100.6.1 255.255.254.0 secondary
ip address 10.100.8.1 255.255.254.0 secondary
ip address 10.100.10.1 255.255.254.0 secondary
ip address 10.100.12.1 255.255.254.0 secondary
ip address 10.100.14.1 255.255.254.0 secondary
ip address 10.100.64.1 255.255.240.0 secondary
ip address 10.100.96.1 255.255.240.0 secondary
ip address 10.100.16.1 255.255.254.0 secondary
ip address 10.100.18.1 255.255.254.0 secondary
ip address 10.100.20.1 255.255.254.0 secondary
ip address 10.100.24.1 255.255.254.0 secondary
ip address 10.100.26.1 255.255.254.0 secondary
ip address 10.100.28.1 255.255.254.0 secondary
ip address 10.100.30.1 255.255.254.0 secondary
ip address 93.170.124.1 255.255.254.0 secondary
ip address 195.191.220.1 255.255.254.0
end

 

asr-1002#show ip route | include 91.221.48.229
L        91.221.48.229/32 is directly connected, Loopback1

 

asr-1002#show running-config | include 91.221.48.229
asr-1002#

 

если отправить Loopback1 в shootdown то маршрут пропадает

Share this post


Link to post
Share on other sites

Может этот адрес прилетает с каким нибудь атрибутом при аутентификации абонента ?

Share this post


Link to post
Share on other sites

orlik

как это проверить ?

 

на данный момент у абонента забрали этот ip он не кому не принадлежит

 

 

вот пример ip который получет через radius --> cisco dhcp server

 

asr-1002#show ip route dhcp
C    10.100.23.191/32 is directly connected, TenGigabitEthernet0/2/0.4014

 

всегда казалось что L - local это только ip которые рельно пресудствуют на маршрутизаторе

Share this post


Link to post
Share on other sites

Dushes

Судя по всему, это баг ПО.

 

Есть шанс, что поможет пересоздание лупбэка, но как я понимаю, у вас он используется для unnumbered-интерфейсов и поэтому no int Lo1 я бы не рискнул сделать просто так, потому что хз что произойдет в момент его удаления.

 

Если есть саппорт, то открывайте кейс, если нет, то я бы запланировал временное окно для ребута, при повторении - апгрейд софта.

 

Еще покажите show ip cef 91.221.48.229 detail и show ip cef 91.221.48.229 platform detail

Share this post


Link to post
Share on other sites

смарта нету

 

не подскажите где можно достать свежую прошивку ?

 

этот интерфейс еще в продакшен не ввели, меня больше беспокоит что бы такого не произошло в будущем

 

asr-1002# show ip cef 91.221.48.229 detail
91.221.48.229/32, epoch 2, flags attached, receive
 NetFlow: Origin AS 0, Peer AS 0, Mask Bits 32
 receive for Loopback1

 

asr-1002#show ip cef 91.221.48.229 platform detail
91.221.48.229/32
Active RP FM Forwarding Table
Forwarding Table

91.221.48.229/32 -> OBJ_ADJ_RECEIVE (0), urpf: 50
Prefix Flags: Receive, NAT address
OM handle: 0x4283aa04
Netflow BGP Origin AS: 0, AS length: 4
Netflow BGP Peer AS: 0, AS length: 4


Active FP FM Forwarding Table
Forwarding Table

91.221.48.229/32 -> OBJ_ADJ_RECEIVE (0), urpf: 50
Prefix Flags: Receive, NAT address
aom id: 38573211, HW handle: 0x1d2c0ab0 (created)
Netflow BGP Origin AS: 0, AS length: 4
Netflow BGP Peer AS: 0, AS length: 4


Active QFP Forwarding Table=== Gtrie Node ===

Gtrie Node Type: Tree Node
HW Content: : 92b4040d 00000004 ffffffff fff3bfff
Gtrie Tree Node Type:: Search Trie Node
=== Gtrie Search Node ===
 TN type 0, TN scan use 0, TN stride 6
 TN inode exists 1, TN skip 0
 TN zero perf real len: 0
 TN par bl offset: 0
 TN par bl len: 0
TBM Tree Array
 TA NNodes 61, TA INode Exists 1, TN TNRefs 0x21ac2300
TBM Tree Node Bitmap
Search Node Bitmap: ff ff ff ff ff f3 bf ff
=== Gtrie Node ===

Gtrie Node Type: Tree Node
HW Content: : 8bcb7c0d 8cfdf5a0 ffffffff ffffffff
Gtrie Tree Node Type:: Search Trie Node
=== Gtrie Search Node ===
 TN type 0, TN scan use 0, TN stride 6
 TN inode exists 0, TN skip 0
 TN zero perf real len: 0
 TN par bl offset: 0
 TN par bl len: 0
TBM Tree Array
 TA NNodes 64, TA INode Exists 0, TN TNRefs 0x1b449660
TBM Tree Node Bitmap
Search Node Bitmap: ff ff ff ff ff ff ff ff
=== Gtrie Node ===

Gtrie Node Type: Tree Node
HW Content: : 8dfefd8d 00000004 00303300 f000f03f
Gtrie Tree Node Type:: Search Trie Node
=== Gtrie Search Node ===
 TN type 0, TN scan use 0, TN stride 6
 TN inode exists 1, TN skip 0
 TN zero perf real len: 0
 TN par bl offset: 0
 TN par bl len: 0
TBM Tree Array
 TA NNodes 20, TA INode Exists 1, TN TNRefs 0x18a07658
TBM Tree Node Bitmap
Search Node Bitmap: 00 30 33 00 f0 00 f0 3f
=== Gtrie Node ===

Gtrie Node Type: Tree Node
HW Content: : 8bd2990d 8defe514 ffffffff ffffffff
Gtrie Tree Node Type:: Search Trie Node
=== Gtrie Search Node ===
 TN type 0, TN scan use 1, TN stride 6
 TN inode exists 1, TN skip 0
 TN zero perf real len: 24
 TN par bl offset: 17
 TN par bl len: 5
TBM Tree Array
 TA NNodes 64, TA INode Exists 1, TN TNRefs 0x21e05de8
TBM Tree Node Bitmap
Search Node Bitmap: ff ff ff ff ff ff ff ff
=== Gtrie Node ===

Gtrie Node Type: Tree Node
HW Content: : 8ceb3685 94a8b620 0f000000 00000000
Gtrie Tree Node Type:: Search Trie Node
=== Gtrie Search Node ===
 TN type 3, TN scan use 0, TN stride 6
 TN inode exists 0, TN skip 0
 TN zero perf real len: 0
 TN par bl offset: 0
 TN par bl len: 0
TBM Tree Array
 TA NNodes 0, TA INode Exists 4, TN TNRefs 0x1e36bb28
TBM Tree Node Bitmap
Search Node Bitmap: 1e 00 00 00 00 00 00 00
=== Gtrie Node ===

Gtrie Node Type: Leaf Node
HW Content: : 00002080 00000000 94cb6540 89c80000
 QPPB QoS Precedence valid: 0
 QoS Precedence: 0
 QPPB QoS Group valid: 0
 QoS Group: 0
 BGPPA Traffic Index valid: 0
 BGPPA Traffic Index: 0
 TBLF refcount: 2
 TBLF application lf handle: 0
 CTS src_sgt: 0
 CTS dst_sgt: 0
 Prefix Length: 32
 Prefix: 5b dd 30 e5
 Lisp local eid: 0
 Lisp remote eid: 0
 Lisp locator status bits: 0
 Lisp dynamic configured eid: 0
 Lisp dynamic discovered eid: 0
 tun_lookup_flags: 0000
=== OCE ===

OCE Type: Adjacency, Number of children: 0
Adj Type: : Receive Adjacency
Encap Len: : 0
L3 MTU: : 0
Adj Flags: : 0
Fixup Flags: : 0
Interface Name:
Next Hop Address: : 00000000 00000000 00000000 00000000
Next HW OCE Ptr: : 00000000
Fixup_Falgs_2: : 0
receive

Share this post


Link to post
Share on other sites

Dushes

Так всё понятно, этот адрес у вас использовался для NAT. Ищите его в xlat-е

 

show ip nat translations | i 91.221.48.229

Share this post


Link to post
Share on other sites

ip nat pool NAT_POOL_1 93.170.126.1 93.170.126.254 netmask 255.255.255.0
ip nat pool NAT_POOL_2 93.170.127.1 93.170.127.235 netmask 255.255.255.0
ip nat inside source list 105 interface TenGigabitEthernet0/2/0.1 overload
ip nat inside source list POOL_1 pool NAT_POOL_1 overload
ip nat inside source list POOL_2 pool NAT_POOL_2 overload

 

access-list 105 permit ip host 195.191.220.4 10.98.0.0 0.0.1.255
access-list 105 permit ip host 195.191.221.21 10.98.0.0 0.0.1.255
access-list 105 permit ip host 195.191.220.184 10.98.0.0 0.0.1.255
access-list 105 permit ip host 195.191.220.208 10.98.0.0 0.0.1.255
access-list 105 permit ip host 195.191.220.3 10.98.0.0 0.0.1.255
access-list 105 permit ip host 91.238.222.120 10.98.0.0 0.0.1.255

 

asr-1002#show ip nat translations inside 91.221.48.229
Total number of translations: 0

 

asr-1002#show ip nat translations outside 91.221.48.229
Total number of translations: 0

 

asr-1002#show ip nat translations total
Total number of translations: 317528

 

по show ip nat translations | i 91.221.48.229 вывод еще жду походу на долго

 

и собственно вопрос если это NAT то почему маршрут иcчезает, когда ложится в даун loopback

Share this post


Link to post
Share on other sites

asr-1002#show ip nat translations inside 91.221.48.229

asr-1002#show ip nat translations outside 91.221.48.229

 

таким способом не ищутся записи для обычного nat overload. я не знаю более правильных способ, чем через include

 

Web-redirect/L4redirect не используется у вас?

Share this post


Link to post
Share on other sites

s.lobanov

 

Web-redirect еще не внедрили

Share this post


Link to post
Share on other sites

s.lobanov

 

ночью придется делать, железку дико колбасить начинает, при таком количестве сессий, пришлось прервать, начали появлятся артефакты в трафике

 

asr-1002#show version
Cisco IOS XE Software, Version 03.11.00.S - Standard Support Release
Cisco IOS Software, ASR1000 Software (PPC_LINUX_IOSD-ADVENTERPRISE-M), Version 15.4(1)S, RELEASE SOFTWARE (fc2)

Share this post


Link to post
Share on other sites

Если и ночью не дождетесь, то сделайте clear ip nat trans * и посмотрите останется ли "NAT address" в выводе

asr-1002#show ip cef 91.221.48.229 platform detail

.....

Prefix Flags: Receive, NAT address

Share this post


Link to post
Share on other sites

у себя пользуем PRTG, VISIO, скрипты, мегаплан

 

Не понял если честно про какую карту речь

Share this post


Link to post
Share on other sites
asr-1002#show ip nat translations | i 91.221.48.229
asr-1002#

Share this post


Link to post
Share on other sites

clear ip nat trans *

 

сделал но не помогло все также

 

NAT address так же остался

Share this post


Link to post
Share on other sites

на сайте карта сети, где подключены дома

 

по виду

leaflet + свой тайлы + geojson база домов

Share this post


Link to post
Share on other sites

u234

 

leaflet + наша карта местная

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this