Jump to content
Калькуляторы

Не работает сетевой принтер за NAT Сайты ок, веб-печать тоже. Печать - висит ((

Сейчас сделано так:

на микротике:

ether3: 192.168.5.1/24

ether5: 192.168.2.251/24

wlan1: как клиент, получает по DHCP 192.168.1.89/24

 

К ether3 подключен кабелем сетевой принтер с IP 192.168.5.3/24.

К ether5 подключена локальная сеть офиса.

 

Смысл всей этой заморочки: из нескольких разных сетей печатать на одном сетевом принтере.

Я хочу попытаться обойтись БЕЗ добавления маршрутов до принтера на каждой рабочей станции и не затрагивать настройки интернет-шлюза. Просто виден в локальной сети хост с IP 192.168.2.251, который переадресует запросы на 192.168.5.3. Т.е. в локалке народ считает, что принтер никуда не переносился, а доступен на старом адресе (192.168.2.251).

 

Аналогично для клиентов беспроводной сети. У них принтер как был с адресом 192.168.1.89, так и должен остаться.

 

********************************************

/ip firewall nat print

 

0 chain=srcnat action=masquerade out-interface=wlan1 log=no log-prefix=""

 

1 ;;; From 192.168.2.251 to 192.168.5.3 (на принтер из локалки)

chain=dstnat action=dst-nat to-addresses=192.168.5.3 routing-mark=to-192-168-2-251 log=no log-prefix=""

 

2 ;;; From wlan1 to 192.168.5.3 (на принтер из wifi сети)

chain=dstnat action=dst-nat to-addresses=192.168.5.3 routing-mark=wlan1-ip-mark log=no log-prefix=""

 

 

********************************************

/ip firewall mangle print

Flags: X - disabled, I - invalid, D - dynamic

 

0 chain=prerouting action=mark-routing new-routing-mark=to-192-168-2-251 passthrough=yes dst-address=192.168.2.251 log=no log-prefix=""

 

1 chain=prerouting action=mark-routing new-routing-mark=wlan1-ip-mark passthrough=yes dst-address=192.168.1.89 log=no log-prefix=""

 

Больше никаких запретов, ограничений и пр. Только это.

 

Если из сети 192.168.2.0/24 отправляю на печать на принтер 192.168.2.251, печать может пару раз пройти, потом висяк - не печатает.

Если из той же сети зайти на веб-интерфейс принтера - все ок, и можно даже доки печатать.

 

Причем, зараза такая, он сначала начал печатать, я уж расслабился почти и вдруг, один за другим, стали говорить, что принтер не печатает ((

 

Я подозреваю, что через nat принтер не хочет принимать задания. Веб-то работает, т.е. nat работает. Можете подсказать, куда копать?

Share this post


Link to post
Share on other sites

А зачем тебе нат?

в данной ситуации, если принтер подключен к ether3: 192.168.5.1/24 c айпи 192.168.5.3/24

А весь офис к ether5: 192.168.2.251/24.

То. все будет работать при условии, что у всего офиса основной шлюз 192.168.2.251

 

Пакеты к 192.168.5.3 из сети 192.168.2.251/24 буду отправляться на основной шлюз.

У него роут на 192.168.5.3/24 будет иметь приоритет, так как он железный.

И все будет работать.

Share this post


Link to post
Share on other sites

А, дочитал, если он не основной шлюз...

тогда просто DNTAT

 

add action=dst-nat chain=dstnat dst-address=1.1.1.1 to-addresses=2.2.2.2

 

add action=src-nat chain=srcnat src-address=2.2.2.2 to-addresses=1.1.1.1

Share this post


Link to post
Share on other sites

Т.е. с mangle я намудрил... Начитался с тем про разные маршруты - хотел заодно и попробовать, что к чему. Сейчас попробую проверить.

 

Добавлено:

 

Если 192.168.5.3 - это принтер, то:

 

add action=dst-nat chain=dstnat dst-address=192.168.2.251 to-addresses=192.168.5.3

add action=dst-nat chain=dstnat dst-address=192.168.1.3 to-addresses=192.168.5.3

 

с srcnat возник вопрос.

 

если тупо добавить:

 

add action=src-nat chain=srcnat src-address=192.168.5.3 to-addresses=192.168.2.251

add action=src-nat chain=srcnat src-address=192.168.5.3 to-addresses=192.168.1.3

 

то будет работать только первый srcnat. Видимо, все же надо как-то метить в dstnat, чтобы потом отвечать srcnat в нужный интерфейс?

 

Добавлено (2): Хватило для работы только правил dst-nat. В action я поставил netmap. Но суть почти та же. А src-nat вообще не нужно, т.к. со стороны принтера мне ничего инициировать не надо, а stateful похоже прекрасно все видит ))

 

В общем, вопрос на этом закрыт. Спасибо огромное! Я наколбасил, как всегда, с три короба, хотя в уме держал мысль, которая, по-идее, и должны была вылиться в это простое решение.

Edited by billybons2006

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this