Jump to content
Калькуляторы

SNR-S3750G-48S-E MPLS не работает

Добрый день,

Пытаюсь поднять mpls по схеме, как здесь http://shop.nag.ru/article/oriond48mpls

 

Конфиг коммутатора А(слева)

 

mpls enable

 

ip vrf test

rd 100:1

route-target both 100:1

!

interface Vlan591

label-switching

ldp enable

ip address 10.168.7.117 255.255.255.252

!

interface Loopback1

ip address 172.31.255.42 255.255.255.255

!

interface Loopback3

ip vrf forwarding test

ip address 192.168.200.1 255.255.255.255

!

router ospf 1

network 10.168.7.116/30 area 0

network 10.168.7.120/30 area 0

network 172.31.255.42/32 area 0

!

router bgp 92

neighbor 172.31.255.43 remote-as 92

neighbor 172.31.255.43 update-source Loopback1

address-family vpnv4 unicast

neighbor 172.31.255.43 activate

exit-address-family

address-family ipv4 vrf test

redistribute connected

exit-address-family

!

router ldp

 

Конфиг коммутатора B аналогичен, но адрес loopback интерфеса 192.168.100.1.

 

В таблицах обоих коммутаторов роуты видны.

A#sh ip route vrf test

Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP

O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default

 

B 192.168.100.1/32 [200/0] via 172.31.255.43, 00:04:52 tag:0

C 192.168.200.1/32 is directly connected, Loopback3 tag:0

Total routes are : 2 item(s)

 

Ping не проходит.

 

A#ping vrf test src 192.168.200.1 192.168.100.1

Type ^c to abort.

Sending 5 56-byte ICMP Echos to 192.168.100.1, using source address 192.168.200.1, timeout is 2 seconds.

.....

Success rate is 0 percent (0/5), round-trip min/avg/max = 0/0/0 ms

 

A#sh ver

SNR-S3750G-48S-E Device, Compiled on Nov 15 05:43:44 2013

sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia

CPU Mac f8:f0:82:10:18:b9

Vlan MAC f8:f0:82:10:18:b8

SoftWare Version 7.0.3.5(R0123.0011)

BootRom Version 7.1.4

HardWare Version 1.0.2

CPLD Version N/A

Serial No.:SW032810D610000163

Copyright © 2013 NAG LLC

All rights reserved

Last reboot is cold reset.

Uptime is 0 weeks, 0 days, 1 hours, 8 minutes

 

A#sh tcam usage

TCAM Total: 1536 extended (3072 standard) entries on unit: 0

USED: 62 extended entries for l4 function

FREE: 1474 extended entries

TCAM Total: 1536 extended (3072 standard) entries on unit: 1

USED: 62 extended entries for l4 function

FREE: 1474 extended entries

Share this post


Link to post
Share on other sites

Sorry,

Loopbackи действительно не пингуются.

CE же подключенные к обычному влану, в том же VRF пингуются и работают нормально.

Share this post


Link to post
Share on other sites

Да,после того как поднялись CE в схеме c 2-мя рутерами, подняли схему с P роутером в центре, работало нормально.

Далее переконфигурировал центральный P в PE c route-reflector, т.е. PE-PE(RR)-PE, то же все нормально.

Share this post


Link to post
Share on other sites

железо какое используете в роли ПЕ? распишите подробнее )

а VPWS не пробовали?

 

л3впны конечно хорошо.. но..

 

п.с. покажите полностью конфиг роутер лпд?

Edited by zhenya`

Share this post


Link to post
Share on other sites

В тестовой схеме все PE SNR-S3750G-48S-E.

Версии у всех 7.0.3.5(R0207.0012), конфиги как в первом сообщении.

 

Ни VPLS, ни PW не заработали, только L3VPN.

 

router ldp

router-id 172.31.255.42

transport-address 172.31.255.42

Share this post


Link to post
Share on other sites

а у меня VPWS работало в схеме ASR9010 -vlan- 3750. Нюанс только с targeted hello.

Share this post


Link to post
Share on other sites

а у меня VPWS работало в схеме ASR9010 -vlan- 3750. Нюанс только с targeted hello.

Предполагаю, что это работало на старой версии прошивки, в последних версиях VPWS и PW отключены из-за проблем со стабильностью.

Share this post


Link to post
Share on other sites

Конкретнее можно?

SoftWare Version 7.0.3.5(B0207.0012)

BootRom Version 7.1.4

я на этом игрался..

Share this post


Link to post
Share on other sites

Еще, если в конфиге PE прописано так

router ldp

router-id 172.31.255.42

transport-address 172.31.255.42

, то пинги между CE вообще не проходят.

Конфиг для LDP должен быть тупым, только

router ldp

, тогда все работает.

 

А для Orion Delta 48 VPLS и PW будут работать, так как написано в документации ?

L3VPN на Orion Delta 48 работает нормально.

Share this post


Link to post
Share on other sites

Использовать функционал EoMPLS (VPWS/VPLS) на коммутаторах серии S3750G не рекомендуется. Аппаратная составляющая имеет серьезные ограничения, в ходе эксплуатации могут возникать краши коммутатора.

Share this post


Link to post
Share on other sites

С S3750G понятно, на OrionDelta 48 функционал EoMPLS (VPWS/VPLS) работает ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this