Jump to content
Калькуляторы

MPLS. вопросы новичка mpls l2vpn

Доброго времени суток, коллеги!

Начинаю понемногу осваивать MPLS/VPLS.

есть несколько банальных вопросов, которые из-за отсутсвия практики сложны к пониманию.

В лабе на Dinamips всё прошло гладко ( ldp,l3vpn), но когда провел аналогию с реальной сетью и применимости MPLS появилось куча вопросов.

Всё усложняет отсутсвие l2vpn в GNS3 как в cisco так и в J.

 

 

 

Есть сеть на схеме:

image.png

 

2 PE в роли MX80, в ядре MX480 и cat6509 sup2t. От каждого PE прокинуто до MX480 2 влана ( NAT и Real-ip).

К каталисту и MX подключены транком коммутаторы, к тем в свою очередь access-портом сервера которые должны видеть друг друга по L2.

 

 

1)тут вижу проблему для l2vpn, тк во всех книжках по Juniper пишут что интерфейс куда приземляется CE должен быть вида

 

ps@tormore> show configuration interfaces ge-0/0/1
vlan-tagging;
encapsulation vlan-ccc;
unit 802 {
description "to CE6";
encapsulation vlan-ccc;
vlan-id 802;
}
unit 805 {
description "to ce10";
encapsulation vlan-ccc;
vlan-id 805;
}

 

Т.е. весь физ-линк с инкапсуляцией vlan-ccc.

А у меня сейчас на портах

    flexible-vlan-tagging;
   mtu 9192;
   encapsulation flexible-ethernet-services;

 

я хочу чтобы на одном из юнитов был CE со своим l2vpn, на другом юните тупо vlan-id L3.

 

 

2) В случае если сервис НАТ-а и выхода в интернет для белых адресов организован с MX480, то он становится не совсем P-роутером, а PE/P?

 

как я вижу финальную схему:

от каждого BRAS-MX80 по 2 l2vpn-туннеля до Бордера-MX480, здесь же будет VFI point-to-multipoint.

В одном дефолт на НАТ, в другом дефолт на MX480 и потом в internet.

 

 

Просьба высказать свое мнение и указать на минусы.

Share this post


Link to post
Share on other sites

1)тут вижу проблему для l2vpn, тк во всех книжках по Juniper пишут что интерфейс куда приземляется CE должен быть вида

ps@tormore> show configuration interfaces ge-0/0/1
vlan-tagging;
encapsulation vlan-ccc;

Так пишут только в старых книжках.

 

я хочу чтобы на одном из юнитов был CE со своим l2vpn, на другом юните тупо vlan-id L3.

C flexible-ethernet-services так и будет работать.

 

2) В случае если сервис НАТ-а и выхода в интернет для белых адресов организован с MX480, то он становится не совсем P-роутером, а PE/P?

 

как я вижу финальную схему:

от каждого BRAS-MX80 по 2 l2vpn-туннеля до Бордера-MX480, здесь же будет VFI point-to-multipoint.

В одном дефолт на НАТ, в другом дефолт на MX480 и потом в internet.

 

 

Просьба высказать свое мнение и указать на минусы.

Мне кажется, что Вы слишком увелкаетесь L2 VPN-ами. Строить L2 VPN для соединения маршрутизаторов в своей сети это перебор :)

Share this post


Link to post
Share on other sites

Мне кажется, что Вы слишком увелкаетесь L2 VPN-ами. Строить L2 VPN для соединения маршрутизаторов в своей сети это перебор :)

 

Под эти задачи подойдет L3VPN, но сущность L2vpn ближе..тк "аналог" VLAN :)

Хорошо, попробуем собрать в лабе на L3vpn.

 

ХМ..тогда сразу вопрос. между какими адресами будет подниматься этот VPN? физ линк в сторону ядра это L3.

читал что-то про логические lt-0/0/x в ту сторону копать?

Share this post


Link to post
Share on other sites

rdntw, L3vpn это VRF.

lt интерфейс для коммутации vr внутри железки.

Share this post


Link to post
Share on other sites

ОК. опять же везде рассматривается случай когда СЕ цепляется через физ линк.

root@PE1> show configuration routing-instances
CUS1 {
instance-type vrf;
interface ge-0/0/0.0;
route-distinguisher 172.16.0.1:1;
vrf-target target:64496:1;
vrf-table-label;
}
root@PE1> show configuration interfaces ge-0/0/0
unit 0 {
family inet {
address 10.0.0.1/31;
}
}

 

А у меня это либо unit на физ линке в сторону абонентов.

для физ-лиц это вообще demux.

У меня немного другая ситуация, нужно прям на самом PE завернуть в VRF построенный на MPLS. но что в качестве интерфейса писать-то?)

вместо этого например

 

root@PE1> show configuration interfaces ge-0/0/0

unit 0 {

family inet {

address 10.0.0.1/31;

}

}

 

что должно быть? или вообще GRE?

Share this post


Link to post
Share on other sites

rdntw, а что мешает писать unit в VRF?

На край политикой (а тут что хотите) переложить в VRf?

Share this post


Link to post
Share on other sites

rdntw, а что мешает писать unit в VRF?

На край политикой (а тут что хотите) переложить в VRf?

 

ну смотрите. есть текущий магистральный линк с браса в сторону ядра, например xe-0/0/0:

 

admin@BRAS# show interfaces xe-0/0/0
description UPLINK;
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 50 {
   description REAL-IP;
   vlan-id 50;
   family inet {
       filter {
           output ACCESS_ON_BILLING;
       }
       sampling {
           input;
           output;
       }
       address 135.121.xx.xx/30;
   }
}
unit 100 {
   description NAT;
   vlan-id 100;
   family inet {
       sampling {
           input;
           output;
       }
       address 192.168.255.100/24;
   }
}

[edit]
admin@BRAS#

 

 

admin@BRAS_Butovo# show routing-options
static {

   route 0.0.0.0/0 next-hop 192.168.255.1;
}

 

чем мне в будущем MPLS заменить xe-0/0/0.100 и куда нужно будет кинуть дефолт.

 

если xe-0/0/0 превратиться в xe-0/0/0.0 L3/mpls ?

Share this post


Link to post
Share on other sites
чем мне в будущем MPLS заменить xe-0/0/0.1001 и куда нужно будет кинуть дефолт.

 

Я смотрю на ваш конфиг и на рисунок, но не могу найти xe-0/0/0.1001

Share this post


Link to post
Share on other sites

Я смотрю на ваш конфиг и на рисунок, но не могу найти xe-0/0/0.1001

 

прошу прощения, xe-0/0/0.100

Share this post


Link to post
Share on other sites

rdntw, так а в чем проблема? 1 юнит в vlan, другой в inet. Вас это смущает?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this