Jump to content
Калькуляторы

Проблемы с Mikrotik DHCP-Relay или маршрутизацией междуVLAN

Доброго времени суток, коллеги!

Столкнулся со следующей проблемой:

Есть управляемый L2-коммутатор, в который воткнуты аплинки, коммутаторы доступа пользователей, сервера. Все это находится в разных VLAN. Коммутатор соединен с Mikrotik AH1100X2 четырьмя линками (по одному на каждый VLAN), но нас интересуют только два. В VLAN100 живут сервера, в VLAN101 пользователи. Соответственно, на микротике подняты интерфейсы 10.0.100.254 и 10.0.101.254, которые являются шлюзами для каждой из подсетей, на каждом поднят DHCP-Relay. DHCP-сервер живет в VLAN100, в нем адреса раздаются без проблем. А вот клиенты из VLAN101 получить адреса не могут. По логам видно, что Mikrotik принимает запросы от килентов, перенаправляет их серверу, получает от сервера ответ и пересылает его обратно в сеть, но вот до клиента этот ответ не доходит. Хосты из этих подсетей нормально видят друг друга, а вот при попытке попинговать интерфейсы микротика между собой выходит такая картина:

 

[dolgachev@MikroTik] > ping 10.0.101.254 interface=VLAN100
HOST                                     SIZE TTL TIME  STATUS
10.0.101.254                                            timeout
10.0.101.254                                            timeout
10.0.101.254                                            timeout
10.0.101.254                                            timeout

 

Подскажите пожалуйста, в чем проблема. Заранее признателен.

Edited by dolgachev

Share this post


Link to post
Share on other sites

[dolgachev@MikroTik] > /ip dhcp-server print
Flags: X - disabled, I - invalid
#   NAME                                          INTERFACE                                         RELAY           ADDRESS-POOL                                         LEASE-TIME ADD-ARP
[dolgachev@MikroTik] > /ip pool print
# NAME                                                                                                                                                      RANGES
0 vpnusers                                                                                                                                                  10.0.102.10-10.0.102.200
[dolgachev@MikroTik] > /ip dhcp-relay print
Flags: X - disabled, I - invalid
#   NAME                                                                      INTERFACE                                                                     DHCP-SERVER     LOCAL-ADDRESS
0   VLAN101                                                                   VLAN101                                                                       10.0.100.1      10.0.101.254
1   VLAN100                                                                   VLAN100                                                                       10.0.100.1      10.0.100.254
[dolgachev@MikroTik] >

 

Забыл уточнить, DHCP-сервер виндовый

Edited by dolgachev

Share this post


Link to post
Share on other sites

эээ... у вас из консоли DHCP сервера не видно. Куда подевался?

И настройки в принципе странные какие-то

Share this post


Link to post
Share on other sites

На микротике только DHCP-Relay.

Pool создан для VPN пользователей, к данной теме отношения не имеет.

В чем странность настроек?

Share this post


Link to post
Share on other sites

Блин, надо было сразу говорить, что DHCP на винде. Если он живет в vlan100, то он и отвечает с тэгом vlan100, который пользователям vlan101 пофигу. DHCP в вашем случае должен в транке жить, тогда и relay, по идее, не нужны будут

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this