Jump to content
Калькуляторы

Mikrotik RB951G-2HnD + IPTV

Здравствуйте. На старом DIR-300NRU с прошивкой от Zyxel Keenetik Lite IPTV включался просто выставлением соответствующей галочки, работал нормально. На Микротике так не получается. Для соединения с провайдером требуется только PPPOE, на старом роутере этого было достаточно. На Микротике интернет работает, я не стал удалять дефолтную конфигурацию, и просто прописал данные для авторизации. IGMP Proxy установил, в нем создал интерфейсы ppoe-out1 в качестве upstream, галочку нужную поставил, в качестве Source IP Addres автоматический прописался мой "белый" IP. Интерфейс bridge-local прописал в качестве Querier, в поле IP сам проставился стандартный адрес Микротика. Ну и в файрволле прописал правила для TCP и IGMP. Но IPTV не работают, в поле MFC есть Wrong Packets, вот думаю не в этом ли затык, и если да, то что же я сделал неправильно?

post-121941-095632900 1407649453_thumb.jpg

post-121941-023401600 1407649459_thumb.jpg

post-121941-029695400 1407649465_thumb.jpg

post-121941-040044900 1407649470_thumb.jpg

Share this post


Link to post
Share on other sites

Ну и в файрволле прописал правила для TCP и IGMP.

IPTV multicast - это UDP. Никакого TCP. Попозже, если получится, попробую у себя IPTV.

Share this post


Link to post
Share on other sites

Ошибся, конечно же правила для UDP и IGMP создал.

Share this post


Link to post
Share on other sites

Скрины не смотрел, но разве у провайдера мультикаст льется через PPPoE?

Share this post


Link to post
Share on other sites

Присоединяюсь к DeLL.

Скорей всего вам нужно в качестве Upstream выбрать не PPPoE, а WAN интерфейс.

Share this post


Link to post
Share on other sites

На WAN вообще никакие пакеты не идут, и в разделе IGMP интерфейсы становятся неактивными.

 

На DIR300 как-то же работал IPTV. Из всех настроек только логин\пароль и галочка в соответствующем разделе, и этого было достаточно.

Edited by sanrega

Share this post


Link to post
Share on other sites

Выясните у провайдера как к вам приходит мультикаст. Если на дир300 была кастомная прошивка провайдера - тогда вариантов может быть масса.

Share this post


Link to post
Share on other sites

На DIR300 прошивка была вообще от Кинетика Лайт, не кастомная. У прова спрашивал - говорит, что по UDP идет мульткаст.

Share this post


Link to post
Share on other sites

Воткни шнур напрямую в комп и запусти IPTV. Если работает - значит надо настраивать микротик на ether1 или куда у тебя там шнур подключен от провайдера, но никак не на pppoe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this