Jump to content
Калькуляторы

c3750/c3750x & qinq

Всем привет,

ситуация такая - имеем раздачу кольцами (des3200), колца подключены к L2 агрегаторам (dgs3120), агрегаторы подключены к неск с3750G (L3 mode), те в свою очередь к двум c3750x (L2), к которым подключена вся серверная группа. Раздача инета по pptp. Решили попробовать ipoe, но так чтобы прежняя схема оставалась рабочей. C длинками примерно понятно что делать - нужно запустить селективный qinq и заворачивать, например, клиенсткие c-vlan 1000 ... 3000 какждого сегмента в сервисные s-vlan 500, 501 и т.д. Суть вопроса - как протащить qinq фреймы до браса. Наткнулся на статью

Jumbo/Giant Frame Support on Catalyst Switches Configuration Example

правильно ли я понимаю, что мне достаточно изменить на каталистах mtu jumbo size, например, до макс. размера и сервисные вланы (500,501 ...) протянуть от портов, которым подключены L2 агрегаторы, до портов подключенных к брасу? Порты на каталистах в trunk mode:

 

c3750-48#sh run | b 1/0/47
interface GigabitEthernet1/0/47
switchport trunk encapsulation dot1q
switchport trunk native vlan 21
switchport trunk allowed vlan 21,50,52,102,107,909
switchport mode trunk
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!

Share this post


Link to post
Share on other sites

Нет же, не правильно.

Это обычный транк который ниразу ни куинку. Только нэйтив влан организован. Вам надо указать туннел в транке.

switchport mode dot1q-tunnel

Ну собствено и порт должен быть в акцессе и VID в который хотите упаковывать пачку вланов.

Edited by myst

Share this post


Link to post
Share on other sites

Нет же, не правильно.

Это обычный транк который ниразу ни куинку. Только нэйтив влан организован. Вам надо указать туннел в транке.

switchport mode dot1q-tunnel

Ну собствено и порт должен быть в акцессе и VID в который хотите упаковывать пачку вланов.

смысл вот в чем dot1q-tunnel мне не нужен, нужно старую схему не трогать и чтобы она работала (порты каталиста к которым подключены агрегаторы должны быть в транке). Идея в том, чтобы фреймы qinq c длинка воспринимались c3750 как 802.1q фреймы с TPID=0x8100 но с большей длинной, по идее каталисту вообще должно быть фиолетово что идет вслед за заголовком 802.1q, он должен это воспринимать как jumbo фрейм и передавать его как обычный 802.1q (в сервисных вланах 500, 501 ...) только с большей длиной. Или не прокатит? то почему?

Share this post


Link to post
Share on other sites

А понял.

В таком случае если фреймы уже упакованы во второй тэг ничего делать не надо, прокидывайте обычным транком. Увеличьте систем мту до 1504 и все.

Share this post


Link to post
Share on other sites

А понял.

В таком случае если фреймы уже упакованы во второй тэг ничего делать не надо, прокидывайте обычным транком. Увеличьте систем мту до 1504 и все.

понял, спасиб :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this