Jump to content
Калькуляторы

Проброс vlan! Как правильно сделать.

Суть вопроса вот в чем.Есть mikrotik rb2011 подключен к провайдеру, получен статичный ip. есть также точка внешняя sxt lite 2. Хочу точку доступа поставить на соседнем доме(другу инет дать в частный дом). Договорился с провайдером о выделении доп порта на коммутаторе в соседнем доме (провайдер один и тот же) и пробросе vlan между портами. Теперь вопрос: мне нужно на rb 2011 этот vlan принять тегом а на sxt отдать антегом, как правильно это сделать?

Ниже прикреплен файл со скринами настроек.

Настраивалось все согласно статьям в интернете

Share this post


Link to post
Share on other sites

На Rb2011 создаете на нужном порту влан, дальше либо создаете другой влан на порту внутренней сети, бриджуете их между собой, на антенне абонента сетевой порт бриджуете с вланом, созданном на бридже=) Либо вместо вланов пробрасываете по EoIP туннелю внутри сети.

Share this post


Link to post
Share on other sites

На Rb2011 создаете на нужном порту влан, дальше либо создаете другой влан на порту внутренней сети, бриджуете их между собой, на антенне абонента сетевой порт бриджуете с вланом, созданном на бридже=) Либо вместо вланов пробрасываете по EoIP туннелю внутри сети.

Как я понял на антене а все правильно настроил, а вот на rb 2011 нужно было кое что доделать.

Вот ссылка на файл с настройками

https://cloud.mail.ru/public/ce89f9bcc427/%D0%9D%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B8%20%D0%BD%D0%B0%20sxt%20lite%202.docx

Share this post


Link to post
Share on other sites

сегодня опробовал систему, ничего не вышло.в чем может быть проблема.

Share this post


Link to post
Share on other sites

сегодня опробовал систему, ничего не вышло.в чем может быть проблема.

Потому что в Микротик настраивать vlan - это шляпа. ;)

Share this post


Link to post
Share on other sites

сегодня опробовал систему, ничего не вышло.в чем может быть проблема.

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

потому что у кого то руки не прямоваты ! Без обид всё гоняем Вланами нет проблем !

если Вы привыкли к Длинкам не стоит говорить что другой производитель г.....

Share this post


Link to post
Share on other sites

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

достаточно помыть руки и шляпа испариться...

сли Вы привыкли к Длинкам не стоит говорить что другой производитель г.....

 

ну тут вы зря у длинком с настройками вланов вообще все просто и понятно

Share this post


Link to post
Share on other sites

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

достаточно помыть руки и шляпа испариться...

сли Вы привыкли к Длинкам не стоит говорить что другой производитель г.....

 

ну тут вы зря у длинком с настройками вланов вообще все просто и понятно

 

а я разве говорил что там сложно или что длинк г...? я говорил про привычку так как человек знает как это делать на другом оборудовании .

Share this post


Link to post
Share on other sites

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

В микротике есть много других способов передавать данные и разделять клиентов между собой.

Share this post


Link to post
Share on other sites

сегодня опробовал систему, ничего не вышло.в чем может быть проблема.

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

потому что у кого то руки не прямоваты ! Без обид всё гоняем Вланами нет проблем !

если Вы привыкли к Длинкам не стоит говорить что другой производитель г.....

Я тоже "гоняю вланы без проблем!". Я сетую не на невозможность, а на нюансы настройки. Что Вы что вы, никакой любви и зависимости к Dlink не испытываю. Где я сказал, что другой производитель (в данном контексте Mktk) - говно?

Share this post


Link to post
Share on other sites

сегодня опробовал систему, ничего не вышло.в чем может быть проблема.

Потому что в Микротик настраивать vlan - это шляпа. ;)

 

потому что у кого то руки не прямоваты ! Без обид всё гоняем Вланами нет проблем !

если Вы привыкли к Длинкам не стоит говорить что другой производитель г.....

Я тоже "гоняю вланы без проблем!". Я сетую не на невозможность, а на нюансы настройки. Что Вы что вы, никакой любви и зависимости к Dlink не испытываю. Где я сказал, что другой производитель (в данном контексте Mktk) - говно?

 

Да так нюансы есть в у каждой железки не зависимо от производителя .

Share this post


Link to post
Share on other sites

Схема чуть чуть изменилась.необходимо на ethernet порту принять vlan теггом, а отдать на внутреннюю на другой порт антегом.Вроде бы все настроил но все равно ничего не вышло.

Вот конфиги

# jul/13/2014 00:11:03 by RouterOS 6.15

# software id = X7R6-MUST

#

/interface bridge

add l2mtu=1598 name=bridge1 protocol-mode=none

add l2mtu=1594 name=vlan

/interface ethernet

set [ find default-name=ether1 ] speed=1Gbps

set [ find default-name=ether2 ] speed=1Gbps

set [ find default-name=sfp1 ] auto-negotiation=no comment=WAN

/interface wireless

set [ find default-name=wlan1 ] antenna-gain=3 band=2ghz-b/g/n channel-width=\

20/40mhz-Ce disabled=no distance=indoors frequency=auto l2mtu=1600 mode=\

ap-bridge multicast-helper=full ssid=HOME tdma-period-size=auto tx-power=\

18 tx-power-mode=all-rates-fixed wds-default-bridge=bridge1 wds-mode=\

dynamic wireless-protocol=802.11

/ip neighbor discovery

set sfp1 comment=WAN

/interface wireless nstreme

set wlan1 enable-nstreme=yes

/interface vlan

add interface=sfp1 l2mtu=1594 name=vlan1 use-service-tag=yes vlan-id=4094

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \

group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \

wpa-pre-shared-key=qwerty123 wpa2-pre-shared-key=qwerty123

/ip hotspot user profile

set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \

mac-cookie-timeout=3d

/ip ipsec proposal

set [ find default=yes ] enc-algorithms=3des

/ip pool

add name=dhcp_pool1 ranges=192.168.10.2-192.168.10.254

add name=dhcp_pool2 ranges=192.168.10.2-192.168.10.254

add name=dhcp_pool3 ranges=192.168.10.2-192.168.10.254

add name=dhcp ranges=192.168.88.2-192.168.88.254

add name=dhcp_pool5 ranges=192.168.5.2-192.168.5.254

/ip dhcp-server

add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1

/port

set 0 name=serial0

/system logging action

set 0 memory-lines=100

set 1 disk-lines-per-file=100

/caps-man manager

set enabled=yes

/interface bridge port

add bridge=bridge1 interface=ether2

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether5

add bridge=bridge1 interface=ether6

add bridge=bridge1 interface=ether8

add bridge=bridge1 interface=ether9

add bridge=bridge1 interface=ether10

add bridge=bridge1 interface=wlan1

add bridge=bridge1 interface=ether7

add bridge=vlan interface=ether1

add bridge=vlan interface=vlan1

/interface pptp-server server

set authentication=pap,chap,mschap1,mschap2 enabled=yes

/interface wireless cap

set caps-man-addresses=192.168.88.1 interfaces=wlan1

/ip address

add address=5.104.200.66/30 interface=sfp1 network=5.104.200.64

add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0

add address=192.168.5.1/24 interface=vlan1 network=192.168.5.0

/ip dhcp-server network

add address=192.168.88.0/24 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes servers=8.8.8.8

/ip firewall filter

add chain=forward protocol=icmp

add chain=forward comment="Accept established connections" connection-state=\

established

add chain=forward connection-state=related

add action=drop chain=forward connection-state=invalid

add chain=forward protocol=udp

/ip firewall nat

add action=masquerade chain=srcnat out-interface=sfp1 to-addresses=0.0.0.0

add chain=srcnat src-address=192.168.5.0/24

/ip route

add distance=1 gateway=5.104.200.65

/ip service

set telnet disabled=yes

set ftp disabled=yes

set ssh disabled=yes

set api disabled=yes

set api-ssl disabled=yes

/ip upnp

set allow-disable-external-interface=no

/lcd interface

set sfp1 interface=sfp1

set ether1 interface=ether1

set ether2 interface=ether2

set ether3 interface=ether3

set ether4 interface=ether4

set ether5 interface=ether5

set ether6 interface=ether6

set ether7 interface=ether7

set ether8 interface=ether8

set ether9 interface=ether9

set ether10 interface=ether10

set wlan1 interface=wlan1

/lcd interface pages

set 0 interfaces="sfp1,ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8\

,ether9,ether10,wlan1"

/routing igmp-proxy

set quick-leave=yes

/routing igmp-proxy interface

add interface=bridge1

add alternative-subnets=0.0.0.0/0 interface=sfp1 upstream=yes

add interface=wlan1

/system clock

set time-zone-name=Europe/Moscow

/system lcd

set contrast=0 enabled=no port=parallel type=24x4

/system lcd page

set time disabled=yes display-time=5s

set resources disabled=yes display-time=5s

set uptime disabled=yes display-time=5s

set packets disabled=yes display-time=5s

set bits disabled=yes display-time=5s

set version disabled=yes display-time=5s

set identity disabled=yes display-time=5s

set bridge1 disabled=yes display-time=5s

set vlan disabled=yes display-time=5s

set wlan1 disabled=yes display-time=5s

set sfp1 disabled=yes display-time=5s

set ether1 disabled=yes display-time=5s

set ether2 disabled=yes display-time=5s

set ether3 disabled=yes display-time=5s

set ether4 disabled=yes display-time=5s

set ether5 disabled=yes display-time=5s

set ether6 disabled=yes display-time=5s

set ether7 disabled=yes display-time=5s

set ether8 disabled=yes display-time=5s

set ether9 disabled=yes display-time=5s

set ether10 disabled=yes display-time=5s

set vlan1 disabled=yes display-time=5s

/system ntp client

set enabled=yes primary-ntp=80.90.180.140 secondary-ntp=62.76.96.4

/system routerboard settings

set cpu-frequency=700MHz

Share this post


Link to post
Share on other sites

Создать bridge1, назвать input. Добавить в него порт eth1 (порт, куда приходят vlan в теге). Создать vlan , в interface указать input. Создать bridge2, назвать untagvlanXX, где ХХ vlan id. Добавить в бридж untagvlanXX желаемый vlan и порт, в который хотите снимать tag (access port).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this