Jump to content
Калькуляторы

ASR 1000, пара проблем

День добрый

 

Вопрос с шейпингом/полисингом на ASR1000 (RP2, четыре 10G интерфейса)

 

Делаю раз:

 

policy-map Shaping
class class-default
 shape average 100000

interface TenGigabitEthernet0/0/0
no ip address
channel-group 1 mode active

interface Port-channel1.10
encapsulation dot1Q 10
ip address 1.0.0.1 255.255.255.0
service-policy output Shaping

 

Шейпинг не срабатывает, полисинг тоже. Хост, подключенный к vlan 10, качает на полной скорости

Убираю Port-channel - шейпинг пашет.

ios роли не играет, пробовал на 03.09.02, 03.11.01 и т.д.

Edited by KonstantinC

Share this post


Link to post
Share on other sites

Так на портченеле и не будет работать.

Надо непосредственно на физические интерфейсы вешать, которые в группу входят.

Share this post


Link to post
Share on other sites

ограничение скорости через сабскрайбинг нормально работает на Po

Share this post


Link to post
Share on other sites

Да,

Так на портченеле и не будет работать.

Надо непосредственно на физические интерфейсы вешать, которые в группу входят.

На какие физические интерфейсы?

На портченеле куча сабинтерфейсов, на каких то надо ограничивать скорость, на каких то нет

 

 

ограничение скорости через сабскрайбинг нормально работает на Po

Да, isg сессии на том же port channel шейпятся как надо

Share this post


Link to post
Share on other sites

Да, про qos и port-channel читал на cisco.com

Но конкретной доки где было бы написано, что shaping на port-channel работать не будет не видел

 

На in не проверял.. не требуется там резать скорость

Share this post


Link to post
Share on other sites

да дальше нужно читать.

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/qos_mqc/configuration/xe-3s/asr1000/qos-mqc-xe-3s-asr1000-book/qos-mqc-xe-3s-asr1000-book_chapter_01011.html

 

The aggregate-type port-channel interfaces have the following limitations:

 

All the member links of a port channel must be of the same speed. This prevents a potential packet reordering issue. It is not supported to combine Gigabit Ethernet, Fast Ethernet, or Ethernet interfaces into the same port channel.

_10-Gigabit Ethernet is not supported._

 

QoS on an aggregate port-channel subinterface is not supported.

QoS on member links is not supported when an aggregate port-channel main interface is configured with QoS.

Share this post


Link to post
Share on other sites

zhenya`

Хм.. ну сам то port-channel пашет

 

QoS не поддерживается значит..

похоже и шейпинг тоже

Edited by KonstantinC

Share this post


Link to post
Share on other sites

А вот внутри любого vrf нет:

 

На cat 6500 поведение точно такое-же. Используют вот такой финт:

ip route vrf <vrf> <cust-ip> 255.255.255.255 <int> <cust-ip> 

.

В качестве шлюза указывается IP кастомера. Попробуйте.

Edited by Zarin

Share this post


Link to post
Share on other sites

Второй любопытный момент на ASR.

Маршрут для unnumbered интерфейса в global прописывается

 

interface Loopback100
ip address 1.1.1.1 255.255.255.0

interface Port-channel1.20
encapsulation dot1Q 20
 ip unnumbered Loopback100

ip route 1.1.1.2 255.255.255.255 port-channel 1.20

 

А вот внутри любого vrf нет:

interface Loopback100
ip vrf forwarding TestVRF
ip address 1.1.1.1 255.255.255.0

interface Port-channel1.20
encapsulation dot1Q 20
ip vrf forwarding TestVRF
ip unnumbered Loopback100

ip route vrf TestVRF 1.1.1.2 255.255.255.255 port-channel 1.20
[b]% For VPN or topology routes, must specify a next hop IP address if not a point-to-point interface[/b]

Share this post


Link to post
Share on other sites

В качестве шлюза указывается IP кастомера. Попробуйте.

Спасибо, коллега!

Действительно,

ip route vrf TestVRF 1.1.1.2 255.255.255.255 port-channel 1.20 1.1.1.2

прокатило

Share this post


Link to post
Share on other sites

дык.. там тема про кос ) а не в целом про портечнелы ) 10ые портченелы все ок. если смотреть show policy-map inter увидите, что оно suspended..

Share this post


Link to post
Share on other sites

Хм.. ну сам то port-channel пашет

 

QoS не поддерживается значит..

похоже и шейпинг тоже

port-channel load-balancing vlan-manual спасет отца русской демократии.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this