Jump to content
Калькуляторы

Cisco SCE 2020: не работает "dual link"

Раньше наш SCE 2020 3.8.0PP32 пропускал трафик через первый link: были задействованы гигабитные интерфейсы 1 (подписчики) и 2 (сеть).

Решили задействовать второй link и гигабитные интерфейсы 3 и 4, чтобы пустить через них еще немного подписчиков.

 

Подключили как в диаграмме "Figure 6-3 Cabling Diagram: Dual Link One SCE Platform Inline" из руководства Cisco SCE 2000 Installation and Configuration Guide

 

92787.jpg

 

В итоге у подписчиков, чей трафик пропускается через link 1 всё работает, а у подписчиков, чей трафик пропускается через link 2 не работает.

Прошу помощи, т.к. не можем понять в чём дело.

 

Пытались тестировать link 2: для чистоты теста подключили два ноутбука в интерфейсы link 2 (3 и 4), установили ноутбукам адреса 192.168.0.1/255.255.255.0 и 192.168.0.2/255.255.255.0, и "пустили пинг" друг на друга.

Ноутбуки не могут пинговать друг друга, но при этом их MAC-адреса имеются в ARP-таблицах обоих ноутбуков - т.е. link 2 пропускает ARP-запросы.

 

На всякий случай сделали "shutdown" - не помогло.

SCE2000(config)#>interface LineCard 0
SCE2000(config if)#>shutdown

 

Посмотрели "link to port mappings" - всё верно.

SCE2000#>show interface LineCard 0 link-to-port-mappings
Link Id     |   Upstream Port (Subscribers) |  Downstream Port (Network)
---------------------------------------------------------------------------
0           |               0/1             |               0/2             
1           |               0/3             |               0/4 

 

Наша конфигурация:

 

 

SCE2000(config)#>do show running-config
#This is a general configuration file (running-config).
#Created on 18:39:59  MSK  TUE  April  15  2014

#cli-type 1
#version 1

clock timezone MSK 4
access-list 1 permit x.x.x.x
no service telnetd
ip access-class 1
ip ssh    
no ip ssh SSHv1
no management-agent notifications notification-list 1417,1418,804,815,1404,1405,1406,1407,1408,400
no management-agent notifications notification-list 402,421,440,441,444,445,446,450,437,457
no management-agent notifications notification-list 3593,3594,3595,10040

interface LineCard 0
aggregative-global-controllers
aggregative-global-controller-dynamic mode suspend
aggregative-global-controller-dynamic mode active

connection-mode inline on-failure bypass
no silent 
shutdown  
flow-open-mode classical
service-bandwidth-prioritization-mode global
protocol-pack version 3.8.0PP32


flow-filter partition name "ignore_filter" first-rule 4 num-rules 32
flow-filter partition name "udpPortsToOpenBySw" first-rule 40 num-rules 21
no attack-filter protocol TCP
no attack-filter protocol UDP
no attack-filter protocol ICMP attack-direction single-side-both
no attack-filter protocol other attack-direction single-side-both
attack-filter subscriber-notification ports 80
replace spare-memory code bytes 3145728

interface FastEthernet 0/0
ip address x.x.x.x 255.255.255.0 

interface FastEthernet 0/1
ip address x.x.x.x 255.255.255.0 

interface GigabitEthernet 0/1

interface GigabitEthernet 0/2

interface GigabitEthernet 0/3

interface GigabitEthernet 0/4

exit      
ip default-gateway x.x.x.x

line vty 0 4
exit      
interface Mng 0/1
exit      
interface Mng 0/2
exit      
username sce secret 5 xxx
aaa authentication login default local 
aaa authentication enable default none 

interface LineCard 0
subscriber anonymous-group name "everybody" IP-range 0.0.0.0:0x00000000
exit      
no subscriber LEG dhcp-lease-query
subscriber LEG dhcp-lease-query servers 127.0.0.1
logger device SCE-agent-Statistics-Log max-file-size 204800
management-agent property "com.pcube.management.framework.install.activation.operation" "Install"
management-agent property "com.pcube.management.framework.install.activated.version" "3.5.5 build 262"
management-agent property "com.pcube.management.framework.install.activated.package" "SCA BB"
management-agent property "com.pcube.management.framework.install.activation.date" "xxx"
management-agent sce-api logging

 

 

Share this post


Link to post
Share on other sites

Сбросили конфигурацию:

SCE2000#>copy running-config startup-config
Writing general configuration file to temporary location...
Backing-up general configuration file...
Copy temporary file to final location...

SCE2000#>erase startup-config-all
Box will return to factory default state after reload, continue ? 
y                        
Please reload now.

SCE2000#>reload
Are you sure? y      
the system is about to reboot, this will end your CLI session

 

Как только SCE начал перезагружаться, то link2 тут же начал пропускать трафик - один из ноутбуков начал пинговаться.

Но "счастье" закончилось, как только SCE загрузился.

 

Текущая default конфигурация:

SCE2000#>show running-config
#This is a general configuration file (running-config).
#Created on 12:01:31  UTC  THU  April  17  2014

#cli-type 1
#version 1

no management-agent notifications notification-list 1417,1418,804,815,1404,1405,1406,1407,1408,400
no management-agent notifications notification-list 402,421,440,441,444,445,446,450,437,457
no management-agent notifications notification-list 3593,3594,3595,10040

interface LineCard 0

connection-mode inline on-failure bypass
no silent
no shutdown

interface FastEthernet 0/0
ip address x.x.x.x 255.255.255.0 

interface FastEthernet 0/1
ip address x.x.x.x 255.255.255.0 

interface GigabitEthernet 0/1

interface GigabitEthernet 0/2

interface GigabitEthernet 0/3

interface GigabitEthernet 0/4

exit      
ip default-gateway 10.1.2.254

line vty 0 4
exit      
interface Mng 0/1
exit      
interface Mng 0/2
exit      

no subscriber LEG dhcp-lease-query
subscriber LEG dhcp-lease-query servers 127.0.0.1
logger device SCE-agent-Statistics-Log max-file-size 204800

Share this post


Link to post
Share on other sites

В итоге построили стенд как на диаграмме, но вместо Subscriber'ов и Network'ов у нас ноутбуки, которые пингуют друг друга:

 

92799.jpg

 

Link 1 пропускает пинги, а Link 2 нет.

 

 

anix посоветовал активировать auto-negotiate на портах:

 

interface GigabitEthernet 0/1
auto-negotiate
interface GigabitEthernet 0/2
auto-negotiate
interface GigabitEthernet 0/3
auto-negotiate
interface GigabitEthernet 0/4
auto-negotiate

Но ничего не изменилось... :(

Share this post


Link to post
Share on other sites

что показывает show interface linecard 0 link mode и show interface linecard 0 connection-mode ?

попробуйте сказать conf t ; int line 0 ; link mode all-links forwarding

хотя, по умолчанию они все в "форвардинге".

Share this post


Link to post
Share on other sites

что показывает show interface linecard 0 link mode и show interface linecard 0 connection-mode ?

попробуйте сказать conf t ; int line 0 ; link mode all-links forwarding

хотя, по умолчанию они все в "форвардинге".

Да, уже в "форвардинге":

SCE2000#>show interface LineCard 0 link mode 
Link mode on GBE1-GBE2
Current link mode is           : forwarding
Actual  link mode on active is : forwarding
Actual  link mode on failure is: monopath-bypass

Link mode on GBE3-GBE4
Current link mode is           : forwarding
Actual  link mode on active is : forwarding
Actual  link mode on failure is: monopath-bypass

SCE2000#>show interface linecard 0 connection-mode
slot 0 connection mode
Connection mode is inline
slot failure mode is bypass
Redundancy status is standalone

Share this post


Link to post
Share on other sites

Вот наша конфига(хотя по умолчанию он должен пропускать через себя трафик).

SCE2000#show running-config
#This is a general configuration file (running-config).
#Created on 11:22:15  UTC  THU  April  24  2014

#cli-type 1
#version 1

ip ssh
no management-agent notifications notification-list 1417,1418,804,815,1404,1405,1406,1407,1408,400
no management-agent notifications notification-list 402,421,440,441,444,445,446,450,437,457
no management-agent notifications notification-list 3593,3594,3595,10040

interface LineCard 0
aggregative-global-controllers
aggregative-global-controller-dynamic mode suspend
aggregative-global-controller-dynamic mode active

connection-mode inline on-failure bypass
no silent
no shutdown
service-bandwidth-prioritization-mode global
protocol-pack version 3.7.5PP29


flow-filter partition name "ignore_filter" first-rule 4 num-rules 32
flow-filter partition name "udpPortsToOpenBySw" first-rule 40 num-rules 21
attack-filter subscriber-notification ports 80
replace spare-memory code bytes 3145728

interface FastEthernet 0/0
ip address 192.168.10.252 255.255.255.0

interface FastEthernet 0/1
ip address 192.168.10.252 255.255.255.0

interface GigabitEthernet 0/1
auto-negotiate

interface GigabitEthernet 0/2
auto-negotiate

interface GigabitEthernet 0/3
auto-negotiate

interface GigabitEthernet 0/4
auto-negotiate

exit
ip default-gateway 192.168.10.254

line vty 0 4
exit
interface Mng 0/1
exit
interface Mng 0/2
exit
username admin password cisco
aaa authentication login default none
aaa authentication enable default none

no subscriber LEG dhcp-lease-query
subscriber LEG dhcp-lease-query servers 127.0.0.1
logger device SCE-agent-Statistics-Log max-file-size 204800
management-agent property "com.pcube.management.framework.install.activation.operation" "Install"
management-agent property "com.pcube.management.framework.install.activated.package" "SCA BB"
management-agent property "com.pcube.management.framework.install.activated.version" "3.7.5 build 92"
management-agent property "com.pcube.management.framework.install.activation.date" "Mon Dec 17 16:44:01 UTC 2012"
SCE2000#

Share this post


Link to post
Share on other sites

Попробовали перепрошить с scos-v380-b127-sce2000-classic-k9.pkg, но и это не помогло.

Может кто-то подскажет, как определить используемую версию SEos? Используемый нами файл называется просто "SEOS". :)

 

Вот наша конфига(хотя по умолчанию он должен пропускать через себя трафик).

Благодарю! Чуть позже попробуем применить.

Share this post


Link to post
Share on other sites

Заметил, что у anix и BasilKlyev прошивка 3.7.x, а у нас 3.8.0.

Интересно, может ли быть дело в версии прошивки?

в соседней теме я выложил софт 4.1.0 но без Reporter'а

если репортер вам не нужен, попробуйте обновиться т.к. последние протокол паки сейчас будут только для софта 4.0.0 и 4.1.0

(п.с. тамже добрые люди выложили 4.0.0 софт, если нужен репортер)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this