Jump to content
Калькуляторы

VPN через второй Bridge

Два бриджа bridge-local и bridge-hds

Первый бридж local принимает интернет и сеть из первой сети и завязан на порты 1, 2, 3 второй бридж hds должен раздать pptp на порт ether4

 

Через порты 1, 2, 3 все работает, подключается VPN но через порт ether4 не получается

Проблема в том, что если привязать к ether4 мастер порт 2 или 3 то начинает раздаваться DHCP но все работает как надо, вот только DHCP мешает и это проблема

post-111351-035024000 1391185566_thumb.jpg

post-111351-098317200 1391185571_thumb.jpg

post-111351-073274500 1391185626_thumb.jpg

post-111351-035012900 1391185633_thumb.jpg

post-111351-095906400 1391185639_thumb.jpg

post-111351-018650600 1391185645_thumb.jpg

post-111351-039198300 1391185651_thumb.jpg

post-111351-072459400 1391185909_thumb.jpg

Share this post


Link to post
Share on other sites

Два бриджа bridge-local и bridge-hds

Первый бридж local принимает интернет и сеть из первой сети и завязан на порты 1, 2, 3 второй бридж hds должен раздать pptp на порт ether4

 

Через порты 1, 2, 3 все работает, подключается VPN но через порт ether4 не получается

Проблема в том, что если привязать к ether4 мастер порт 2 или 3 то начинает раздаваться DHCP но все работает как надо, вот только DHCP мешает и это проблема

1) Вот скажите, export compact сделать вам религия не позволяет?

2) Какой ip имеет 4 порт? Вереннн ваш бридж hds?

Share this post


Link to post
Share on other sites

1) Не умел делать экспорт конфигурации, спасибо научился

2) Затрудняюсь ответить, как на порт привязать IP

3) Вереннн ваш бридж hds, тоже сложно сказать

 

[admin@MikroTik] > /export compact
# jan/09/1970 20:56:54 by RouterOS 6.3
# software id = 41CT-0L4U
#
/interface bridge
add l2mtu=1598 name=bridge-hds protocol-mode=rstp
add l2mtu=1598 name=bridge-local protocol-mode=rstp
/interface ethernet
set 0 comment=WAN name=ether1-gateway
set 1 comment=LAN-TTK name=ether2-master-local
set 2 comment=LAN-TTK name=ether3-master-local
set 3 comment=LAN-HDS
/ip neighbor discovery
set ether1-gateway comment=WAN
set ether2-master-local comment=LAN-TTK
set ether3-master-local comment=LAN-TTK
set ether4 comment=LAN-HDS
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=43xx02DDxxA5 wpa2-pre-shared-key=43xx02DDxxA5
add authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=profile1 supplicant-identity="" unicast-ciphers=tkip,aes-ccm \
   wpa-pre-shared-key=xxxxxx wpa2-pre-shared-key=xxxxxx
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above default-authentication=no disabled=no distance=indoors frequency=2222 frequency-mode=superchannel ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=\
   ap-bridge periodic-calibration=enabled security-profile=profile1 wireless-protocol=802.11
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=dhcp_pool1 ranges=192.168.88.250-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge-local name=dhcp1
/ppp profile
add bridge=bridge-hds name=ppp_bridging use-encryption=yes
/queue simple
add max-limit=2M/2M name=queue1 target=ether3-master-local
/queue type
add kind=pcq name=PCQ-Download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64
add kind=pcq name=PCQ-Upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64
/queue simple
add disabled=yes max-limit=100M/100M name=Limit-all queue=PCQ-Upload/PCQ-Download target=bridge-local
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=ether3-master-local
add bridge=bridge-local interface=wlan1
add bridge=bridge-hds interface=ether4
/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 enabled=yes mrru=1600
/interface sstp-server server
set enabled=yes
/ip address
add address=192.168.88.1/24 interface=wlan1 network=192.168.88.0
add address=192.168.88.1/24 interface=bridge-local network=192.168.88.0
add address=192.168.88.1/24 disabled=yes interface=bridge-hds network=192.168.88.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1 netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-gateway to-addresses=0.0.0.0
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=2302 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=2302
add chain=dstnat dst-port=1723 protocol=tcp to-addresses=192.168.88.3 to-ports=0-65535
add chain=dstnat protocol=gre
/ip proxy
set enabled=yes
/ip route
add distance=1 dst-address=10.0.0.0/8 gateway=10.198.24.1
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge-local type=internal
add interface=ether1-gateway type=external
/ppp secret
add local-address=192.168.88.200 name=hds password=hds profile=ppp_bridging remote-address=192.168.88.201 service=pptp
/system leds
set 0 interface=wlan1
/tool graphing interface
add
/tool graphing queue
add
/tool graphing resource
add

Edited by Vitokhv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this