Jump to content
Калькуляторы

Проблема с Bridge

Добрый вечер. Есть CRS125-24G-1S-RM создавалась топология (см. рис)

Проблема в том что соединение: vlan 50 trunk -> CRS125-24G-1S-RM ->vlan 50 trunk

Для теста была сброшена конфигурация и попытка пропустить транзитом trunk 50.

/interface bridge
add l2mtu=1586 name=VLAN_50
/interface vlan
add interface=ether1 l2mtu=1586 name=VLAN_50_e1 vlan-id=50
add interface=ether2 l2mtu=1586 name=VLAN_50_e2 vlan-id=50
/interface bridge port
add bridge=VLAN_50 interface=VLAN_50_e1
add bridge=VLAN_50 interface=VLAN_50_e2

 

В результате устройства не видят друг друга через trunk.

Если повесить ip на bridge=VLAN_50, то пинги с CRS125-24G-1S-RM идут на подключенные устройства. Но связи устройств между собой нету.

Какие есть идеи? Что я упустил?

post-117690-026013700 1390495389_thumb.jpg

Edited by Akuny

Share this post


Link to post
Share on other sites

Что бы сделать трунк, нужно просто 2 физических порта объединить в бридж, при необходимости повесить на него IP. Если не нужно, что бы какие-то вланы шли через эту связку, фильтрами бриджа блокируете все вланы по выходному интерфейсу, а перед ними вставляете разрешающие правила для пропуска нужных.

Share this post


Link to post
Share on other sites

Что бы сделать трунк, нужно просто 2 физических порта объединить в бридж, при необходимости повесить на него IP. Если не нужно, что бы какие-то вланы шли через эту связку, фильтрами бриджа блокируете все вланы по выходному интерфейсу, а перед ними вставляете разрешающие правила для пропуска нужных.

Аналогично

/interface bridge
add l2mtu=1586 name=VLAN_50
/interface bridge port
add bridge=VLAN_50 interface=ether1
add bridge=VLAN_50 interface=ether2

Трафик не идет. (Device 1 (VLAN 50 tag) <-> eth1 Mikrotik eth2 <-> Device 2 (VLAN 50 tag))

При прямом соединении (Device 1 (VLAN 50 tag) <-> Device 2 (VLAN 50 tag)) все работает.

Куда копать?

Edited by Akuny

Share this post


Link to post
Share on other sites

А вы номера портов не путаете? Те что на картинке у вас обведены 50 вланом будут совсем не ether1 и ether2=)

Share this post


Link to post
Share on other sites
А вы номера портов не путаете? Те что на картинке у вас обведены 50 вланом будут совсем не ether1 и ether2=)

 

Для теста была сброшена конфигурация и попытка пропустить транзитом trunk 50.

 

Остальная конфигурация не вызывает проблем (сделано через Bridge), проблема именно транзите VLAN.

Для теста пытаюсь пропустить через eth1 и eth2 транзитом vlan 50 (trunk).

На CCR1036-12G-4S таким образом (через bridge) без проблем идет трафик транзитом. А на CRS125-24G-1S-RM - не идет.

Share this post


Link to post
Share on other sites

Все там идет. Для этого нужно сбросить конфигурацию полностью, объединить 2 порта в бридж. После чего пускаете влан в первый и он выходит из второго. Для проверки зайдите в свойства бриджа и нажмите кнопку Torch, поставьте все галочки и нажмите старт, должно показать вланы, которые идут по нему. Если не показывает, то заходите в свойства сетевого порта и там нажимайте.

Share this post


Link to post
Share on other sites

Все там идет. Для этого нужно сбросить конфигурацию полностью, объединить 2 порта в бридж. После чего пускаете влан в первый и он выходит из второго.

Не идет... Аппаратная проблема?

Share this post


Link to post
Share on other sites

Все там идет. Для этого нужно сбросить конфигурацию полностью, объединить 2 порта в бридж. После чего пускаете влан в первый и он выходит из второго.

Не идет... Аппаратная проблема?

 

Вы с помощью torch посмотрели, все ли доходит?

Share this post


Link to post
Share on other sites

torch на bridge ничего не показывает.

 

Обновил прошивку до 6.8rc1 - проблема решилась. Vlan транзитом нормально проходит через brigde.

Edited by Akuny

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this