Jump to content
Калькуляторы

Микротик - проблема ppp+nat Проблема с пропуском трафика

Есть микротик

CCR1036-12G-4S

 

1000 активных pppoe + pptp сессий

Шейпер через радиус атрибут "Mikrotik-Rate-Limit": значение примерно такие "1M 1536k 768k 8 8 1M"

NAT (не маскарадинг): src-nat

 

Интерфейсы

1.Wan

2.mkr_1

3.mkr_2

4.mkr_3

5.mkr_4

6.mkr_5

7.mkr_6

 

Порты Микротика подключены к каталисту, который имеет гигабитные порты.

 

На данный момент работает Linux (pptp+pppoe) в данный момент нагрузка на канал 250мбит,

 

перевожу клиентов на микротик, и наблюдаем, что на WAN-порт больше 98Мбит не поднимается.

Что-то нужно сделать?

Share this post


Link to post
Share on other sites

Проверить, нет ли затыка на самом сетевом порту?

 

Проверял "Bandwidth test", максимальная скорость 660 Мбит, напрямую и через каталист.

 

А что значит "Затык"?

На WAN-интерфейсе

Queue type = only-hardware-queue

 

куда еще смотреть не прелставляю

Share this post


Link to post
Share on other sites

Надо export compact сделать и посмотреть, нет ли проблем в конфиге. Возможно попадает под шейпер сетевой порт по ошибке.

Share this post


Link to post
Share on other sites

Надо export compact сделать и посмотреть, нет ли проблем в конфиге. Возможно попадает под шейпер сетевой порт по ошибке.

 

/queue tree

add name=Total_download parent="2. WAN" priority=1

add name=Total_upload parent="2. WAN" priority=1

 

Это может влиять?

Просто это то, что я явно не делал.

Share this post


Link to post
Share on other sites

Удалите это оттуда, а так же поищите маркировки трафика касательно этого WAN порта. Т.к. если используете дерево очередей, то и парентом должен быть внутренний интерфейс, а так он может попасть под общее ограничение дерева. Если деревья не используйте, то весь мусор удалите.Если конфигурация разрабатывалась кем-то другим, можно для теста просто эти правила отключить.

Share this post


Link to post
Share on other sites

Сбросил конфигурацию, настроил все с нуля.

Но результата не дало.

 

Выбрал момент для переключения.

Все равно все также, Выше 100Мбит не поднимается

Share this post


Link to post
Share on other sites

Есть несколько ключевых моментов

src-nat или маскарад?

 

add action=src-nat chain=srcnat src-address=172.26.0.0/18 src-address-list="" to-addresses=1.1.1.1

 

1.1.1.1 - это ip-реальник

Share this post


Link to post
Share on other sites

Зачем адрес реальника указывать? Все будет и без него работать. Если несколько каналов то нужно маршрутами разруливать.

Share this post


Link to post
Share on other sites

Зачем адрес реальника указывать? Все будет и без него работать. Если несколько каналов то нужно маршрутами разруливать.

а что тогда указывать? интерфейс?

Share this post


Link to post
Share on other sites

Зачем адрес реальника указывать? Все будет и без него работать. Если несколько каналов то нужно маршрутами разруливать.

а что тогда указывать? интерфейс?

 

Ничего не указывать. Вы уже указали адреса, с которых возможен доступ в интернет.

Share this post


Link to post
Share on other sites

Я нигде не указывал где доступ в интернет, или вы имеете ввиду основной маршрут?

 

Без указания адреса не получается создать правило

 

add action=src-nat chain=srcnat src-address=172.26.0.0/18 src-address-list="" to-addresses=1.1.1.1

Edited by u.s.s.r

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this