Jump to content
Калькуляторы

cross lane card LACP LAG on Cisco Catalyst 6500 series switches

Добрый день,

 

Возник вопрос поддерживает ли cat65 LACP линк агрегацию меж несколькими одинаковыми моделями lane cards?

 

Спасибо за ответ!

Share this post


Link to post
Share on other sites

да.

 

Делается так же как и обычный лацп.

Edited by myst

Share this post


Link to post
Share on other sites

А разве получится на !dcef картах настроить разную балансировку?

Share this post


Link to post
Share on other sites

да.

 

Делается так же как и обычный лацп.

 

а с разными? имеется ввиду с одинаковой link speed, но разным phys media, аля 1GbE copper и spf?

Share this post


Link to post
Share on other sites

да.

 

Делается так же как и обычный лацп.

 

а с разными? имеется ввиду с одинаковой link speed, но разным phys media, аля 1GbE copper и spf?

 

Честно говоря не пробовал. Но не вижу причин почему нет.

На этой недели могу воткнуть-проверить.

Share this post


Link to post
Share on other sites

Не получится. Должен быть 1 type

 

хмм надо проверить, а с чем это связано? я например никаких причин не вижу чтоб лацп не работал.

Share this post


Link to post
Share on other sites

Он ругается что разный media type и не дает добавить rj45 и sfp порты в 1 lacp

Share this post


Link to post
Share on other sites

моменто

6509_sw#sh run int port-channel 11
Building configuration...

Current configuration : 163 bytes
!
interface Port-channel11
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
spanning-tree portfast edge
end

6509_sw#sh run interface GigabitEthernet6/8
Building configuration...

Current configuration : 174 bytes
!
interface GigabitEthernet6/8
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
channel-group 11 mode active
end

6509_sw#sh run interface GigabitEthernet6/9
Building configuration...

Current configuration : 174 bytes
!
interface GigabitEthernet6/9
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
channel-group 11 mode active
end

6509_sw#sh  interface GigabitEthernet6/9   
GigabitEthernet6/9 is administratively down, line protocol is down (disabled)
 Hardware is C6k 1000Mb 802.3, address is 0011.5ce1.d45c (bia 0011.5ce1.d45c)
 Description: # PO-11 #
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Auto-duplex, Auto-speed, media type is 10/100/1000BaseT
 input flow-control is off, output flow-control is off
 Clock mode is auto
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles 
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
6509_sw#sh  interface GigabitEthernet6/8
GigabitEthernet6/8 is administratively down, line protocol is down (disabled)
 Hardware is C6k 1000Mb 802.3, address is 0011.5ce1.d45b (bia 0011.5ce1.d45b)
 Description: # PO-11 #
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Auto-duplex, Auto-speed
 input flow-control is off, output flow-control is off
 Clock mode is auto
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles 
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

 

6509_sw#sh module | i Sup
 5    9  Supervisor Engine 32 8GE (Active)      WS-SUP32-GE-3B     SAL1010FE6Y
 6    9  Supervisor Engine 32 8GE (Hot)         WS-SUP32-GE-3B     SAD09250CEB

 

SUP32 - если вы помните там 8 SFP портов, 9й - медный.

Edited by myst

Share this post


Link to post
Share on other sites

А есть возможность поднять на нём линки? Просто помоему в этот момент она начинает ругаться.

Share this post


Link to post
Share on other sites

Переделал на активный SUP, сделал no shut и порт-ченнелу и физическим портам (воткнуть правда некуда)... ничего не ругалось.

 

Физически порты некуда воткнуть, свободного оптического кабелька нет под рукой.

Edited by myst

Share this post


Link to post
Share on other sites

моменто

6509_sw#sh run int port-channel 11
Building configuration...

Current configuration : 163 bytes
!
interface Port-channel11
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
spanning-tree portfast edge
end

6509_sw#sh run interface GigabitEthernet6/8
Building configuration...

Current configuration : 174 bytes
!
interface GigabitEthernet6/8
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
channel-group 11 mode active
end

6509_sw#sh run interface GigabitEthernet6/9
Building configuration...

Current configuration : 174 bytes
!
interface GigabitEthernet6/9
description # PO-11 #
switchport
switchport access vlan 100
switchport mode access
shutdown
channel-group 11 mode active
end

6509_sw#sh  interface GigabitEthernet6/9   
GigabitEthernet6/9 is administratively down, line protocol is down (disabled)
 Hardware is C6k 1000Mb 802.3, address is 0011.5ce1.d45c (bia 0011.5ce1.d45c)
 Description: # PO-11 #
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Auto-duplex, Auto-speed, media type is 10/100/1000BaseT
 input flow-control is off, output flow-control is off
 Clock mode is auto
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles 
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
6509_sw#sh  interface GigabitEthernet6/8
GigabitEthernet6/8 is administratively down, line protocol is down (disabled)
 Hardware is C6k 1000Mb 802.3, address is 0011.5ce1.d45b (bia 0011.5ce1.d45b)
 Description: # PO-11 #
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Auto-duplex, Auto-speed
 input flow-control is off, output flow-control is off
 Clock mode is auto
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles 
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

 

6509_sw#sh module | i Sup
 5    9  Supervisor Engine 32 8GE (Active)      WS-SUP32-GE-3B     SAL1010FE6Y
 6    9  Supervisor Engine 32 8GE (Hot)         WS-SUP32-GE-3B     SAD09250CEB

 

SUP32 - если вы помните там 8 SFP портов, 9й - медный.

 

 

вопрос именно о cross lane card LAG, на портах одной lane card или на самом супервизоре все работает :)

Share this post


Link to post
Share on other sites

вопрос именно о cross lane card LAG, на портах одной lane card или на самом супервизоре все работает :)

 

В общем: etherchannel работает на портах с любых карт с одинаковыми параметрами: размером буферов и очередями QOS

пример : Etherchannel из портов с активного и hot sup

пример : Etherchannel из портов 6416 в разных слотах

 

Ранее не работало, если размер буферов на картах различался (пример - попытка обьединения портов с 6416 и 6516а)

Но в последних IOS вроде заработал etherchannel между портами разных карт (sup32 и 6416), но не подтвержу.

Share this post


Link to post
Share on other sites

вопрос именно о cross lane card LAG, на портах одной lane card или на самом супервизоре все работает :)

Ну и cross точно так же работает. Вот на разных карточках проверить не могу ибо у меня все одинаковые.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this