Jump to content
Калькуляторы

bgp mikrotik+cisco

прошу помочь разобраться с небольшой проблемой распространения маршрутов.

 

имеется сеть, топология звезда. (номера AS изменены) в центре - cisco с BPG (AS 65000), к ней оптоволоконными каналами подключены клиентские роутеры на базе RB450 (AS 10800-11000)

Роутеры передают маршруты cisco, cisco передает маршруты всем остальным роутерам, кроме отправителя. Проблематика в следующем - часть роутеров видит маршруты "прозрачно", а часть - через cisco. Соответственно - лишний трафик через интерфейс.

 

 

Маршруты через cisco.

 

13 ADb  10.210.3.0/24                      10.254.203.2             20
14 ADb  10.210.4.0/24                      10.254.203.2             20
15 ADb  10.210.5.0/24                      10.254.203.2             20

 

Маршруты напрямую:

6 ADb  10.210.3.0/24                      10.254.235.18           20
7 ADb  10.210.4.0/24                      10.254.235.56           20
8 ADb  10.210.5.0/24                      10.254.235.11           20

 

Типичная настройка bgp для RB. Одинакова почти для всех маршрутизаторов.

/routing bgp instance
add as=10921 client-to-client-reflection=no disabled=no ignore-as-path-len=no name=ANY out-filter="" \
   redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes \
   router-id=10.254.203.29 routing-table=""
/routing bgp peer
add address-families=ip as-override=yes default-originate=never disabled=yes hold-time=15s in-filter=cisco_second_in instance=\
   ANY multihop=no name=cisco_second nexthop-choice=default out-filter=cisco_second passive=no remote-address=10.254.203.2 \
   remote-as=65000 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default use-bfd=no

 

 

Выдержка из конфига cisco

router bgp 65000
bgp router-id 10.204.203.2
bgp log-neighbor-changes
neighbor 10.204.203.201 remote-as 10888
neighbor 10.204.203.18 remote-as 10900
neighbor 10.204.203.56 remote-as 10897
neighbor 10.204.203.8 remote-as 10930
neighbor 10.204.203.11 remote-as 10959
neighbor 10.204.203.17 remote-as 10900
neighbor 10.204.203.21 remote-as 10970
neighbor 10.204.203.29 remote-as 10909
!
address-family ipv4
 no synchronization
 bgp redistribute-internal
 network 90.2xxxxx.0 mask 255.255.255.0
 network 90.2xxxxx.0 mask 255.255.255.0
 neighbor 10.204.200.201 activate
 neighbor 10.204.200.201 default-originate
 neighbor 10.204.200.201 distribute-list incom in
 neighbor 10.204.200.201 distribute-list incom_out out
 neighbor 10.204.203.18 activate
 neighbor 10.204.203.18 default-originate
 neighbor 10.204.203.18 distribute-list incom in
 neighbor 10.204.203.18 distribute-list incom_out out
 neighbor 10.204.203.56 activate
 neighbor 10.204.203.56 default-originate
 neighbor 10.204.203.56 distribute-list incom in
 neighbor 10.204.203.56 distribute-list incom_out out
 neighbor 10.204.203.8 activate
 neighbor 10.204.203.8 default-originate
 neighbor 10.204.203.8 distribute-list incom in
 neighbor 10.204.203.8 distribute-list incom_out out
 neighbor 10.204.203.11 activate
 neighbor 10.204.203.11 default-originate
 neighbor 10.204.203.11 distribute-list incom in
 neighbor 10.204.203.11 distribute-list incom_out out
 neighbor 10.204.203.17 activate
 neighbor 10.204.203.17 default-originate
 neighbor 10.204.203.17 distribute-list incom in
 neighbor 10.204.203.17 distribute-list incom_out out
 neighbor 10.204.203.21 activate
 neighbor 10.204.203.21 default-originate
 neighbor 10.204.203.21 distribute-list incom in
 neighbor 10.204.203.21 distribute-list incom_out out
 neighbor 10.204.203.29 activate
 neighbor 10.204.203.29 default-originate
 neighbor 10.204.203.29 distribute-list incom in

Share this post


Link to post
Share on other sites

Зачем bgp redistribute-internal ?

 

Какой еще IGP протокол используется? Как соеденены роутеры? Что в фильтр листах?

 

Вы привели пример конфига клиентского роутера с as=10921, которого даже нет в конфиге центральной циски. Думаете телепаты буду искать за вас ошибку в конфиге, который вы не напечатали?

Share this post


Link to post
Share on other sites

Зачем bgp redistribute-internal ?

на cisco есть OSPF, пережиток старого. redistribute используется для предачи маршрутов между протоколами.

 

Роутеры соединены оптикой, адресное пространство одно, друг с другом напрямую обмениваться информацией могут.

 

В фильтр листах ровным счеттом ничего, что могло бы заинтересовать, просто фильтрация 192.168. и им подобных сетей.(правила deny и permit для подсетей). На микротиках в фильтрах тоже ничего

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this