Jump to content
Калькуляторы

замена dual wan router: 2xRouterBOARD + ospf

Положим домой заведено 2 провайдера, один быстрый и используется как основной, второй медленный и резервный. Оба провайдера для доступа к Internet применяют VPN.

Маршрутизатор с 2мя и более wan портами с нормальной производительность можно купить где начиная от 11к рублей (dfl-260e например). При этом от маршрутизатора требуется просто переключиться на резервного провайдера на другой в случае выхода из строя основного. Возникла следующая схема

 

t35NVXDg.png

 

На RB750gl dhcp clinet принудительно задается метрика >110

Если l2tp соединение отключается, то для rb750gl шлюзом по умолчанию становиться RB751U-2HnD

 

Можно добавить vrrp на случай выхода из строя одного из маршрутизаторов

Всякие netbook и прочую портативную технику можно заставить ходить через более медленного провайдера при помощи Policy Base Routing

 

Настройки OSPF

 

[admin@MikroTik750GL] > /routing ospf export

# jul/21/2012 14:36:46 by RouterOS 5.2

#

/routing ospf instance

set default disabled=no distribute-default=if-installed-as-type-1 in-filter=\

ospf-in metric-bgp=auto metric-connected=20 metric-default=1 \

metric-other-ospf=auto metric-rip=20 metric-static=20 name=default \

out-filter=ospf-out redistribute-bgp=no redistribute-connected=as-type-1 \

redistribute-other-ospf=no redistribute-rip=no redistribute-static=\

as-type-1 router-id=192.168.88.1

/routing ospf area

set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\

default

add area-id=0.0.0.88 disabled=no instance=default name=home type=default

/routing ospf network

add area=backbone disabled=no network=0.0.0.0/32

add area=home disabled=no network=192.168.88.0/24

[admin@MikroTikRB751U-2HnD] > /routing ospf export

# jul/21/2012 10:35:03 by RouterOS 5.18

#

/routing ospf instance

set [ find default=yes ] disabled=no distribute-default=if-installed-as-type-1 \

in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 \

metric-other-ospf=auto metric-rip=20 metric-static=20 name=default \

out-filter=ospf-out redistribute-bgp=no redistribute-connected=as-type-1 \

redistribute-other-ospf=no redistribute-rip=no redistribute-static=\

as-type-1 router-id=192.168.88.2

/routing ospf area

set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=\

backbone type=default

add area-id=0.0.0.88 disabled=no instance=default name=home type=default

/routing ospf network

add area=home disabled=no network=192.168.88.0/24

add area=backbone disabled=no network=0.0.0.0/32

Share this post


Link to post
Share on other sites

Я так скромно предполагаю, что тут можно использовать 2 штуки RB750GL ?

(на один RB750GL надо повесить два компа и не более)

Share this post


Link to post
Share on other sites

Да можно и RB751U-2HnD использовать, там вайфай есть.

 

А в верхней схеме можно было одним микротиком обойтись и поднять на нем сразу 2 PPP соединения.

Share this post


Link to post
Share on other sites

А в верхней схеме можно было одним микротиком обойтись и поднять на нем сразу 2 PPP соединения.

 

ЗдОрово! WiFi ненужен, не подскажите где про 2 PPP на борту можно пример посмотреть ?

 

Один L2TP уже работает, я так предполагаю надо из 5го master local(например) сделать 2 Gateway(Только что при этом поменять...?)? И его указать во втором PPP соединении.

 

Да, собственно смысл этой схемы - переход на резервный канал и обратно при отсутствии одного из них. Как тут быть ?

Edited by Diman_xxxx

Share this post


Link to post
Share on other sites

Мастер порт - вы начальную конфигурацию не сбросили. Нужно сбросить, настроить первый порт на первого провайдера, второй на второго. Создать 2 PPP соединения (возможно придется прописать Routing Mark для того что бы соединения через нужные каналы пошли), далее уже рулить метриками для указания основного канала.

 

Остальные порты объединяете в бридж и делаете на нем нат и DHCP.

Share this post


Link to post
Share on other sites

Мастер порт - вы начальную конфигурацию не сбросили. Нужно сбросить, настроить первый порт на первого провайдера, второй на второго. Создать 2 PPP соединения (возможно придется прописать Routing Mark для того что бы соединения через нужные каналы пошли), далее уже рулить метриками для указания основного канала.

 

Остальные порты объединяете в бридж и делаете на нем нат и DHCP.

 

Спасибо.

А сбрасывать обязательно?

В начальной кфг 2-5 порты объединены в бридж? (считал что в бридже только 2 порта)

Share this post


Link to post
Share on other sites

Они объединены не в бридж, там настроен мастер порт и работает по подобию коммутатора. Я вам в личку скинул информацию по настройке.

 

 

Share this post


Link to post
Share on other sites
А в верхней схеме можно было одним микротиком обойтись и поднять на нем сразу 2 PPP соединения.

тогда vrrp не прекрутиш

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this