Перейти к содержимому
Калькуляторы

Mikrotik проблема с инжектированием маршрутов

Имеется следующая схема:

aa2e865ce99508553a7965d5d35e6b2e.png

 

2 Area соеденены 0 через IPIP туннели.

 

RA-RB RA1 - RB1 - RB1100AHx2 (5.14)

RC1 - cisco 3550

RC - cisco 4948

На каждый микротик заведен разный провайдер.

 

Конфигурация OSPF:

 

RA:

> routing ospf area print detail

Flags: X - disabled, I - invalid, * - default 
0  * name="backbone" instance=default type=default area-id=0.0.0.0 

1    name="VL" instance=VL type=default area-id=10.0.1.0

===================================

 

> routing ospf interface print detail

Flags: X - disabled, I - inactive, D - dynamic, P - passive 
0    interface=vlan_66_mgm cost=10 priority=255 authentication=none authentication-key="" authentication-key-id=1 network-type=broadcast instance-id=0 retransmit-interval=5s transmit-delay=1s 
     hello-interval=5s dead-interval=10s use-bfd=no 

2    interface=ether2 cost=10 priority=255 authentication=none authentication-key="" authentication-key-id=1 network-type=broadcast instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=5s 
     dead-interval=10s use-bfd=yes 

5    interface=ipip_vladlink_msk00_mastertel cost=40 priority=255 authentication=md5 authentication-key="109" authentication-key-id=1 network-type=point-to-point instance-id=0 retransmit-interval=5s 
     transmit-delay=1s hello-interval=5s dead-interval=10s use-bfd=no 

 

==================================

 

> routing ospf instance print detail

Flags: X - disabled, * - default 
0  * name="default" router-id=255.255.255.1 distribute-default=never redistribute-connected=no redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=as-type-2 metric-default=1 
     metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in out-filter=DNS-OUT 

1    name="VL" router-id=200.0.3.1 distribute-default=if-installed-as-type-1 redistribute-connected=no redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=as-type-1 
     metric-default=2 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=auto metric-other-ospf=auto in-filter="" out-filter=""   

================================

 

> routing ospf network print detail

Flags: X - disabled, I - invalid 
0   network=172.20.3.96/30 area=VL (Transit MT-Cisco vlan_66)   

2   network=172.20.3.104/30 area=VL (Transit MT-MT ether2)

5   ;;; Backbone Network MSK
    network=172.23.0.0/30 area=backbone

 

================================

 

> routing filter print detail

Flags: X - disabled 
0   chain=DNS-OUT prefix=10.0.0.0/19 invert-match=no action=accept set-bgp-prepend-path="" 

1   chain=DNS-OUT prefix=172.20.0.0/19 invert-match=no action=accept set-bgp-prepend-path="" 

2   chain=DNS-OUT invert-match=no action=discard set-bgp-prepend-path="" 

 

 

Cisco 4948

 

interface Vlan66

description # MGM 1 VLAN #

ip address 172.20.3.98 255.255.255.252

ip ospf cost 10

ip ospf hello-interval 5

ip ospf dead-interval 10

ip ospf priority 50

!

interface Vlan67

description # MGM 2 VLAN #

ip address 172.20.3.102 255.255.255.252

ip ospf cost 10

ip ospf hello-interval 5

ip ospf dead-interval 10

ip ospf priority 50

!

router ospf 100

router-id 172.20.3.98

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 172.20.3.96 0.0.0.3 area 10.0.1.0

network 172.20.3.100 0.0.0.3 area 10.0.1.0

 

ip route 10.0.0.0 255.255.224.0 Null0 254

ip route 172.20.0.0 255.255.224.0 Null0 254

 

 

На остальных роутерах совершенно симметричная конфигурация (ну фильтры с другой стороны обратные и RID AID итд разные).

При поднятии обоих интерфейсов наблюдается крайне странная картина на микротиках:

 

На RA:

> ip route print detail
29 ADo  dst-address=10.3.0.0/19 gateway=172.23.0.2 gateway-status=172.23.0.2 reachable via  ipip_vladlink_msk00_mastertel distance=110 scope=20 target-scope=10 ospf-metric=50 ospf-type=external-type-1
88 ADo  dst-address=172.23.0.0/19 gateway=172.23.0.2 gateway-status=172.23.0.2 reachable via  ipip_vladlink_msk00_mastertel distance=110 scope=20 target-scope=10 ospf-metric=50 ospf-type=external-type-1 

 

==========================================

 

> routing ospf print detail

27 instance=VL dst-address=10.3.0.0/19 state=imported-ext-1 gateway="" interface="" cost=50 area=external
82 instance=VL dst-address=172.23.0.0/19 state=imported-ext-1 gateway="" interface="" cost=50 area=external
94 instance=default dst-address=10.3.0.0/19 state=ext-1 gateway=172.23.0.2 interface=ipip_vladlink_msk00_mastertel cost=50 area=external
98 instance=default dst-address=172.23.0.0/19 state=ext-1 gateway=172.23.0.2 interface=ipip_vladlink_msk00_mastertel cost=50 area=external 
99 instance=default dst-address=172.23.0.0/30 state=intra-area gateway=0.0.0.0 interface=ipip_vladlink_msk00_mastertel cost=40 area=backbon

e

 

На RB (Происходит свершенно не понятное для меня):

> ip route print detail

29 ADo  dst-address=10.3.0.0/19 gateway=172.20.3.105 gateway-status=172.20.3.105 reachable via  ether2 distance=110 scope=20 target-scope=10 ospf-metric=60 ospf-type=external-type-1 
30  Do  dst-address=10.3.0.0/19 gateway=172.23.0.6 gateway-status=172.23.0.6 reachable via  ipip_vladlink_temp_msk00_centertel distance=110 scope=20 target-scope=10 ospf-metric=20 ospf-type=external-type-1 
89 ADo  dst-address=172.23.0.0/19 gateway=172.23.0.6 gateway-status=172.23.0.6 reachable via  ipip_vladlink_temp_msk00_centertel distance=110 scope=20 target-scope=10 ospf-metric=20 ospf-type=external-type-1

 

==========================================

 

> routing ospf print detail

34 instance=VL dst-address=10.3.0.0/19 state=ext-1 gateway=172.20.3.105 interface=ether2 cost=60 area=external 
89 instance=VL dst-address=172.23.0.0/19 state=imported-ext-1 gateway="" interface="" cost=20 area=external
1 instance=default dst-address=10.3.0.0/19 state=ext-1 gateway=172.23.0.6 interface=ipip_vladlink_temp_msk00_centertel cost=20 area=external
5 instance=default dst-address=172.23.0.0/19 state=ext-1 gateway=172.23.0.6 interface=ipip_vladlink_temp_msk00_centertel cost=20 area=external  

 

1) Тоесть, роутер получает маршрут до 10.3.0.0 от 2х источников, через TunB и импортированный через ether2 от RA. Первый маршрут cost=20, второй маршрут с cost=60

но инсталирует в таблицу маршрутизации оба этих маршрутов с одинаковым distance причем пакеты до 10.3.0.0 упорно улетают через ether 2 а не через connected интерфейс.

 

2) По каким то невероятным причинам маршрут до 172.23.0.0 указан с cost=20 в instance=VL

 

Пытался так же во внутреннюю эрию инжектировать metric-other-ospf=40 с RA и metric-other-ospf=10 с RB, ситуация аналогичная.

 

Коллеги, есть мысль куда думать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас